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Chapter 1: Introduction

ABOUT CALIBERRM

CaliberRM is a powerful, state-of-the-art requirements management system that 
enables project teams to deliver higher quality applications that meet end-user 
specifications. CaliberRM enables teams to fully define, manage and communicate 
changing requirements. Changes to requirement data are recorded and stored in 
CaliberRM’s database, providing reliable and up-to-date information for effective 
requirements-based application development and testing. 

CaliberRM is comprised of the components listed below. 

Component Description

CaliberRM Requirements Management System

Framework Administrator Controls administrative functions for CaliberRM projects

Document Factory Generates customized documents from user-defined 
templates

Requirement Viewer Provides a detailed view of a requirement without launching 
the full product

StarTeam Toolbar Launches CaliberRM, Framework Administrator and 
Document Factory from the system tray

RM Import Utility Imports a project from a file previously created by the 
CaliberRM Export utility

RM Export Utility Exports a project from CaliberRM into an ASCII file, which 
may then be imported to another application

Diagnostic Tool Provides current status information to aid in troubleshooting

Help Help files for Framework Administrator, CaliberRM Client and 
Web Client
About CaliberRM � 1
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The two main components of CaliberRM are the Framework Administrator and 
CaliberRM. The Framework Administrator is the component that maintains 
administrative information, such as users and groups. CaliberRM is the requirement 
management component that administers projects, requirements and other 
CaliberRM custom utilities. Additionally, there are several integrated third-party 
products that, as a whole, provide a complete solution to application lifecycle 
management, from developing requirements to testing the application. 

WHAT’S NEW IN THIS VERSION

The following table provides information on the new features and enhancements in 
this version.

Feature Description Detail

ationalization CaliberRM now supports the 
Unicode character sets.

•  Through the support of Unicode character s
CaliberRM now provides character fidelity 
regardless of language. CaliberRM custome
can now manage requirements in any 
language.

ronic Signature 
aselines

Allows authorized users to sign 
a baseline.

•  Delivered in response to requests from 
customers in regulated industries, as well a
those with rigorous internal process audits.

•  The electronic simulation of a “sign off shee
that can be used for multiple purposes, larg
related to the approval of a set of requireme
prior to development work taking place.

•  Baseline administrators are created to man
baseline signatures.
2 � What’s New in this Version  
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Feature Description Detail

line 
inistration

New level of administrators 
called Baseline Administrators 
added.

•  Baseline administrators are created on the 
user’s Password tab in the Framework 
Administrator.

•  Baseline Administrators are created to man
all aspects of baseline maintenance. Caliber
Administrators no longer have baseline 
maintenance capabilities.

•  When a baseline is selected in CaliberRM, 
baseline description is displayed below the 
project description.

ved Project, 
p & User 
gement

Project membership is kept 
synchronized with group 
membership.

•  If you add a new user to a group in a projec
that user is assigned to all projects that con
the group. The same rule applies when 
removing a user from a group.

 Disable Administrators can limit the 
number of times a user can 
attempt to login.

•  After a certain number of unsuccessful login
attempts, a user’s account is disabled until 
contacting the administrator.

t Installation CaliberRM now supports silent 
or unattended client 
installations.

•  The CaliberRM client installation program n
supports silent client installations and 
upgrades.

eam Message 
er (MPX)

Allows you to publish 
information about MPX events, 
such as creating a 
requirement.

•  Requirement additions appear in the user’s
requirement tree even if the parent node ha
already been expanded.

•  Requirement deletions are removed from th
user’s requirement tree even if the parent n
has already been expanded.

•  Clients cache requirement data as it is retrie
from the server, the next time those 
requirements are selected, they are retriev
from local cache. If a requirement is chang
by someone else, the client retrieves the la
data from the server.

•  If the StarTeam Message Broker is not used
o CaliberRM will function without any issu
o you can refresh the project to see 

requirements that are added or deleted.
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TECHNICAL ENHANCEMENTS

The following table provides information on the new technical enhancements in 
this version.

Feature Description Detail

ort for 
ury’s 
irector 

ains in 7.6 and 

The integration supports 
creating traces to tests in 
domains.

•  Mercury Interactive added domains to 
TestDirector as a way to further manage tes
projects. CaliberRM now supports those 
domains.

ration with 
soft’s Visual 
o .NET

Allows you to view 
requirements in the context of 
the development environment.

•  Delivers live requirement information directl
within the IDE.

•  Requirements data can be tailored specifica
to enable you to work with only those 
requirements that are important to you. 

Enhancement Description

Integrations The location of the CaliberRM executable is 
stored in the registry for any integration to use. 
The path is 
HKEY_LOCAL_MACHINE\Software\Borland\
CaliberRM.

Together integration The Together vendor add-in .dll file is installed 
in the CaliberRM directory.

New installs Default paths have been updated to reflect the 
Borland name. Default installation paths are 
now located at c:/Program Files/Borland. In 
addition, the CaliberRM program icon is now 
the new Borland suite icon. The requirement 
icon has not changed.
4 � Technical Enhancements  
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CALIBERRM DOCUMENTATION

This package includes several forms of information to help you learn CaliberRM. 

The User Guide contains complete details about using CaliberRM.

The Installation Guide contains system requirements and instructions on how to 
install Framework Administrator, CaliberRM, Spell Checker dictionaries, Web 
components, CaliberRM Datamart & Datamart Explorer, and Network Install and 
Upgrade.

The Help System contains all the information in the User Guide, optimized for use 
online. 

Sample Templates help you create your own templates for Document Factory.

Sample Databases allow you to log on to CaliberRM and learn its features and 
functions in a non-production environment.

Enhancement Description

Help > About The server name and IP address a client is 
logged onto have been added to the Help > 
About > Additional Info menu in the 
Framework Administrator and CaliberRM 
clients. 

CaliberRM SDK versioning The CaliberRM SDK version number is now 
synchronized with the CaliberRM version 
number.

Project Refresh You can refresh a project using the F5 key in 
the Windows client while maintaining focus on 
the item that is selected.

Glossary Enhancement You can hover over a glossary term to see the 
definition in a balloon tip. Note: The display 
may cut off after 256 characters.

User-Defined Attribute 
Enhancement

You can hover over a UDA label to see its 
description. 
CaliberRM Documentation � 5
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The CaliberRM Tutorial is a condensed version of the User Guide, designed to get 
users started quickly in CaliberRM.

CaliberRM White Papers provide information on CaliberRM integrations and how 
to use them.

ABOUT THIS MANUAL

This manual provides detailed information about the CaliberRM tools and features 
and is intended for use as a reference in everyday work. The chapters are presented 
in an order that helps the new user understand the Framework Administrator and 
CaliberRM quickly; starting with basic functionality and progressing to more 
advanced features. This manual contains the following sections:

• Administrator Section: This section describes the user interface, tools and 
features of the Framework Administrator module. This section is comprised of 
Chapters 1-8.

• CaliberRM Administrator Section: This section describes the administrative 
commands of the CaliberRM Client module. This section is comprised of 
Chapters 9-11.

• CaliberRM User Section: This section describes the CaliberRM user interface 
and describes the commands, tools and utilities available to a CaliberRM non-
administrative user. This section is comprised of Chapters 12-28.

• Appendices: This section contains additional supplemental information.

• Glossary: This section contains a brief description of terms used in the 
Framework Administrator and CaliberRM systems.

CaliberRM documentation assumes you have a working knowledge of Microsoft 
Windows NT4 or 2000 operating system and its conventions, including standard 
menus and commands. If you are new to Windows, you can get help with these 
techniques by accessing Microsoft Windows Help. To get help, choose
Start > Help from the Start menu on the Windows desktop.
6 � About this Manual  
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CONVENTIONS USED IN THIS MANUAL

This manual uses the following typographical conventions and notations:

BORLAND SUPPORT

Borland offers a variety of support options. These include free services on the 
Internet, where you can search our extensive information base and connect with 
other users of Borland products. In addition, you can choose from several 
categories of support, ranging from support on installations of the Borland product 
to fee-based consultant-level support and extensive assistance.

Convention Purpose Example

File > Open Project Indicates cascading menu 
commands.

Select File > Open Project to 
open a project.

Bold Used for menu names, menu 
commands, button or field 
names.

Click the Details tab.

“Bold in Quotes” Text to be entered. Type “Admin” as the userid.

Note: Used to direct your attention to 
important information.

Note: The command will...

Italics Used in notes and step 
headers and as parameter 
placeholders. Replace the 
indicated text with the 
appropriate real name or value 
when using the command.

Note: The default is... 
or
Calibrrm -p <project>

Indicates that a step you are 
about to perform may have 
unexpected results.

Warning! If you perform 
this step....

Buttons in margins Helps you learn the buttons’ 
functions.

1. Click the Save button. 
Conventions Used in This Manual � 7



CHAPTER 1: INTRODUCTION
For more information about Borland’s support services, see our web site at http://
www.borland.com/devsupport/

From the Web site, you can access many newsgroups where CaliberRM users 
exchange information, tips and techniques.

Refer also to the Borland Community site at http://community.borland.com. It 
provides access to lots of information, articles, code examples, and upcoming news 
about CaliberRM.

When contacting support, be prepared to provide complete information about your 
environment, the version of the product you are using, and a detailed description of 
the problem.

For support on third-party tools or documentation, contact the vendor of the tool.

SYSTEM REQUIREMENTS

For details about the system requirements for CaliberRM, please refer to the 
CaliberRM Installation Guide.

INTERNATIONALIZATION

Through the support of Unicode character sets, CaliberRM now provides character 
fidelity regardless of language.  You can now manage requirements in any 
language. Contact your System Administrator for instructions on setting your 
regional settings.

LOGGING ON

To log on to a CaliberRM component: 

1. Select Start > Programs > CaliberRM, then select the component you want to 
launch. The Login screen is displayed.
8 � System Requirements  
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2. Enter your server Server name, User name and Password. The default User 
name and Password are admin.

3. Click Logon. CaliberRM launches the component and places the StarTeam 
Toolbar icon in your system tray.

STARTEAM TOOLBAR

The StarTeam Toolbar (referred to later as simply “the Toolbar”) is a component of 
the StarTeam and CaliberRM products that enables you to log on to CaliberRM and 
StarTeam using only one login. It makes it easier for you to log on to multiple 
servers and to launch different programs from a single location. 

The Toolbar is automatically populated with shortcuts for the tools of the StarTeam 
and CaliberRM products that are installed on your workstation. Because the 
Toolbar uses the standard Windows program shortcut feature, you can easily add 
any other program as a tool for quick launch.

The Toolbar enables you to:

• Specify which portions of its user interface are visible (none, system tray only, 
window only, or system tray and window).

• Cache the user name and password used to log on to each StarTeam or Caliber 
server, making it easier for you to log on to multiple servers, and reducing the 
number of times you must log on to the same server to perform certain 
operations. (There is even an option for using the same user name and 
password for each server, so you do not have to log on to other servers where 
that user name and password is valid.)

• View the cached server/user associations.

• Add program shortcuts as tools on the Toolbar, so you can easily locate and 
start those tools. (You can also modify or delete an existing tool.)

• Display the Toolbar’s help information or version information.
StarTeam Toolbar � 9



CHAPTER 1: INTRODUCTION
When you launch a component of CaliberRM, the Toolbar icon is displayed in the 
system tray.

When you right-click the icon, a pop-up menu is displayed.

Click Open to open the main StarTeam Toolbar window, displayed on the 
following page. You can also double-click the icon to open the Toolbar.

Click a component name to launch the program.

Click About to view details about the Toolbar.

Click Exit to exit the Toolbar. 

STARTEAM TOOLBAR WINDOW 

The main Toolbar window enables you to change toolbar options.

Toolbar Options

• Display systray icon: Determines if the StarTeam Toolbar icon is displayed in 
the system tray. A check in the box indicates the feature is enabled.

StarTeam 
Toolbar icon
10 � StarTeam Toolbar Window  
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Click to E
Collapse 
window. elp on 

r.

splay the 
og box.

it the 
• Display expanded Toolbar at startup: Displays the full Toolbar window on 
startup. A check in the box indicates the feature is enabled.

• Hide from taskbar when minimized: Determines whether the StarTeam 
Toolbar icon is displayed in the taskbar when the toolbar is minimized. A check 
in the box indicates the feature is enabled.

• Use same username/password for each server: Enables the Toolbar to use 
the same username and password for each component. A check in the box 
indicates the feature is enabled.

• Server List: This displays all of the servers that are cached by the StarTeam 
Toolbar. For each server, the product icon, Server Type, Host Name, Port, and 
User Name are displayed.

Click the icon to launch a 
component. Right-click to add a tool shortcut.

xpand or 
the main 

Click for h
the Toolba

Click to di
About dial

Click to ex
Toolbar.
StarTeam Toolbar Window � 11
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Adding a Tool Shortcut

Note: The StarTeam Toolbar uses the standard Windows shortcut wizard for add-
ing tool shortcuts. Therefore, if someone other than yourself logs in using his/her 
Windows username and installs CaliberRM, the first time you log in using your 
username, you may not see any shortcuts on the Toolbar. You must add 
CaliberRM, its components and StarTeam shortcuts using the method below.

Note: These tools are not available for single login, just quick launch.

To add a tool shortcut on the menu:

1. Right-click on the toolbar.

2. Select Add Tool from the pop-up menu.
12 � StarTeam Toolbar Window  



CHAPTER 1: INTRODUCTION
The Windows Shortcut Wizard is launched.

3. Enter the location of the executable you want a shortcut for, or click the 
Browse button to navigate to it.

4. Click Next. The Select Title for this program screen is displayed.
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5. Enter a name for the shortcut and click Finish.

6. Right-click the toolbar and select Refresh Tools.

The icon now appears in the toolbar and can be launched from the StarTeam 
Toolbar.

Modifying a Tool Shortcut

To modify a shortcut:

1. Right-click on the tool icon of the shortcut you want to modify.

2. Select Modify Tool. The Shortcut properties window is displayed as shown on 
the following page.

new shortcut
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3. Make changes as necessary and click OK. The window closes and the changes 
are applied.

Deleting a Tool Shortcut

To delete a shortcut:

1. Right-click on the tool icon of the shortcut you want to delete.

2. Select Delete Tool. The shortcut is deleted.
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STARTEAM MESSAGE BROKER (MPX)

The StarTeam Message Broker, or MPX, allows you to publish information about 
MPX events, such as creating or deleting a requirement. 

Benefits of MPX include:

• Requirement additions appear in the requirement tree even if the parent node 
has already been expanded.

• Requirement deletions are removed from the requirement tree even if the 
parent node has already been expanded.

• Clients cache requirement data as it is retrieved from the server, the next time 
those requirements are selected, they are retrieved from local cache. If a 
requirement is changed by someone else, the client retrieves the latest data 
from the server.

If the StarTeam Message Broker is not used:

• CaliberRM will function without any issues.

• you can refresh the project to see requirements that are added or deleted.
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Chapter 2: Framework Administrator 
Overview

OVERVIEW

The Software Quality Management (SQM) Framework (Framework Administrator) 
is a central communications framework for CaliberRM and integrated products. 
The Framework Administrator controls administrative functions, including users, 
groups, projects, licensing, security and automatic notification.

Before users can begin entering requirements into CaliberRM, you must first define 
projects and set up users and groups in the Framework Administrator.

USER INTERFACE

The Framework Administrator contains four views, each of which allows you to 
perform specific tasks. The views available are: 

• Project View

• User View

• Group View

• User Connections Monitor View

Project View

The Project View lists all projects and displays specific information for a selected 
project, including general project information, users and groups assigned to the 
project, project baselines and project integrations. The Project View is shown on 
page 50. 

Projects are discussed in more detail in “Projects” on page 49 .
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User View

The User View lists all users and displays specific information for a selected user, 
including name, department, phone and fax numbers, email address, group 
membership and password. The User View is shown on page 69. 

Users are discussed in more detail in “Users and Groups” on page 69.

Group View

The Group View lists all groups and displays specific information for a selected 
group, including name, description and members. The Group View is shown on 
page 81. 

Groups are discussed in more detail in “Users and Groups” on page 69.

User Connections Monitor View

The User Connections Monitor provides information to CaliberRM administrators 
about the identity and the number of connected users for the CaliberRM server. 

The Monitor View is shown and detailed on page 46.

MENUS

Within the Framework Administrator, there are six menus: File, Edit, View, Tools, 
Report and Help. Each menu contains items that enable you to perform certain 
functions. The menus are described in more detail in the following sections.
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File Menu

The File menu contains several commands related to administrative tasks. 

The commands perform the following functions: 

• New Project: Creates a new project.

• New User: Creates a new user.

• New Group: Creates a new group.

• Save Changes: Saves the changes you have made to the selected project, user 
or group.

• Admin: Displays the Admin sub-menu, which contains the following 
commands for performing administrative tasks:

• Account Restrictions: Displays the Account Restrictions dialog box, which 
allows you to set parameters for password administration. See page 32 for 
more information.

• Notifications: Displays the Notifications dialog box, which allows you to 
set parameters necessary to enable automatic email notification. See page 34 
for more information.
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• Departments: Displays the Departments dialog box, which allows you to 
modify the department list for users. See page 35 for more information.

• Security Profiles: Displays the Security Profiles dialog box, which allows 
you to create, modify and delete security profiles. See page 89 for more 
information.

• Glossaries: Displays the Glossaries dialog box, which allows you to create, 
modify and delete project glossaries. See page 62 for more information.

• License Management: Displays the License Management dialog box that 
allows you to configure and manage your user licenses. See page 37 for 
more information.

• TestDirector Configuration: Displays the TestDirector Configuration dia-
log box, which allows you to set up the host, database and login information 
for the integration with TestDirector. The configuration properties are 
applied to all CaliberRM projects. See “Enabling Other Integrations” on 
page 422 for information about how to enable the TestDirector integration.

• Select Enterprise Configuration: Displays the Select Enterprise Configu-
ration dialog box, which allows you to enable or disable the integration with 
Select Enterprise. The configuration properties are applied to all CaliberRM 
projects. See “Enabling Other Integrations” on page 422 for information 
about how to enable the Select Enterprise integration.

Note: For information about setting up these integrations, please visit the 
CaliberRM Customer Zone at http://www.starbase.com/support/logintosup-
portonline.asp, or contact support.

• Save Settings: Saves system settings, including current view and item selected, 
window size and window position.

• Exit: Closes the Framework Administrator.

• Exit and Log Off: Closes the Framework Administrator and logs you off of 
the Caliber system. Also closes CaliberRM if it is open.
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Edit Menu

The Edit menu contains several standard Windows commands.

The commands perform the following functions:

• Undo: Reverses the previous action performed.

• Cancel Changes: Cancels any unsaved changes you have made and returns 
data to its original form.

• Cut: Cuts the selected text.

• Copy: Copies the selected text.

• Paste: Pastes cut or copied text into the space selected.

• Delete: Deletes the selected project, user or group.

• Find in Tree: Enables you to find projects, users and groups whose names 
meet specified criteria.

Find in Tree

To search for a project, user or group:

1. Choose either the Project View, User View or Group View, depending upon 
what you would like to find.
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2. Select Edit > Find from the menu, or click the Find button. 

The Find in Tree dialog box is displayed.

3. Type the name of the item you would like to find, or any portion of the name in 
the Find what field.

4. If you want the search engine to find items with names that match exactly, 
select the Match whole word only check box.

5. If you want the search engine to match names by case, select the Match case 
check box.

6. Select the direction in which to search (Up from the currently selected item, or 
Down). 

7. Click the Find Next button until the item you are searching for is selected.

8. Click the Cancel button to close the Find in Tree dialog box.
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View Menu

The View menu contains commands to specify the view you want to see. 

The commands perform the following functions:

• Projects: Changes the view to display the list of projects on the left, with 
project information on tabs on the right.

• Users: Changes the view to display the list of users on the left, with user 
information on tabs on the right.

• Groups: Changes the view to display the list of groups on the left, with group 
information on tabs on the right.

• Monitor: Displays the view selections for the User Connections Monitor.

• User Connections: Displays the User Connections Monitor view.

• Products Connections: Displays the Products Connections Monitor view.

• Logout: Allows an administrator to log a client off the system.

• Refresh: Updates project information.

• Toolbar: Shows/hides the toolbar. A check mark indicates that the toolbar is 
displayed.

• Status Bar: Shows/hides the status bar. A check mark indicates that the status 
bar is displayed.
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Tools Menu

The Tools menu contains various commands on four tabs. By selecting Tools > 
Options, you may select any of the four tabs.

General Tab:

Save Settings on Exit: Saves system settings, including last view and item 
selected, window size and window position, when exiting the Framework 
Administrator.

Confirm Before Saving: Displays a confirmation dialog box that asks if you 
want to save the project, user or group you have modified. This option is 
selected by default.

Communications Tab:

Normal Transaction Time Out: Determines how long, in seconds, the client 
will wait for a response from the server for normal transactions, such as
displaying project data. If you are running the Framework Administrator 
remotely, you may need to increase this time by a few seconds.

Lengthy Operation Time Out: Determines how long, in seconds, the client 
will wait for a response from the server for lengthy operations, such as 
running reports. The time needed to build reports will depend upon the report 
selected and the amount of data to be compiled.
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Network Diagnostics Level: Determines the level of detail presented when 
you run the network diagnostics utility. This utility can be used to 
troubleshoot communication problems. This option should only be changed 
at the direction of Borland’s product support group.

Appearance Tab:

Flat Toolbars: Displays the toolbar buttons as flat, instead of raised. 

Icons on Menus: Shows icons next to commands on the menus that have 
corresponding toolbar buttons. This helps you recognize toolbar buttons.

Resize Windows While Moving Splitter Bar: Redraws the tabs on the right 
side of the screen dynamically when you move the screen splitter. This may 
cause some minor flickering on your screen while redrawing, depending on 
your computer’s configuration.

Date Format: Determines how dates are displayed. Format is determined 
according to Windows settings that are specified when you select Settings > 
Control Panel > Regional Settings > Date from the Windows Start menu. 

Wizards Tab: 

Use Wizards when creating new:

Projects: Determines if projects are created using the Project Creation 
Wizard or Expert Mode.

Users: Determines if users are created using the User Creation Wizard or 
Expert Mode.

Groups: Determines if groups are created using the Group Creation Wizard 
or Expert Mode.

Select the check box next to items you want to create using a Wizard.

To change the Framework Administrator options:

1. Select Tools > Options from the menu.

2. Set the options as desired on each tab.

3. Click OK to save your changes.

4. Click Cancel to exit without saving changes.
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Report Menu

The Framework Administrator provides three standard reports: Project, User and 
Group. The Report menu allows you to preview and print standard reports of 
project, user and group data. 

The commands perform the following functions:

• Project: Displays the option to export, preview or print the Project report, 
which lists all projects with their data, including description and baselines. To 
export the report, click the Export button. See “Exporting Reports” on page 27 
for detailed information about the Export feature.

• User: Displays the option to preview or print the User report, which lists all 
users with their data, including description, name, address, department, email 
address and group assignments.

• Group: Displays the option to preview or print the Group report, which lists all 
groups with their data, including email address, description and users assigned.

To preview the report, click the Preview button. See “Report Preview” on page 28 
for detailed information about the Preview feature.

To print the report, click the Print button and follow the normal Windows printing 
procedure.
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EXPORTING REPORTS

This feature is only available for project reports. If you would like to export user or 
group information, use the Export to Access feature detailed in “Chapter 24: 
Export to Access” on page page 383.

To export reports:

1. In the report Report Setup dialog box, click the Export button. The Save As 
dialog box is displayed.

2. Choose a location in which to save your file.

3. Enter a File name and type.

4. Click Save.

When the export is complete, CaliberRM prompts you to open the file.
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REPORT PREVIEW

The Report Preview contains several options for viewing your report preview, and 
allows you to print the data. 

The toolbar features (listed in order from left to right) perform the following 
functions:

First Page: Displays the first page of the report.

Previous Page: Displays the previous page.

Current Page number: Displays what page is currently being viewed.

Next Page: Displays the next page.

Last Page: Displays the last page of the report.

Cancel: Cancels the loading process of the records. 

Print: Displays the Print dialog box, which allows you to choose the printer, 
pages to print and number of copies to print.

Printer Setup: Displays options for setting up your printer.

Magnification: Zooms in or out.

Total: Displays the total number of records in the report.

Percent Read: Displays the percentage of records displayed in the preview.

Records Read: Displays the number of records displayed in the preview.
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Help Menu

The Help menu displays options for accessing the Help system.

The commands perform the following functions:

Help Topics: Displays the Help system.

Using Help: Displays instructions for using the Help system.

Technical Support: Displays information about contacting Borland’s technical 
support team.

Borland Home Page: Opens an Internet browser and displays the Borland 
home page.

About Framework Administrator: Displays information about the SQM 
Framework.
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Chapter 3: Getting Started in Framework 
Administrator

This chapter details the tasks an administrator must perform before users can begin 
entering and managing requirements in CaliberRM. Other miscellaneous 
administrator tasks are also described here. 

PASSWORD ADMINISTRATION

To comply with corporate and government security regulations, CaliberRM enables 
administrators to create and enforce user password policies. Password administra-
tion is comprised of two sets of restrictions: enterprise level and user level. Enter-
prise level settings set the policy for all user accounts. The exception is Password 
Expiration. If you go to an individual user’s password tab and set the password to 
never expire, that option supersedes the Enterprise Password Administration set-
ting. 

Password policies are implemented by selecting a set of password restrictions from 
the following options:

• Set maximum password age by specifying the number of days a password is 
valid before it is required to be changed.

• Set minimum password age by allowing password changes immediately or 
imposing a waiting period of a certain number of days from the date of the last 
change.

• Ensure password uniqueness by keeping a history of used passwords. The 
password history is used in conjunction with the minimum password age 
option, and protects against multiple, repeated password changes.

• Set password minimum length. 
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Enterprise Password Administration

To set the enterprise password options:

1. Select File > Admin > Account Restrictions from the menu. The Account 
Restrictions dialog box is displayed.

2. In the Maximum Password Age box, select Password Never Expires if 
passwords should remain valid indefinitely, or select Expires In and enter a 
number between 1 and 999 to expire passwords in a certain number of days.

3. In the Minimum Password Age box, select Allow Changes Immediately to 
allow users to change their password immediately, or select Allow Changes In 
and enter a number between 1 and 999 to allow password changes in a certain 
number of days from the date of the last password change.

Note: This setting is to protect against multiple password changes when 
Password History is set.

4. In the Minimum Password Length box, select Permit Blank Password to 
permit a blank password, or select At Least and enter a number between 1 and 
14 to set the minimum number of characters allowed.
32 � Password Administration  



CHAPTER 3: GETTING STARTED IN FRAMEWORK ADMINISTRATOR
5. In the Password Uniqueness box, select Do Not Keep Password History, or 
select Remember to keep a password history of 1 to 24 passwords. Passwords 
that are retained in the history cannot be reused.

6. In the Auto Disable box, select the Do not automatically disable user 
accounts option button if you want users to be able to attempt to login an 
indefinite number of times or the Disable users after n consecutive login 
attempts within a 12 hour period option button if you want to limit the 
number of times a user can attempt to login. See page 78 for information on 
how to re-enable a user once the account has been disabled.

7. If Expires In is selected in Step 2, indicate the number of days between 0 and 
45 to begin warning the user in advance of password expiration.

8. Click OK.

Note: Enterprise Password Administration affects all users.The exception is 
Password Expiration. If you go to an individual user’s password tab and set the 
password to never expire, that option supersedes the Enterprise Password Admin-
istration setting. 

User Account Password Administration

The user account password restrictions enable administrators to:

• force users to change their password the next time they log on to a server.

• prevent users from changing their password.

• allow users to have passwords that never expire.

• disable user accounts.

You can set password restrictions for a user account when creating a user, or you 
can change an existing user account. For information about setting password 
restrictions when creating or modifying a user, see “Setting the User Password” on 
page 78.
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SETTING UP AUTOMATIC NOTIFICATION

Before automatic notification can be enabled, you have to set up the email system 
for the Framework Administrator to use. 

Note: Simple Mail Transfer Protocol (SMTP) is the only mail system that Borland 
supports.

To set Notification parameters:

1. Select File > Admin > Notifications from the menu.

2. Select the Enable check box. The Host, Port and Sender Address fields 
become active.

3. In the Port field, enter the port used for the SMTP service. The default port 
setting is 25.

4. In the Sender Address field, enter an email address. Notification emails 
contain the email address of the user making the requirement change. If the 
user’s email is not defined, CaliberRM displays the email address entered in the 
Sender Address field.

5. Click OK to save your parameters.

For information about enabling automatic notification, see “Enabling Automatic 
Notification” on page 59.
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DEPARTMENTS

When you create a user, you can specify the department to which the user is 
assigned. You may add, modify or delete departments as needed, either from within 
the User View, on the User Info tab or from the File menu at any time.

Note: Departments are used for information purposes only, and are not the same 
as user groups, although they may have the same name. Use of this feature is 
optional.

Creating a Department

To create a department:

1. Select File > Admin > Departments from the menu. The Departments dialog 
box is displayed.

2. Click the New button.

The Create New Department dialog box is displayed as shown on the 
following page.
Departments � 35



CHAPTER 3: GETTING STARTED IN FRAMEWORK ADMINISTRATOR
3. Enter a name and description for the department. Click OK.

4. When you have finished, click Close to exit the Departments dialog box.

Modifying a Department

To modify a department:

1. Select File > Admin > Departments from the menu. The Departments dialog 
box is displayed.

2. Select the department you want to modify and click the Edit button. 

The department’s dialog box is displayed.

3. Make the changes and click OK.

4. Click Close to exit the Departments dialog box.
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Deleting a Department

To delete a department:

1. Select File > Admin > Departments from the menu. The Departments dialog 
box is displayed.

2. Select the department you want to delete and click the Delete button. 

A message is displayed, verifying that you want to delete the department.

3. Click Yes to delete it, or No to save it.

4. Click Close to exit the Departments dialog box.

SECURITY PROFILES

The SQM Framework uses a default security profile that is sufficient for your initial 
security setup. For instructions on modifying the default security profile and 
customizing security profiles, see “Security” on page 89.

LICENSE MANAGEMENT

CaliberRM requires you to manage user license information for each product. This 
enables you to fully maximize product potential. 

There are three license specifications for CaliberRM users:

• Named User License: This license is assigned to a particular user. 

Note: If a named user attempts to connect from more than one machine, the 
connection from the second machine is treated as a concurrent license if one 
is available. If none are available, the user receives a No License Available 
caution window and must try again later.

• Concurrent User License: This license is assigned and available to a group of 
users. For example, if your license dictates that you have 10 concurrent users, 
you can assign as many users as concurrent users as necessary, but only 10 can 
be logged in at a given time.
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• Not Authorized User License: This license is assigned to a particular user. An 
unauthorized user is always unable to login.

Important Notes: 

• The Admin user is always a named user for each product, but does not count 
against the number of named user licenses you have. However, if the Admin 
user attempts to connect from more than one machine, the connection from the 
second machine is treated as a concurrent license if one is available. 

• The Framework Administrator and Diagnostic Tool do not count against your 
number of licenses used.

• The number of licenses purchased does not affect how many users you can 
create in the Framework Administrator.

Information is located on the License Management dialog box. Select File > 
Admin > License Management to access it.

Login Examples 

The Admin user logs in from Client 
Machine A, then logs in from Client 
Machine B.

Machine A logs the Admin user in as a Named 
User, without using an allocated Named User 
license. Machine B logs the Admin user in as a 
Concurrent User if a concurrent license is 
available for the application. If not, the Admin 
user receives a No License Available caution 
window and must try again later.

A Named user logs in from Client 
Machine A, then logs in from Client 
Machine B.

The connection from Machine B is treated as a 
concurrent license if one is available for the 
application. If none are available, the user 
receives a No License Available caution window 
and must try again later.

A Named or Concurrent user logs in 
the Framework Administrator or the 
Diagnostic Tool.

No license key is used.

A Concurrent user logs in twice from 
the same machine.

No license key is used.
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Making License Changes 

To make changes to your licenses by project:

1. Select File > Admin from the menu. The License Management dialog box is 
displayed.

For each product you have a license for, there is a corresponding tab that 
displays the license key, the license expiration date, the number of Named 

Login Examples 

A Concurrent user logs in to two 
separate machines.

Another license is used.

A Named or Concurrent user logs in to 
CaliberRM Datamart.

No license key is used.
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User and/or Concurrent User licenses you have, and a userid and license 
designation for each Caliber user. The exception is the Datamart tab, which 
simply displays the key, the product and expiration date. See the table below 
for clarification.

Important Notes:   

• For a 30 day evaluation copy (blank license key) of CaliberRM, the 
number of named and concurrent licenses is 500. This applies to new 
installations and upgrades.

• Once a license key is entered the key cannot be removed, only replaced.

• Do not change the date on the CaliberRM Server until you have a 
permanent key. 

• Once a valid CaliberRM Datamart license key is entered any user can run 
the Datamart programs. 

Important Note for Customers Who Purchase Named User Licenses: 
Before you enter a new license key, for either an upgrade or new purchase, 
please ensure you have assigned CaliberRM users their Named User licenses 
and not exceeded the total number of Named User licenses provided by your 
new key.

Product License Key Evaluations

CaliberRM License Key is required 
after evaluation period.

To evaluate the product, leave the 
key field blank or enter a valid 
evaluation License Key.

CaliberRM Web 
Viewer 

License Key is required 
after evaluation period.

To evaluate the product, leave the 
key field blank or enter a valid 
evaluation License Key.

CaliberRM Explorer/
Datamart

License Key is required 
to install.

To evaluate the product, enter a 
valid evaluation License Key 
during the install.
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Example: You have 100 CaliberRM users, and made 50 of them Named 
Users during your evaluation period. You then purchase 10 Named User 
licenses. Before entering the new license key, reduce your 50 Named Users to 
the 10 Named User desired. Otherwise, your new license key will automati-
cally assign the 10 Named User licenses to the first 10 CaliberRM users from 
the 50 Named Users you selected during your evaluation period. 

2. You can change any user’s license key type by selecting the user from the list, 
and choosing the appropriate option button.

Note: Use the SHIFT key to select a range of users, or the CTRL key to 
select additional users.

Usage Reports

You can create usage reports that provide details about how often your CaliberRM 
users log in, how long they stay logged in and more.

To generate a usage report:

1. Select File > Admin from the menu. The License Management dialog box is 
displayed as shown on page 39.

2. Select the product you want a report of by clicking that product tab.
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3. Click the Usage Report button. The Usage Report dialog box is displayed.

4. Select the date range you want the report to display.

5. If you want the data grouped, select the Grouped By check box, and select a 
method from the drop-down list.

6. Select the output: 

• Open in default browser – Select this option to view the report 
immediately. Go to Step 7 on page 43.

• Save as XML – Select this option to save the file as an .xml file to view 
later. Go to Step 8 on page 45.
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7. Click OK. Your default browser opens and displays the usage report, as shown 
below.

The report displays a table with ten columns:

• User ID: The user’s userid.

• Client IP Address: The user’s IP address.

• Login Date: The date the user logged in.

• Login Time: The time the user logged in.

• Login Status: The login status of the user.

- Invalid Login or Password: The user could not login because his/her 
userid or password is invalid.

- User Not Authorized: The user could not login to the product because 
he/she is not a licensed user.
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- Password Expired: The user could not login because his/her pass-
word has expired.

- License Obtained: The user was granted a license, and logged in suc-
cessfully.

- No License Available: The user could not login because there was not 
an available license.

• License Type: The license type assigned to the user.

- N/A: Not Applicable, meaning the product does not support named or 
concurrent licenses, such as Framework Administrator.

- Named: The user is assigned a named user license.

- Concurrent: The user is assigned a concurrent license.

Note: The License Type is usually displayed as N/A. The exception is with a 
Login Status of either License Obtained or No License Available, which is 
displayed as Named or Concurrent. 

• Application: The CaliberRM client application the user accessed. See the 
table on the following page for details about each product component.

• Log Out Date: The date the user logged out.

• Log Out Time: The time the user logged out.

• Duration: The amount of time, in hours, minutes and seconds the user 
spent logged in.
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8. If you selected to save the report as an .xml in Step 6, click the Browse button 
to navigate to the location where you want to save the file.

9. Enter a name for the file and click Open. The file is saved.

10. Click OK to exit the License Management dialog box. 

Moving the Usage Report Data to Microsoft Excel

Once you view your usage report, you may want to analyze it in Microsoft Excel.

To analyze your data in Excel:

1. Complete Steps 1-7, beginning on page 41.

2. Select Edit > Select All from the menu.

3. Select Edit > Copy from the menu.

Product Name Application

CaliberRM •   CaliberRM Win32 client
•   CaliberRM Web (Java – with add/modify capabilities)
•   CaliberRM Document Factory
•   CaliberRM Import
•   CaliberRM Export
•   CaliberRM Viewer
•   CaliberRM SDK (COM/Java API)

CaliberRM Web Viewer •   CaliberRM Web Viewer –  Web Viewer (Java - read only 
capability)

CaliberRM Datamart •   CaliberRM PRO Datamart – PROConfigurator
•   CaliberRM PRO Datamart – PROExtractor
•   CaliberRM PRO Datamart – PROSynchronizer
Note: CaliberRM Explorer is not under License 
Management.

CaliberRM Framework 
Administrator

•   CaliberRM Framework Administrator
•   CaliberRM Diagnostic Tool
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4. Open Excel and create a blank spreadsheet.

5. In Excel, select Edit > Paste. The data is filled in.

6. Adjust your spreadsheet as necessary.

USER CONNECTIONS MONITOR

The User Connections Monitor provides information to CaliberRM administrators 
about the identity, license information and the number of connected users to the 
CaliberRM server, and for each product. The Monitor also provides a logout 
method for administrators to log clients off the system.

User Connections View

To view information about individual users, click the Monitor button or select 
View > Monitor > User Connections from the menu. The user list is displayed.

The User Connections view indicates the total number of users connected to the 
Caliber Server. Expanding the Active Users node shows a detailed list of connected 
users including their IP Address, Product, License Information, personal 
information, and more.

Press F5 to refresh the information.
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Product Connections View

To view information about connected users by Product, select View > Monitor > 
Product Connections from the menu. The product list is displayed.

The Product Connections view indicates the total number of users connected to 
each Caliber product. Expanding the Product Name node shows a detailed list of 
connected users including their IP Address, Product, License Information, personal 
information, and more.

Press F5 to refresh the information.

CLIENT LOGOUT

If a CaliberRM client crashes, gets locked or disconnected from the network, an 
administrator can log it off of the system. This allows the administrator to free 
resources immediately instead of waiting for the server to timeout the connection. 
All resources used by that client are available for use by other clients.  This includes 
releasing the license, unlocking locks and freeing memory.

To logout a client:

1. Select the Monitor view in Framework Administrator.

2. Select the user connection you want to disconnect.

3. Select View > Monitor > Logout from the menu. The client is disconnected.
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OVERVIEW

A project is defined as work that you need to manage as a whole, such as an 
application or system under development. Projects consist of several types of 
information, including users and groups, requirement types and requirements. 
Project administration is performed in the Framework Administrator and includes:

• creating, modifying and deleting projects,

• assigning users and groups,

• assigning security profiles,

• setting automatic notification,

• creating, modifying and deleting project glossaries,

• enabling project integrations.

The Project View contains a set of four tabs that facilitate administrator activities:

• Project Info

• Group Assignment

• Glossaries

• Project Baselines

• External Traceability

The Framework Administrator Project View is shown on the following page.
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CREATING A PROJECT

There are two ways to create a project: using the Project Creation Wizard, or using 
Expert Mode. Expert Mode uses the dialog boxes for creating projects and is 
designed for users who are already familiar with defining project information.

Project Creation Wizard

The wizard launches automatically when you click the New Project button if you 
have selected that option in Framework Administrator Options. Select Tools > 
Options > Wizards from the menu to verify that the wizard is selected.

To create a project using the Project Creation Wizard:

1. Click the New Project button. 
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Step 1 of the Project Creation Wizard is displayed.

2. Enter a name for the project.

3. Click Next. Step 2 of the Project Creation Wizard is displayed.

4. Enter a description for the project.
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5. Click Next. Step 3 of the Project Creation Wizard is displayed.

6. Assign groups to the project by selecting the appropriate boxes to the left of the 
group names. 

7. Click Next. Step 4 of the Project Creation Wizard is displayed.
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8. Select the glossary you want to associate with the project from the Available 
list. 

Note: Use the SHIFT key to select a range of glossaries, or the CTRL key to 
select multiple glossaries individually.

9. Click the Move Left button to move the glossary to the Selected list.

Note: You can assign all the glossaries in the Available list to the Selected 
list by clicking the Move All Left button.

10. You may arrange the order of the glossaries by using the Move Up and Move 
Down buttons. The order of the list determines the order in which CaliberRM 
searches the glossaries, and the color order that is displayed when there are 
identical terms in multiple glossaries.

11. Click Next. The New Project Information dialog box is displayed.

12. Verify the information you have entered. If the information is correct, click 
Finish. If not, click Back and make the necessary changes.

The project is created.
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You can now modify the user list, assign a security profile and set automatic 
notification for each group assigned to the project. See “Advanced Steps” on 
page 56.

Creating a Project Using Expert Mode

To create a project using Expert Mode, you must first define the basic project 
information and assign groups. 

Note: To create a project using Expert Mode, the option to use wizards must be 
cleared in Tools > Options > Wizards.

Defining Project Information

To define the project information:

1. Select File > New Project from the menu, or click the New Project button. 

A new project is created and the Project Info tab is displayed.

2. Enter a name and description for the project.
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3. To save the project, select File > Save Changes from the menu, or click the 
Save Changes button. To delete the project, select Edit > Cancel Changes 
from the menu, or click the Cancel Changes button.

Assigning Groups

Once you have created your project, you can assign groups to the project. Users in 
these groups are then able to view and modify the project information as specified 
by their security profiles.

To assign groups to a project:

1. Select the Group Assignment tab. The tab is displayed.

2. Select the box to the left of any group you want to assign. A check mark in the 
box indicates that the group is assigned.

When you assign a group to a project, all of the users who are members of 
that group are automatically assigned to the project. You can then modify the 
user list if necessary to assign only specific members to the project. For more 
information, see “Modifying the User List” on page 57.
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3. To save the project, select File > Save Changes from the menu, or click the 
Save Changes button. To delete the project, select Edit > Cancel Changes 
from the menu, or click the Cancel Changes button.

ADVANCED STEPS

There are three advanced steps to assigning users and groups that can be performed 
once groups have been assigned to a project: modify the user list, assign a security 
profile and set automatic notification for assigned groups within the project. These 
functions are accessed when you select a group from the Group Assignment tab 
and click the Advanced button. 
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Modifying the User List

To modify the user list for the selected group within a project:

1. Select the group with the user list you want to modify.

2. Click the Advanced button. The Advanced functions are displayed.

The Assigned list contains a list of users assigned to that group within the 
project, and the Not Assigned list contains a list of users not assigned to the 
project. All members of the selected group are assigned by default.

3. To automatically add users to the project, select the Users assigned to the 
groups are automatically assigned to the project check box. This option is a 
per project selection. If you select this option, all users assigned to the group 
are assigned to the project and the Assigned and Not Assigned selections are 
unavailable.  If you select this option, go to step 6.

WARNING!  ANY USER THAT IS ASSIGNED TO A PROJECT THAT IS NOT 
ASSIGNED TO A GROUP WILL NO LONGER BE ASSIGNED TO THAT PROJECT IF 
THIS OPTION IS SELECTED.

4. To remove users from the Assigned list box, select them and click the Remove 
button. 

To add users to the Assigned list box, select them from the Not Assigned list 
box and click the Add button.

Note: Use the SHIFT key to select a range of groups, or the CTRL key to 
select additional groups.

5. To display all CaliberRM users in the Not Assigned list box, select the Select 
From All Users option button. 

This allows you to assign users to the group for the selected project only, 
without changing global group assignments. For example, the tester ajones 
may assist in development for a specific project, but does not need to be 
added to the Developers group to participate as a developer for that project 
only.
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Note: If you create new users and assign them to a group that was previously 
assigned to a project, you must modify the user list to move them into the 
Assigned list box.

6. To save your changes, select File > Save Changes from the menu, or click the 
Save Changes button. To delete changes, select Edit > Cancel Changes from 
the menu, or click the Cancel Changes button.

Setting Security in a Project

You can set access privileges for each group in a project by assigning a security 
profile to each group. For more information on creating security profiles, see 
“Creating a Security Profile” on page 90.

To assign a security profile to a group within a project:

1. On the Group Assignment tab, select an assigned group from the group list 
box.

2. Click the Advanced button. The Advanced functions are displayed.

3. Click the Security button. The Security dialog box is displayed.

4. Select the security profiles you want to assign to the group. Profiles apply to all 
users within the selected group, for the selected project only. If multiple 
profiles are selected, the profiles are combined, and the least restrictive access 
level of all selected profiles is used. If no profile is selected, the default profile 
is used to determine access. See “Combining Security Profiles” on page 97

5. Click OK to return to the Group Assignment tab.

6. To save your changes, select File > Save Changes from the menu, or click the 
Save Changes button. To delete changes, select Edit > Cancel Changes from 
the menu, or click the Cancel Changes button.
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Enabling Automatic Notification

Each requirement may have several individuals assigned to it as responsible users. 
For example, the business analyst who created the requirement may be assigned 
responsibility, as well as a developer, tester and manager. 

When a requirement is added, modified or deleted, the responsible users must be 
notified. Framework Administrator notifies all responsible individuals by email, 
according to the notification configuration. However, not all assigned individuals 
need to be notified of every change. Therefore, you can customize notification by 
group within each project. Groups may receive notification if a requirement is 
added, modified or deleted.

To use the notification process, configure the email notification parameters in 
Framework Administrator (see “Setting Up Automatic Notification” on page 34). If 
these parameters are not set up correctly, notifications are generated and queued 
until the email system is properly specified.

To set automatic notification for a group within a project:

1. Select View > Projects from the menu, or click the Project View button.

2. Select the project with the notifications you want to change.

3. From the Group Assignment tab, select an assigned group in the group list. 

4. Click the Advanced button. 
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5. Click the Notifications button. The Notifications dialog box is displayed.

6. Select the A New Requirement is Created check box to notify responsible 
individuals of requirement assignments.

• Select the A Requirement is Deleted check box to notify responsible 
individuals of a deleted requirement. 

• Select the A Requirement is Modified check box to notify responsible 
individuals of a modified requirement.

• Select the A Discussion Item is posted check box to notify responsible 
users that a new discussion item has been added. When a new discussion is 
posted or replied to, an email will be sent to users assigned as responsible to 
the requirement, users who have registered interest in the requirement and 
any other users who have participated in the particular discussion thread.

Note: These options apply to all users within the selected group that are 
assigned to the project. 

7. Click OK to return to the Group Assignment tab.

8. To save your changes, select File > Save Changes from the menu, or click the 
Save Changes button. To delete changes, select Edit > Cancel Changes from 
the menu, or click the Cancel Changes button.
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MODIFYING A PROJECT

To modify an existing project:

1. Select View > Projects from the menu, or click the Project View button.

2. Select the project you want to modify.

Note: When a project is being modified, the project list displays a lock icon 
on the project, indicating that the project cannot be modified by anyone else 
at the same time.

3. Select the tab containing the information you want to modify.

4. Edit the project information.

5. To save your changes, select File > Save Changes from the menu, or click the 
Save Changes button. To delete changes, select Edit > Cancel Changes from 
the menu, or click the Cancel Changes button.

DELETING A PROJECT

WARNING: IF YOU DELETE A PROJECT, YOU CANNOT RECOVER DELETED 
DATA.

Note: Before you can delete a project, you must first delete all requirements in the 
project, unassign all requirement types assigned to the project and delete all 
baselines in the project.

To delete an existing project:

1. Select View > Projects from the menu, or click the Project View button.

2. Select the project you want to delete.

3. Select Edit > Delete from the menu, or click the Delete button. A message is 
displayed verifying that you want to delete the project.

4. Click Yes to delete the project, or No to save it.
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PROJECT GLOSSARIES

CaliberRM can contain multiple glossaries that allow you to define terms that are 
specific to your organization’s projects. These glossaries are created by an 
administrator in the Framework Administrator and maintained in CaliberRM. 
CaliberRM Administrators create, define, delete and modify terms. Defined terms 
are automatically converted to color-coded hyperlinks in the requirement 
description as they are typed.

Creating a Glossary

To create a new glossary:

1. In Framework Administrator, select File > Admin > Glossaries. 

The Glossaries dialog box is displayed.
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2. Click New. The Glossary dialog box is displayed.

3. Enter a name for the new glossary.

4. Select a color for the glossary terms.

5. If you want to add a term, click the New Term button.

6. Click OK. 

The Glossary is created and added to the Glossaries tab. You can also import an 
existing glossary to create a new glossary. See “Importing Glossaries” on page 65.

Assigning a Glossary to a Project

To assign a glossary to a project:

1. In Framework Administrator, select the project in which you want to assign a 
glossary.

2. Select the Glossaries tab. The tab displays a list of all of the selected (assigned) 
and available glossaries.
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3. Select the glossary you want to associate with the project from the Available 
list. 

Note: Use the SHIFT key to select a range of glossaries, or the CTRL key to 
select multiple glossaries individually.

4. Click the Move Left button to move the glossary to the Selected list.

Note: You can assign all the glossaries in the Available list to the Selected 
list by clicking the Move All Left button.

5. You may arrange the order of the glossaries by using the Move Up and Move 
Down buttons. The order of the list determines the order in which CaliberRM 
searches the glossaries, and the color order that is displayed when there are 
identical terms in multiple glossaries.

6. Click the Save button to save the project.

The glossary is assigned to the project.

Modifying a Glossary

To modify a glossary:

1. In the Framework Administrator, select File > Admin > Glossaries. The 
Glossaries dialog box is displayed.

2. Click Modify. The Glossary dialog box is displayed.

3. Make desired changes.

4. Click OK. 

5. Click the Save button to save the project.

The Glossary is modified. You can also import existing glossary terms to an 
existing glossary. See “Importing Glossaries” on the following page.
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Deleting a Glossary

To delete a glossary:

1. In the Framework Administrator, select File > Admin > Glossaries. The 
Glossaries dialog box is displayed.

2. Select the glossary you want to delete from the list.

3. Click Delete. The Deleting Glossaries dialog box is displayed.

4. Click OK to delete the glossary or Cancel to save the glossary. 

5. Click Close to close the Glossaries dialog box.

Importing Glossaries

You can import a predefined glossary of terms into an existing glossary or a new 
glossary. The import file must be an .xml file. See page 66 for a sample .xml file.

To import a glossary:

1. Select File > Admin > Glossaries from the menu. The Glossaries list dialog 
box is displayed.

2. If you want to import terms into a new glossary, click New. If you want to 
import terms into an existing glossary, select that glossary and click Modify. 
The Glossary edit dialog box is displayed.

3. If creating a new glossary, enter a name and color. 

4. Click Import. The Import Glossary Terms dialog box is displayed.
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5. Enter in the name of the file you want to import, or click the Browse button to 
navigate to the file. 

6. Click OK.

The terms now appear in your glossary.

Sample .xml Format

Exporting Glossaries

You can export an existing CaliberRM glossary to an .xml file.

To export a glossary:

1. Select File > Admin > Glossaries from the menu. The Glossaries list dialog 
box is displayed.

2. Select the glossary that contains the terms you want to export from the list and 
click Modify.
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3. Click Export. The Export Glossary Terms dialog box is displayed. 

4. Click the Browse button and navigate to the location you want to save the file. 
Enter in a name for your file

5. Click OK. Your glossary is now in an .xml file.

Note: You can also print glossary information using Document Factory. See 
page 341 for more information.
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USERS

A User is any person who has access to or uses CaliberRM or the Framework 
Administrator system. Users can be developers, managers, testers, CEOs, and 
others in your enterprise. A user may also be defined just for the purpose of 
receiving notifications about requirements. They do not need to actually use 
CaliberRM. 

User information includes contact information for each user, including an email 
address used for automatic notification. Users are placed in one or more groups and 
assigned to projects and requirements. 

Users and groups are defined in Framework Administrator and assigned at the 
project and requirement levels as needed. The graphic below illustrates the 
hierarchy of user and group lists from the framework level to the requirement level.

You may add users to a group in either the User View, shown on the following page, 
or the Group View, shown on page 81. You may also edit user information within 
the Group View.
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USER ACCESS LEVELS

There are four levels of CaliberRM users: 

• Framework Administrator: Has special administrative rights in Framework 
Administrator and in the Requirements Manager. Framework Administrators 
are members of the group Administrators and can only be created by other 
Framework Administrators. Depending on their security profile, an 
administrator does not necessarily have access to all user-level functions.

• CaliberRM Administrator: Has special administrative rights in the 
Requirements Manager. They manage tasks that are requirement-specific (does 
not include baseline maintenance. See Baseline Administrator, below). 
CaliberRM Administrators are created in the Requirements Manager by 
Framework Administrators or by other CaliberRM Administrators. Depending 
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on his/her security profile, an administrator does not necessarily have access to 
all user level functions. See “CaliberRM Administrative Tasks” on page 129.

• Baseline Administrator: Performs all levels of baseline maintenance. This 
user does not have to be a Framework Administrator or a CaliberRM 
Administrator. See page 78 for information on making a user a baseline 
administrator.

• User: Performs user-level functions. Has no administrative rights.

The features and commands available to each user are project and group-specific. 
They are determined by the type of installation, security profile, requirements type 
level and by the product integrations that are enabled in the project.

CREATING A USER

There are two ways to create a user: using the User Creation Wizard or using Expert 
Mode. Expert Mode uses the dialog boxes to create users, and is for those who are 
familiar with defining user information. 

User Creation Wizard

There are four steps to creating a user through the User Creation Wizard. The 
wizard launches automatically when you click the New User button, if you have 
selected that option in Framework Administrator Options. Select Tools > Options 
> Wizards from the menu to verify that the wizard is selected.

To create a user using the User Creation Wizard:

1. Click the New User button. Step 1 of the User Creation Wizard is displayed as 
shown on the following page.
Creating a User � 71



CHAPTER 5: USERS AND GROUPS
2. Enter a unique ID for the user.

3. Enter the first and last name of the user and specify the user’s title and 
department.

4. Click Next. Step 2 of the User Creation Wizard is displayed.

5. Enter the user’s phone, fax, email, pager and location information.
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6. Click Next. Step 3 of the User Creation Wizard is displayed.

7. To assign the user to groups, select groups in the Not a member of list and 
click the Add button.

Note: Use the SHIFT key to select a range of groups, or the CTRL key to 
select additional groups.

8. Click Next. Step 4 of the User Creation Wizard is displayed as shown on the 
following page.
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9. Enter the user’s password and then retype it for verification.

Note: If you assign and attempt to save a password that is inconsistent with 
the Password Policy, you get an error message. For more information, see 
“Enterprise Password Administration” on page 32.

10. Select one or more of the following options to set the appropriate user 
password restrictions:

• User Must Change Password at Next Logon: Forces the user to change 
his/her password at the next logon.

• User Cannot Change Password: Prevents the user from changing his/her 
password.

• Password Never Expires: Allows the user to have a password that never 
expires.

• Account Disabled: Disables the user account.
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Note: The User Must Change Password at Next Logon and the User Cannot 
Change Password check boxes may not be selected at the same time. If you 
select these boxes and attempt to save the information, an error message is 
displayed.

11. Click Next. The New User Information dialog box is displayed.

12. Verify the information you have entered. If the information is correct, click 
Finish. If not, click Back and make the necessary changes.

The user is created.

Creating a User Using Expert Mode

There are three steps to creating a user: 

1. Defining basic user information.

2. Adding the user to groups.

3. Setting the user password. 
Creating a User � 75



CHAPTER 5: USERS AND GROUPS
Note: To create a user using Expert Mode, the option to use wizards for creating 
new users must be cleared in Tools > Options > Wizards.

Defining User Information

To define the basic user information:

1. Select File > New User from the menu, or click the New User button. A new 
user is created, and the User Info tab is displayed.

2. Enter the user information in the fields displayed. 

Note: If the Department needed is not available in the drop-down list, you 
may edit the list by clicking the Browse button. For additional information, 
see “Departments” on page 35.

3. To save the user, select File > Save Changes from the menu, or click the Save 
Changes button. To delete the user, select Edit > Cancel Changes from the 
menu, or click the Cancel Changes button.
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Adding the User to Groups

If groups have already been created, click the Group Membership tab. See page 
81 for instructions on creating a group.

To add the user to groups:

4. Select the group(s) to make the user a member of, from the Not member of list 
box.

Note: Use the SHIFT key to select a range of groups, or the CTRL key to 
select multiple groups individually.

5. Click the Add button to move the selected group(s) to the Member of list box.

Note: When modifying a user, a lock icon is displayed on the user list. This 
prevents someone else from modifying the user at the same time. 

6. To save your changes, select File > Save Changes from the menu, or click the 
Save Changes button. To delete changes, select Edit > Cancel Changes from 
the menu, or click the Cancel Changes button.

Note: To remove users from a group, select the group(s) in the Member of list box 
and click the Remove button.
Creating a User � 77



CHAPTER 5: USERS AND GROUPS
Setting the User Password

To set the password the user must enter to log on, click the Password tab. 

To set the user password:

1. Enter a password in the Password field.

Note: For security reasons, all characters of the password are displayed as 
asterisks (*). If you choose to leave the password information blank, the user 
will be able to log on without entering a password.

2. Retype the password in the Retype Password field. 

If the two passwords do not match, you are prompted to re-enter them.

Note: If you assign and attempt to save a password that is not consistent with 
the Password Policy, you will get an error message. For more information, 
see “Enterprise Password Administration” on page 32.

3. Select one or more of the following options to set the appropriate user 
password restrictions:

• User Must Change Password at Next Logon: Forces the user to change 
his/her password at the next logon.

• User Cannot Change Password: Prevents the user from changing his/her 
password.
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• Password Never Expires: Allows the user to have a password that never 
expires.

• Account Disabled: Disables the user account.

• User Can Perform Baseline Administration: Establishes the user as a 
baseline administrator.

Note: The User Must Change Password at Next Logon and the User Cannot 
Change Password check boxes may not be selected at the same time. If you 
select these boxes and attempt to save the information, an error message is 
displayed. 

4. To save your changes, select File > Save Changes from the menu, or click the 
Save Changes button. To delete changes, select Edit > Cancel Changes from 
the menu, or click the Cancel Changes button instead.

MODIFYING A USER

To modify an existing user:

1. Select View > Users from the menu, or click the User View button.

2. Select the user to modify.

3. Select the tab containing the information to modify.

4. Edit the user information.

5. To save your changes, select File > Save Changes from the menu, or click the 
Save Changes button. To delete changes, select Edit > Cancel Changes from 
the menu, or click the Cancel Changes button.

DELETING A USER

WARNING: REMOVING A USER REMOVES HIM/HER FROM ALL ATTRIBUTES 
AND RESPONSIBILITIES FOR REQUIREMENTS. IF YOU DELETE A USER, YOU 
CANNOT RECOVER DELETED DATA.
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To delete a user:

1. Select View > Users from the menu, or click the User View button. 

2. Select the user to delete.

3. Select Edit > Delete from the menu, or click the Delete button. 

A message is displayed to verify that you want to delete the user.

4. Click Yes to delete the user, or No to save it.

GROUPS

Groups are collections of users with similar responsibilities (i.e., Managers, 
Developers, Engineers, Marketing, etc.). Group information includes contact 
information for each group and group members.
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CREATING A GROUP

There are two ways to create a group: using the Group Creation Wizard or using 
Expert Mode. Expert Mode uses the dialog boxes for creating groups, and is for 
those who are familiar with defining group information.

Group Creation Wizard

There are four steps to creating a group through the Group Creation Wizard. The 
wizard launches automatically when you click the New Group button, if you have 
selected that option in the Framework Administrator Options. Select Tools > 
Options > Wizards from the menu to verify that the wizard is selected.

To create a group using the Group Creation Wizard:

1. Click the New Group button. Step 1 of the Group Creation Wizard is dis-
played.

2. Enter a unique name and an email address for the group.

Note: This email address is used for information only and has no effect on 
notifications.
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3. Click Next. Step 2 of the Group Creation Wizard is displayed.

4. Enter a description for the group.

5. Click Next. Step 3 of the Group Creation Wizard is displayed.

6. To assign users to the group, select users in the Not Selected list and click the 
Add button.
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Note: Use the SHIFT key to select a range of users, or the CTRL key to 
select multiple users individually.

7. Click Next. Step 4 of the Group Creation Wizard is displayed.

8. To assign the group to projects, select projects in the Not Selected list and click 
the Add button.

Note: Use the SHIFT key to select a range of projects, or the CTRL key to 
select multiple projects individually.
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9. Click Next. The New Group Information dialog box is displayed.

10. Verify the information you have entered. If the information is correct, click 
Finish. If not, click Back and make the necessary changes. 

The group is created.

Creating a Group Using Expert Mode

There are two steps to creating a group using Expert Mode: defining group 
information and adding users to the group.

Note: To create a new group using Expert Mode, the option to use wizards must 
be cleared in Tools > Options > Wizards.

Defining Group Information

To define the group information:

1. Select File > New Group from the menu, or click the New Group button. 
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A new group is created, and the Group Info tab is displayed.

2. Enter a name and description for the group.

3. Enter a group email address if desired. 

Note: This email address is used for information only and has no effect on 
notifications.

4. To save your changes, select File > Save Changes from the menu, or click the 
Save Changes button. To delete the group, select Edit > Cancel Changes from 
the menu, or click the Cancel Changes button.

Assigning Users to a Group

To assign users to a group within the Group View:

1. Click the Members tab. The tab is displayed as shown on the following page.
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2. Select the users to add to the group from the Not Members list box.

Note: Use the SHIFT key to select a range of users, or the CTRL key to 
select multiple users individually.

3. Click the Add button to move the selected users to the Members list box.

Note: When a group is being modified, the group list displays a lock icon on 
the group name, meaning that the group cannot be modified by anyone else at 
the same time. 

Note: To remove users from a group, select the user(s) in the Members list 
box and click the Remove button.

4. To save your changes, select File > Save Changes from the menu, or click the 
Save Changes button. To delete changes, select Edit > Cancel Changes from 
the menu, or click the Cancel Changes button.

MODIFYING A GROUP

To modify a group:

1. Select View > Groups from the menu, or click the Group View button. 
86 � Modifying a Group  



CHAPTER 5: USERS AND GROUPS
2. Select the group to modify.

3. Select the tab containing the information to modify.

4. Edit the group information.

5. To save your changes, select File > Save Changes from the menu, or click the 
Save Changes button. To delete changes, select Edit > Cancel Changes from 
the menu, or click the Cancel Changes button. 

DELETING A GROUP

WARNING: IF YOU DELETE A GROUP, YOU CANNOT RECOVER DELETED 
DATA.

To delete a group:

1. Select View > Groups from the menu, or click the Group View button. 

2. Select the group to delete.

3. Select Edit > Delete from the menu or click the Delete button. 

A message is displayed verifying that you want to delete the group.

4. Click Yes to delete the group, or No to save it.
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OVERVIEW

The security requirements for every company are different. A small company may 
require minimal or no security, whereas a company with hundreds of users and 
thousands of requirements may require multiple levels of security. 

As an administrator, you must make a decision about what type of security your 
enterprise needs. There are essentially two security models:

•  “allow by default”– this model allows everyone access by default, but the 
administrator can restrict access using security profiles

• “deny by default” – this model denies everyone access by default, but the 
administrator can allow access using security profiles

Once you have determined which security method your enterprise will use, you can 
modify the default profile or start creating new security profiles. 

Security is disabled by default, and must be enabled on a per project basis. See 
“Enforcing Security for a Project” on page 99.

SECURITY PROFILES

The Framework Administrator controls user access to CaliberRM through security 
profiles. The Framework Administrator has a default security profile that can be 
used initially. See the section “Default Security Profile” on the following page for 
information on the default profile.

Security profiles are created in Framework Administrator, but security for a project 
is enforced or disabled in CaliberRM. See “Enforcing Security for a Project” on 
page 99 for more information on enforcing security. 
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Security profiles:

• are created, modified and assigned to groups in Framework Administrator.

• determine in which requirement types group members can view, create, modify 
and delete requirements.

• determine what requirement attributes group members can modify.

Default Security Profile

The default security profile provides immediate security for a project once you 
enforce security for that project in CaliberRM (see “Enforcing Security for a 
Project” on page 99). All requirement types are assigned to the default profile, and 
may not be removed. The initial default access level is Create, allowing all users to 
create requirements. The initial default Delete level is Owned, allowing only the 
user who owns a requirement to delete it. Both of these levels can be changed at any 
time. For each attribute assigned to the requirement type, access is initially 
determined when the attribute is created, but can be modified at any time.

CREATING A SECURITY PROFILE

There are four steps to creating a security profile:

1. Choose what Requirement Types are assigned to the profile. 

2. Choose the Access level for each type, which determines whether group 
members can see or create requirements of this type.

3. Choose the Delete level for each type, which determines what requirements of 
a specific type group members can delete.

4. Choose which attributes to assign to each requirement type and set the 
Modification level for each attribute. The modification level determines when 
group members can modify the attributes.

Note: For detailed information on requirement types and attributes, see 
“Requirement Types” on page 137, and “Attributes” on page 155.
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Note: Assigning attributes to a requirement type within a security profile does not 
automatically assign the attribute to the requirement type in CaliberRM. 

To create a new security profile:

1. In the Framework Administrator, select File > Admin > Security Profiles 
from the menu. 

The Security Profiles dialog box is displayed.

2. Click the New button. The Security Profile Editor is displayed as shown on 
the following page.
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3. Enter a name and description for the profile.

4. To assign the requirement types to this profile, select the boxes next to the 
requirement types.

5. For the selected requirement type, choose the appropriate option button for the 
level of Access. There are four access levels:

• None: The requirement type does not appear in the group members’ lists.

• List: Group members can see a list of the requirements listed under the 
requirement type, but cannot access any data.

• View: Group members can see a list of the requirements listed under the 
requirement type, and can see data associated with the requirement.

• Create: Group members are able to create requirements in this 
requirement type.

6. For the selected requirement type, choose the appropriate option button for the 
level of Delete access. There are three access levels:

• None: Group members cannot delete any requirements in this requirement 
type.
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• Owned: Group members can delete only the requirements in this 
requirement type that they own.

• Any: Group members can delete any requirement in this type.

7. Select which attributes to assign to the selected requirement type by clicking 
the Add Attribute(s) button.

Note: Adding attributes to a requirement type within a security profile does 
not automatically assign the attribute to the requirement type within 
CaliberRM. 

The Attributes dialog box is displayed.

8. In the Add Attributes dialog box, select one or more attributes from the list. 
This adds the attribute to the requirement type within this profile only. If you do 
not select an attribute for the requirement type, the default profile is used.

Note: Use the SHIFT key to select a range of attributes, or the CTRL key to 
select more than one attribute.

9. Click OK to add the attributes.

Note: To remove an attribute, select it in the list and click the Remove 
Attribute(s) button.
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10. For each attribute, choose the appropriate Modification access option button. 
This option determines what attributes can be modified for a requirement of 
this type. There are three access levels:

• None: Group members cannot modify any attributes in this requirement 
type.

• Owned: Group members can only modify attributes of the requirements 
they own.

• Any: Group members can modify any attribute in this requirement type.

11. Click OK to save the security profile, or Cancel to exit without saving.

MODIFYING SECURITY PROFILES

WARNING: MODIFYING THE DEFAULT SECURITY PROFILE AFFECTS ALL 
PROJECTS.

To modify a security profile:

1. Select File > Admin > Security Profiles from the menu. The Security Pro-
files dialog box is displayed.

2. Select the profile to modify and click the Edit button. The Security Profile 
Editor dialog box is displayed.

3. Select the first requirement type in the list.

Note: You cannot clear requirement types or remove attributes within the 
default security profile.

4. Select the option button for the appropriate Access level.

5. Select the option button for the appropriate Delete level.

6. Select the option button for the appropriate Modification level for each 
attribute in the list.

7. Repeat Steps 3-6 for the each requirement type you want to modify.
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8. Click OK to save the security profile, or Cancel to exit without saving.

9. Click Close in the Security Profiles dialog box.

DELETING SECURITY PROFILES

To delete a security profile:

1. Select File > Admin > Security Profiles from the menu. The Security Pro-
files dialog box is displayed.

2. Select the profile you want to delete in the list.

Note: You cannot delete the default security profile.

3. Click the Delete button. A message is displayed verifying that you want to 
delete the profile.

4. Click Yes to delete the profile, or No to save it.

ACCESS PROFILE EXAMPLES

Individuals and Groups may have different access levels in different projects, or 
more than one access level in a single project. If individuals and groups have 
different access levels in a single project, the access levels are combined and the 
least restrictive level of access is granted.

Individual Access
The user bjones may have Create access in one project, but None access in another.
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Group Access

The Marketing Department has the following security profile:

Members of the Marketing group can:

• create requirements for both the Web Site Marketing and Order Processing 
Marketing requirement types. They can also delete requirements for these types 
because they are Owned by the group. They can Modify any Web Site 
Marketing requirements, but only those Order Processing requirements they 
own.

• see a List of requirement names for Order Processing and Warehouse, but 
cannot see any data associated with those requirements, and cannot modify any 
requirements in these types.

• view data for the Hardware and Software requirement types, but cannot delete 
or modify any requirements.

• not see the Billing requirement type in the requirement list at all.

Requirement 
Type

Access 
Level Delete Level Modification 

Level

Web Site Marketing Create Owned Any

Order Processing 
Marketing

Create Owned Owned

Order Processing List None None

Warehouse List None None

Hardware Read None None

Software Read None None

Billing None None None
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Combining Security Profiles

An individual can be assigned more than one security profile in a project. This 
combined profile contains the least restrictive levels of access available between 
the two groups. If neither profile covers the requirement type or attribute, the 
default profile is used.

For example, the user tjohnson may be in two different groups in one project and 
each group may be assigned different security profiles. Tjohnson’s security access is 
then a combination of the two profiles, and tjohnson is granted the least restrictive 
level of permission found in either profile.

A Group can also be assigned more than one security profile in a project. This 
combined profile contains the least restrictive levels of access available between 
the two groups. If neither profile covers the requirement type or attribute, the 
default profile is used.

For example, the Developer group is assigned both the Developer and the Tech 
Support profiles, as shown on the following page.
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DEVELOPER PROFILE

Requirement 
Type Access Level Delete Level Modification 

Level

Marketing List None None

Hardware Create Any Owned

Software Create Any Owned

Order Processing View None None

TECH SUPPORT PROFILE

Requirement 
Type Access Level Delete Level Modification 

Level

Marketing None None None

Hardware View None None

Software View None None

Order Processing View None None

COMBINED PROFILE

Requirement 
Type Access Level Delete Level Modification 

Level

Marketing List None None

Hardware Create Any Owned

Software Create Any Owned

Order Processing View None None
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Members of the Developer group can:

• see a list of Marketing requirements, 

• create and delete Hardware requirements, and modify those they own,

• create and delete Software requirements, and modify those they own,

• view Order Processing requirements.

ENFORCING SECURITY FOR A PROJECT

Security profiles are created in Framework Administrator and enforced and 
disabled in CaliberRM, by individual project. You must have at least CaliberRM 
administrator privileges to enforce security. Administrators can also modify 
security profiles in CaliberRM. See “Modifying Security Profiles” on page 94 for 
more information.

To enable or disable security for a project, select the appropriate option button in 
the Security area of the Project Info tab.

Enforce or 
disable 
security for a 
project
Enforcing Security for a Project � 99





Chapter 7: Database Administration

CaliberRM provides an automated system, called DB Manager, for performing 
database administration. This feature simplifies and expedites many common 
database maintenance tasks. The most common function is database backup, 
described below. For information on the other DB Manager commands and their 
functions, see the table beginning on page 107.

WARNING! IF YOU ARE RUNNING BACKUP TAPES OF THE SYSTEM, MAKE SURE 
THEY DO NOT BACKUP THE SQMDB DIRECTORY AT DRIVE:\BORLAND\
CALIBERRMSERVER\VERSANT\DB\SQMDB. TO ENSURE THIS DOES NOT HAP-
PEN, DO NOT BACK UP ANY OF THE DIRECTORIES FOUND IN THE DRIVE:\
BORLAND\CALIBERRMSERVER DIRECTORY.

DATABASE BACKUP

IMPORTANT! BE SURE TO VERIFY YOUR BACKUPS PERIODICALLY.  BORLAND 
RECOMMENDS THAT YOU BACKUP THE PRODUCTION SERVER AND RESTORE 
AND TEST BACKUPS OF CALIBERRM PROJECT DATA ON A TEST SYSTEM.  
RESTORING AND TESTING YOUR BACKUPS HELPS TO ENSURE THAT YOUR DATA 
IS BEING BACKED-UP CORRECTLY.

To create a backup file of your database:

1. Log on as the database administrator (DBA) to the machine where the database 
resides. 

Note: You can determine the DBA by opening a command prompt and enter-
ing dbuser -list sqmdb.

WARNING! USING THE INCORRECT ACCOUNT COULD RESULT IN A BACKUP 
FILE THAT CONTAINS INCORRECT OR NO DATA.

Note: The user name is case sensitive and must be exactly the same as used 
when the database was created.
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The install utility created a directory called \CaliberRM_Backup in the root 
of the drive where you installed the CaliberRM server.  This is the default 
(preferred) location for the backup file.

2. Select Programs > Command Prompt from the Windows Start menu.

3. Enter the following command on one line:

dbmgr -backup

4. Check the \CaliberRM_Backup folder and verify the SQMDB.bak file is 
present and is larger than 1 MB.

Note: The dbmgr -backup uses the database vbackup command, which does not 
require that the database be stopped or users be logged off. The vbackup utility 
and any scheduling software must be run under the account of the user that cre-
ated the SQMDB database. Vbackup will create an sqmdb.bak file under non-cre-
ator accounts, but the sqmdb.bak file contains invalid data and cannot be 
restored.

The database backup command can be run as part of a nightly batch process 
detailed on page 103. The procedure backs up all of the committed and saved 
content in the database to an external file on the server. This file can then be backed 
up to removable media and safely stored in accordance with your standard 
operating procedures.

RESTORING A DATABASE FROM A BACKUP

Note: Restoring the database requires that the user be logged off the system.

To restore a database from a backup:

1. Log on as the DBA to the machine where the database resides.

Note: The user name is case sensitive and must be exactly the same as used 
when the database was created.

2. Select Programs > Command Prompt from the Windows Start menu.

3. Enter the following command:

dbmgr -stop
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4. Enter the following command on a single line at the command prompt:

vbackup -device drive:\CaliberRM_Backup\SQMDB.bak -restore SQMDB

substituting “drive” for the letter of the drive where the CaliberRM server is 
installed.

5. At the next command prompt, type the following command:

dbmgr -start

SCHEDULING A DAILY CALIBERRM DATABASE BACKUP

Note: The following procedure uses a Microsoft Windows utility that was current 
at the time of this writing. Your process may be different. Please refer to your 
operating system’s documentation for scheduling a backup.

To schedule a database backup:

1. Complete steps 1-2 starting on page 101.

2. Create a text file named BackupCaliber.cmd that contains the line: 

dbmgr -backup drive:\CaliberRM_Backup\SQMDB.bak

substituting “drive” for the drive where the CaliberRM server is installed.

3. Save the file in the \CaliberRM_Backup\directory that was created during 
installation.

4. Open the Control Panel.

5. Double-click the Scheduled Tasks icon.

6. Double-click the Add a Scheduled Task icon. The Scheduled Task Wizard 
dialog box is displayed.
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7. Click Next. The second Wizard screen is displayed.

Click Browse and navigate to drive:\CaliberRM_Backup, substituting “drive” 
for the drive where the CaliberRM server is installed.

8.  directory and select BackupCaliber.cmd. 

9. Click Next. The third Wizard screen is displayed.
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10. Select the Daily option button and click Next. The fourth Wizard screen is 
displayed.

11. Set the Start time, select the Every Day option button and set the Start date.

12. Click Next. The fifth Wizard screen is displayed.
Scheduling a Daily CaliberRM Database Backup � 105



CHAPTER 7: DATABASE ADMINISTRATION
13. Enter the DBA of the CaliberRM database and the DBA password.

Note: The vbackup utility and any scheduling software must be run under the 
account of the user that created the SQMDB database. Vbackup will create 
an SQMDB file under non-creator accounts, but the sqmdb.bak file will con-
tain invalid data and cannot be restored.

14. Click Next. The last Wizard screen is displayed.

15. Review the screen and click Finish to complete the addition of the task, or 
Back to make any changes.

The task should now appear in the Scheduled Tasks directory.
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DB MANAGER COMMAND SWITCHES

DB Manager uses command line switches to run each utility. The switches and their 
usage are detailed in the table below. 

WARNING: ALL COMMANDS EXCEPT FOR THE DETAILED HELP COMMAND 
REQUIRE THAT ALL USERS BE LOGGED OFF OF CALIBERRM. 

Switch Command Usage

dbmgr –? Detailed Help explains the commands and switches

dbmgr –addvol Add Volume extends the size of a database as it nears 
maximum capacity

dbmgr –backup Database Backup backs up your database

dbmgr –dropclass Dropclass drops unreferenced objects from the 
database; needed after an upgrade

dbmgr –fix Fix Links repairs any broken links in the database 
after you scan the database

dbmgr –free Free Space displays the amount of free space in the 
database; useful for determining whether 
the Add Volume or Optimize Commands 
should be performed

dbmgr –new <–
sample or –empty> 
<dbname>

Create Database 
Command

creates a new database ready for use; 
the sample switch loads the Automated 
Teller Machine sample database

dbmgr –defrag 
dbname]

Reorganize increases the maximum capacity of your 
database and places all data into a single 
system volume. Also reorganizes the 
data (much like a disk defragment) for 
optimum performance

dbmgr –scan Database Scan scans the database for bad links and 
prints the information

dbmgr –start Start Database starts a CaliberRM server and database

*fields in brackets (< >) must be included; fields in braces ( [ ] ) are optional
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CREATING A NEW DATABASE USING DB MANAGER

You can create a new blank database or populate it with sample data using DB 
Manager.

To create a new database:

1. Log on to the machine where the database resides as an administrative user. 

Note: This user becomes the DBA for the new database.

2. Select Programs > Command Prompt from the Windows Start menu.

3. Enter the following command, substituting “database name” with the name you 
want for your new database.

dbmgr -new -empty database name

Note: If you want the new database to contain sample data, substitute - empty 
with -sample.

INCREASING DATABASE SIZE USING THE DEFRAG COMMAND

If your database is reaching maximum capacity, you have the option of increasing 
the maximum capacity of that database and reorganizing the data.

To optimize your database:

1. Log on to the machine where the database resides as the DBA.

dbmgr –stop Stop Database stops a CaliberRM server and database

dbmgr –upgrade Upgrade Database upgrades the current database to the 
current version; performed automatically 
during an install

Switch Command Usage

*fields in brackets (< >) must be included; fields in braces ( [ ] ) are optional
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Note: The user name is case sensitive and must be exactly the same as used 
when the database was created.

2. Select Programs > Command Prompt from the Windows Start menu.

3. Enter the following command:

dbmgr -defrag [new database name]

Note: You have the option of entering a new database name after -defrag if 
you want to name the database. Otherwise, the system creates a default name 
that consists of your current database name with a _n appended to the end, 
where n is a sequential number (e.g. your_database_1).

MOVING A DATABASE

To move a database from one machine to another:

On the machine where the database resides:

1. Log on as the DBA.

Note: The user name is case sensitive and must be exactly the same as used 
when the database was created.

2. Select Programs > Command Prompt from the Windows Start menu.

3. Enter the following command:

dbmgr -backup

4. Enter the following command:

dbmgr -stop

5. In Windows Explorer, copy the logical.log, physical.log and system files from 
the database directory onto a network drive, or some type of movable media to 
move it to the new machine.
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On the machine you want to move the database to:

1. Log on as the DBA and install CaliberRM.

2. Select Programs > Command Prompt from the Windows Start menu.

3. Enter the following command:

dbmgr -stop

4. In Windows Explorer, copy the logical.log, physical.log and system files from 
the current location on a network drive, or some type of movable media to 
c:\tbicaliber\servers\versant\db\sqmdb directory.

Note: If you changed the installation directory during installation, then use 
that directory instead of c:\tbicaliber\servers.

5. In the Dos prompt window, enter the following command:

dbmgr -start

VERSANT DOCUMENTATION

The following sections contain documentation from Versant Software for the 
Versant database.

Vbackup Utility

usage: vbackup [options] command
where options are one or more of:

• -level <level>

• Level 0: Backup the entire database.

• Level 1: Backup changes since the last level 0 backup.

• Level 2: Backup changes since the last level 0 or level 1 backup.

-device <filename>
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-position <position>
-capacity <capacity>
-blocking <blocking>
-comment <comment>
-rollforward
-aggression <aggression>
-script <script>

and command is one of:
-backup <database-names>
-restore <database-name>
-off <database-names>
-log <database-names>
-info <database-names>
-list

Alternatives for the option parameter are:

• -level: Specify incremental level of backup.

• -device: Specify the backup or restore device.

• -position: Specify position on tape for backup or restore. (Unix only)

• -capacity: Specify tape capacity. (Unix only)

• -blocking: Specify number of bytes to read or write at a time. (Unix only)

• -comment: Specify a comment to be associated with a backup.

• -rollforward: Enable roll forward archiving during backup.

• -aggression: Specify buffer flushing interval.

• -script: Specify a script from which to run vbackup.

Alternatives for the command parameter are:

• -backup: Back up a database.

• -restore: Restore a database.
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• -off: Disable roll forwarding.

• -log: Start roll forward archiving.

• -info: Provide information about the contents of a backup file.

• -list: List the set of backups necessary to restore a database. This parameter 
requires use of the -device option parameter.

The purpose of the vbackup utility is to allow recovery from a device failure or 
from accidental deletion of data. If you use just the backup and restore features, you 
can recover to the point of the last backup. If you also use the roll forward features, 
you can recover to the point of the last committed transaction.

General Usage Notes

To use vbackup on a database, you must be the user who created the database, and 
invoke the command on the machine where the database physically resides.

If a database device is completely destroyed, you can recreate the database 
directories on another device with makedb and then use vbackup to both create and 
restore the database in one step.

If the recoverable error “device not ready” is encountered, you are given a chance 
to correct the error and resume the backup or restore. Except for this recoverable 
error, backups are not interactive and can therefore be called from a script or batch 
file.

For options and commands, it is not necessary to specify the full flag as long as 
enough is specified to be unambiguous. For example, since no other flag begins 
with ‘d’, you can shorten -device to any of the following: -devic, -devi, -dev, -de, or  
-d.

Commands

For the command parameter, you can use one of the following.

-backup dbname1 [dbname2 ...]
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Back up the one or more local databases specified as dbname.

You can back up multiple databases to a single tape drive, but not to a single file. To 
back up multiple databases to files, you must invoke the command multiple times, 
each time using a different file name.

Database backups can be “on-line,” which means that a database can be backed up 
while it is being used.

Backups can be “incremental,” which means saving only changes made since the 
last backup, or “full,” which means saving the entire database.

If multiple databases are backed up with a single command, the first one is stored in 
the position specified in the position parameter (see “Option Parameters” on 
page 117) and any additional ones are appended after it.

A database backup saves the results of all transactions committed at the time 
vbackup is invoked. For additional safety, you can also to use the -rollforward 
option in conjunction with the -backup command, but this is rarely necessary. This 
ensures that no log records are discarded unless they have been archived, either 
with another backup or as a result of roll forward archiving with the -log command.

You must invoke the -backup command on the machine on which the database to be 
backed up resides. You cannot backup a remote database.

For example, to backup a database named group to the file /tmp/level0 and also turn 
roll forwarding on:

vbackup -dev /tmp/level0 -rollforward -backup group

For this example, you will then see something like the text shown below (the 
version number actually shown will match your release number).

Invoking -restore immediately stops the specified databases (if running) and set 
them to dba/single-connection mode. After the restore is complete, the database 
mode of the specified databases will be set to multi-user mode.

Before the restore begins, you are given an opportunity to save the log files so that 
you can roll back to the last committed transaction.

The first restore done must always be a level 0 restore. Once this restore has 
successfully completed, you are asked if you would like to do an additional level of 
restore or if you would like to quit.
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If you answer yes to do another restore, you can insert a tape with any level 1 or 2 
backup that is incremental to the level 0 from which you just restored.

Before invoking the restore command, you must first locate the backups from 
which you will be restoring. If the database no longer exists, you must use your 
own records to determine the required backups. If the database is intact and you are 

restoring because you have accidentally deleted important data, you can use the 
-info command to list the backups necessary to restore to the most recently backed 
up state.

Once you know what your backups are, you must next locate the files in which they 
are stored. You are also asked for a safe location to which the current database 
logical log file can be copied so that it is not overwritten during the restore. 

You must invoke the -restore command on the machine on which the database to be 
restored resides. You cannot restore a remote database.

VERSANT Utility VBACKUP Version 5.0.5

Copyright (c) 1989-1996 VERSANT Object Technology

Backing up database ‘group’ to device ‘/tmp/level0’:

0%                 50%                100%

|         |         |         |        |

......................................

Backup has completed successfully.

-restore dbname1 [dbname2 ...]
Restore the one or more local databases specified as dbname.
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Failure Conditions 

When a restore starts, vbackup first copies the existing log file to a backup file 
name _backup_.log. If you encounter a failure during the restore operation, you 
need to copy the backup file to your logical log file, which is, by default, named 
logical.log. After doing this, you can retry to restore the database. If you do not 
copy the backup file to your logical log file before repeating a restore, you may lose 
the changes made by all recent committed transactions.

For example, to restore the database sqmdb from the file sqmdb.bak that is located 
in the root of the C:\ drive:

vbackup -dev c:\sqmdb.bak -restore group

On the following page is a sample of the interactive dialog and output you will see 
during a backup.
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After you have verified that the database was successfully restored, remember to 
remove ‘/versant/db/group/_backup_.log’.

At this point, when you quit, Versant will apply all log records in the file 
_backup_.log to the database.

If an error occurs and you cannot complete the restore and/or roll forward, before 
trying again, replace your logical log file with the _backup_.log file.

-info dbname1 [dbname2 ...]

List the set of backups and roll forward archives necessary to restore the specified 
databases to their most recently backed up state. If no backups have been made and 
roll forward has not been used, this list will be empty.

VERSANT Utility VBACKUP Version 5.0.5

Copyright (c) 1989-1996 VERSANT Object Technology

Restoring database ‘sqmdb’ from device ‘c:\sqmdb’:

During roll forward, would you like to apply records from the database’s 
current log file in addition to any archived records? [default = yes]

This logical log file must then be copied to a safe location so it is not 
overwritten during the restore.

Enter the path of the logical log [default = ‘/versant/db/group/logical.log’]

Enter the path for storing the copy [default = ‘/versant/db/group/
_backup_.log’]

0%   50%   100%

|     |     |     |     |

........................................

Restore has completed successfully.
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List entries have the following format:

Level backup_level made on date/time. comment

Where:

• backup_level: The incremental level of the backup: 0, 1, or 2.

• date/time: The date and time of the backup.

• comment: The comment, if any, entered at the time of the backup.

In many circumstances, such as restoring deleted objects, list information provided 
by -info will be available. However, if you are restoring from a damaged database, 
the same events that damaged your database may also damage backup list 
information. Accordingly, we recommend that you maintain your own records of 
the backups necessary to restore a database and not count on -info being able to 
provide the backup list.

The -info command will also tell you whether roll forward logging is currently on.

Option Parameters

For the options parameter, you can substitute zero or more of the following options.
-level [0 | 1 | 2]

The incremental level of backup to perform, either 0, 1, or 2. The default value is 0. 
Borland recommends always using level 0. This option will be ignored unless it is 
being used with the -backup command.

The level options are:

• level 0: Perform a full backup. (Recommended)

• level 1: Back up all changes made since the last level 0 backup.

• level 2: Back up all changes made since the last level 0 or level 1 backup, 
whichever was most recent.

The most recent set of backups can be viewed with the -info command. When a 
database is small, there is no problem with saving its entire state every time it is 
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backed up, but as database size increases, it becomes more important to set the level 
in a way which minimizes backup size and time.

• -device device_name: The backup device on which to read or write. Under 
NT, this must be a disk file.

• -comment backup_comment: Associate a comment with a backup. The 
default is no comment.

This option only makes sense when used with the -backup command and will be 
ignored when used with other commands. The comment specified will be stored 
with the backup and in the database and will appear when information about the 
backup is listed with the -list or -info commands.

A comment is useful for specifying the name or label of the tape on which the 
backup was made. When providing a comment, it is a good idea to enclose the 
comment string with single quotes. This prevents the shell from misinterpreting it 
as multiple arguments.

Restoring a Database

Before you attempt to restore a database:

1. Determine what backup files you need.

If you are recovering from a deletion or damaging of key objects, you can use 
the -info option to vbackup to list the set of backups necessary to restore the 
specified databases to their most recently backed up state. If list information 
is not available, you will have to rely on your own records. (See also the 
comments for the -info option.)

2. Locate and examine files on tapes or other backup device.

Once you know what backups are needed, you must next locate the tapes or 
file devices on which they are stored. You can use the -list option to vbackup 
to list the backup files stored on a backup device. 
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3. Perform the restore.

To restore from a device, use the -restore option to vbackup. You must restore 
in the proper order as listed by -info or your own records, working from the 
last full backup to the most recent incremental backup. (See also the 
comments for the -restore option.) 

Makedb Utility

Usage: makedb [options] <dbname> 

options: 

• -g: group database 

• -p: personal database, the default 

• -owneruser: make user as owner of database directory 

• -cpprofile db: copy profiles from the specified db directory 

• -nofeprofile: do not create front-end profile 

• -logging: turn logging on 

• -locking: turn locking on 

• -mtlatch: turn single_latch off 

• -noprint: suppress display messages

• dbname: database name

If it does not already exist, create a database directory named dbname per the 
options in the options parameter, and, if they do not already exist, create database 
support files.

You must run makedb or create a database directory and profile files manually 
before creating a database with createdb.

For a remote database, append the node name to the database name using the syntax 
dbname@node.
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For options you can substitute:

• -g: Group database. Group databases are accessible to many users at the 
same time.

• -p: Personal database. The default. Personal databases are accessible to one 
application at a time.

• -owner user: Make user the owner of the database directory. The default is 
to use the current login. You can only make someone else the owner if you 
are logged in as the Administrator.

• -cpprofile db: Copy the profile file profile.be from the specified db direc-
tory to the directory for the new database. This option works only if both 
databases are on the same machine. If only a database name is used rather 
than a full path name, the db directory under the database root directory is 
searched.

• -nofeprofile: Do not create an application process profile.

• -logging: Turn short transaction logging on.

• -locking: Turn short transaction locking on.

• -noprint: Do not display any messages while the command runs.

The directory created will be: /dbroot/dbname

A directory for the database that branches from the database root directory. The 
name of the directory will be the same as the database name specified as dbname.

Database support files that will be created, if they do not already exist, are:../.osc/
dbname

An application process profile file, located in the .osc directory branching from 
your home directory. This file contains operating parameters used when this data-
base is a session database.

• profile.be: A database server process profile file, located in the database 
directory. This file contains database creation and operating parameters.

• .lock: A lock file, which indicates whether or not the database has already 
been started.
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• .dbtype: A database type file, which indicates whether this is a personal or 
group database.

Examples:
makedb my_personal_database
makedb -g our_group_database

Createdb Utility

Usage: createdb [options] <dbname> 
options: 

• -ip: Reallocate and initialize the database 

• -noprint: Suppress display messages 

• dbname: Database name 

Create, format, and initialize a new database with the name dbname and either 
make the new database a part of an existing distributed database system or start a 
new database system. The database name dbname must be unique for the 
distributed database system it will belong to.

You must be the owner of the database (the database administrator) or the NT 
System Administrator to run this utility.

For a remote database, append the node name to the database name using the syntax 
database@node.

Options that may be specified in the options parameter are:

• -i: Reserve space for the system volume. 

Reserving space can prevent you from running out of space at runtime. For 
example, suppose you set the size of the system volume as 100 megabytes in your 
profile, but you really have only 60 megabytes physically available. In this case, if 
you use -i, you will immediately get an out-of-space error, but if you do not use -i, 
you will get an error at runtime as the system volume dynamically expands. If you 
have defined multiple storage volumes and the physical space in one volume is less 
than the logical space, you will get an out-space-error even though there is space 
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available in the next volume. Pre-allocating space may improve performance, 
because space will not have to be dynamically allocated. However, pre-allocating 
space will slow down the process of creating the database, and because the space is 
used immediately, it will prevent it from being used for other purposes. Space for 
log volumes is always pre-allocated according to the parameters set for the plogvol 
and llogvol size specifications.

• -noprint: Suppress display messages while running.

The createdb utility will update the osc-dbid file to register the new database with 
the existing distributed database system. The file osc-dbid containing the path and 
name of all databases in the system must be visible from your machine when you 
run createdb.

Examples:

createdb mydb

createdb -i mydb

Components of the newly created database will be:

• System volume: A system volume for catalog information and data storage, 
with a name, location, size, and device according to the specification in the 
server process profile file profile.be.

• Physical log volume: A physical log volume for physical data information 
related to logging and recovery, with a name, location, size, and device as 
specified in the server process profile file profile.be.

• Logical log volume: A logical log volume for transaction undo-redo infor-
mation related to logging and recovery, with a name, location, size, and 
device as defined in the server process profile file profile.be.

• .sharemem: A shared memory file, which contains a shared memory identi-
fier.
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Dbinfo Utility

Usage: dbinfo [options] <dbname> 
options: 

• -mset multi-user mode: This is the normal mode for a database. For a 
group database, this means that, per the normal definition of a group data-
base, any number of users can make any number of connections. For a per-
sonal database, this means that, per the normal definition of a personal 
database, only one user at a time can use it and can use it only as a session 
database.

• -0set unstartable mode: This mode prohibits all access to the database and 
prevents it from being started with the startdb utility or vutil tool. You 
should use the unstartable mode when you want to restore a database with 
the vbackup utility.

• -1set dbaonly single-connection mode: The database is startable, but it will 
only accept a single connection from a single client run by the database 
administrator.

• -dset dbaonly multi-connection mode: The database is startable, but it will 
only accept connections from clients run by the DBA.

• -pprint existing database mode: List the current database mode.

• -ccreate a new .lock file: This utility can be used only by the database 
administrator of a database. The database administrator is the user who cre-
ated the database.

• dbname: The database name.

Determine or set the current mode of the database specified as database_name.

 The dbinfo utility may be invoked either at the command line or through either the 
o_utility( ) or o_dbinfoapi( ) function.

You can change a database mode from one state to another at any time. After a new 
mode is set, it only affects new connections, and existing connections run without 
interruption. If you want to break existing connections, after running dbinfo, you 
must stop the database with stopdb.
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Removedb Utility

Usage: removedb [options] <dbname> 

Options: 

• -f : Forcibly stop and remove the database immediately even if it is currently 
running and other users are connected to it. Without the -f option, the data-
base will not be removed if it is in use by an active transaction. If it is in use, 
the message “Database in Use” will be printed and removedb will be termi-
nated.

• -rmdir: Remove the database directory and all files in it as well as data.

• -noprint: Suppress display messages while running.

• -dbname: The database name.

Stop the database if it is running, destroy and remove all volumes of the database 
dbname, and delete the database from the system database identifier file osc-dbid.

For a remote database, append the node name to the database name using the syntax 
database@node.

The database system osc-dbid file must be visible from your machine before you 
run removedb. Only the owner of a database can remove it.

When you remove a database, all volumes associated with the database are 
removed. This includes any extra storage volumes that have been added after the 
database was created. However, the database directories and profiles are not deleted 
when you run removedb unless you specify -rmdir. If you do not delete the 
directories and files, you can recreate a removed database using the same 
directories and profiles.

If you delete database directories manually but do not run removedb, the database 
numerical identifier and information about the old name and path remain in the osc-
dbid database system file. Also, if you delete the database directories manually, 
shared memory will not be removed.

Examples:

removedb my_db removedb -f my_db removedb -rmdir mydb
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SERVER CONTROL PANEL

Borland provides a control panel that allows you to configure your CaliberRM 
server. 

Note: The control panel contains advanced options, that should only be changed 
if the server is not functioning properly and at the discretion of Caliber Product 
Support. For information about contacting Support, see “Borland Support” on 
page 7.

To access the control panel, select Settings > Control Panel from the Windows 
Start menu. Double-click CaliberRM Server. The CaliberRM Server Settings 
dialog box is displayed.

The properties that are set on the Global Properties tab are:

• Database Name: Allows you to change the name or location of your database.

• Maximum # of Manager Threads: Determines the number of threads used by 
the server manager. The maximum number of threads that can be used is 20, 
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and the default for this option is 10. This option should only be changed at the 
direction of Borland Product Support.

• Idle Timeout Time: Determines how many hours the server will remain idle 
before it automatically recycles.

The properties that are set on the Logging tab are:

• Start a new log file: Determines how often you want to start a new log file.

• Log Buffer Size: Determines the number of traced transactions retained in 
memory. 

• Log Directory: Determines the location of the log file.

• Log Filter options: Determines the level of filtering you want. A check 
indicates the option is selected.

• Function Calls: When selected, the lowest level of filtering occurs. 

• Parameters: When selected, a medium level of filtering occurs.

• Details: When selected, the highest level of filtering occurs.

• Save log buffer option buttons: Determines when the log buffer is saved to 
the log file.
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The properties that are set on the Integrations tab are:

TestDirector Section:

• Enabled: Allows you to enable the TestDirector integration. A check indi-
cates the integration is enabled.

• Version: Allows you to set the version of TestDirector you are using.

Select Enterprise Section:

• Enabled: Allows you to enable the Select Enterprise integration. A check 
indicates the integration is enabled. 

Note: For more information on how to setup these integrations, see “Enabling 
Other Integrations” on page 422.
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There are two levels of administrative functionality: the SQM Framework 
Administrator and the CaliberRM Administrator. Framework Administrators 
perform the tasks particular to the SQM Framework and have access to most 
CaliberRM functions.

CaliberRM administrators are CaliberRM users that have special administrative 
rights in the Requirements Manager. They manage tasks that are requirement-
specific. Depending on their security profile, CaliberRM administrators do not 
necessarily have access to all user-level functions.

CALIBERRM ADMINISTRATIVE TASKS

Selecting File > Admin displays the Admin sub-menu, which contains some of the 
commands for performing administrative tasks.

Before users can begin entering requirements, a user with at least CaliberRM 
administrative privileges must perform some administrative tasks to organize 
projects and to group requirements. These tasks include:

• Modifying security profiles. See “Modifying Security Profiles” on page 94.
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• Creating other CaliberRM administrators. See “Creating CaliberRM 
Administrators” on page 130.

• Enabling requirements to be mapped or shared. See “Enabling Shared and 
Mapped Requirements” on page 130.

• Enforcing or disabling security for a project. See “Enforcing Security” on 
page 131.

• Maintaining the glossary. See “Maintaining Project Glossaries” on page 132.

• Creating requirement types. See “Requirement Types” on page 137.

• Assigning requirement types to projects. See “Setting Requirement Types 
Within a Project” on page 152.

• Modifying system attributes. See “System Attributes” on page 155.

• Creating and assigning user-defined attributes. See “User-Defined Attributes” 
on page 158.

CREATING CALIBERRM ADMINISTRATORS

CaliberRM administrators are created in CaliberRM by SQM Framework 
administrators, or by other CaliberRM administrators. To assign CaliberRM 
administrators, select File > Admin > CaliberRM Administrators from the menu. 

The list of users is displayed.

Select the box next to the names of the users that should have administrator 
privileges for all projects in CaliberRM.

ENABLING SHARED AND MAPPED REQUIREMENTS

Shared and mapped requirement must be enabled in CaliberRM by a CaliberRM 
administrator before a user can create mapped requirements.
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To enable shared and mapped requirements:

1. From the project drop-down list, open the project containing the requirements 
you want to share by clicking on the project name. The Project Info tab is dis-
played.

2. If the project that contains requirements you want to map, select the 
Requirements in this project can be mapped to shared requirements check 
box. 

If the project that contains requirements you want to share, select the 
Requirements in the project can be shared check box.

To share and map requirements in the same project, select both boxes.

ENFORCING SECURITY 

Security profiles created in Framework Administrator are enforced in the 
Requirements Manager on a per project basis. You must have at least CaliberRM 
administrator privileges to enforce security.
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To enforce or disable security for a project, select the appropriate option button in 
the Security area of the Project Info tab.

MAINTAINING PROJECT GLOSSARIES

In CaliberRM, you can have multiple glossaries that contain project-specific terms. 
Each project may have multiple glossaries assigned to it, with each glossary having 
a color assigned to it. When a term is selected, the color indicates which glossary 
the term belongs to. Project glossaries are created, modified and deleted in the 
Framework Administrator (see “Project Glossaries” on page 62) and terms are 
maintained by CaliberRM Administrators in CaliberRM.

Creating and Defining a Term

To create and define terms in the glossary:

1. Select Tools > Glossary. 

Enforce or disable 
security for a 
project
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The Glossary dialog box is displayed.

2. Select the glossary you want to add the term to from the drop-down list.

3. Click the New Term button.

Note: The following characters are not allowed in creating a term in 
CaliberRM glossaries: !, ?, :, :, “, ‘, (, ), [, ], {, }, carriage returns, and line 
feed.
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The Enter New Glossary Term dialog box is displayed.

4. Enter the new term and its definition.

5. Click OK. The term and its definition are displayed in the Glossary dialog box.

6. Click Close.

Note: You can also add a term by right-clicking a word in a requirement descrip-
tion. 

Modifying a Term

To modify a term and/or its definition:

1. Select Tools > Glossary. The Glossary dialog box is displayed.

2. Select the glossary that contains the term you want to modify from the 
Glossary Name drop-down list.

3. In the Type in the term to find section, enter the term you want to modify. The 
term is highlighted.
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4. Click the Modify Term button. The Modify Glossary Term dialog box is 
displayed.

5. Make any necessary changes to the term or its definition.

6. Click OK to close the Modify Glossary Term dialog box. 

7. Click Close to close the Glossary dialog box.

Deleting a Term

To delete a term and its definition from the glossary:

1. Select Tools > Glossary. The Glossary dialog box is displayed.

2. Select the glossary that contains the term you want to delete from the Glossary 
Name drop-down list.

3. In the Type in the term to find section, enter the term you want to delete. The 
term is highlighted.

4. Click the Delete Term button. A confirmation dialog box is displayed 
verifying that you want to delete the term.
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5. Click Yes if you want to delete the term, or No if you want to cancel the 
deletion.

The Glossary dialog box is displayed and the deleted term is no longer 
available in the glossary.

6. Click Close.
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Requirement types are high-level groups of requirements and are typically 
classified by their function (i.e., Business, Marketing, GUI, Hardware, Software, 
Testing, etc.). Requirement type definition is an administrative task and 
requirement types are available for use in all projects. 

CaliberRM supports multiple requirement types so that you can easily organize 
requirements. For example, a project may contain marketing, system, usability, 
software, coding and even testing requirement types. Requirements can be traced 
between requirement types to facilitate prioritization and aid in impact analysis.

Each requirement type can be customized using custom tabs and user-defined 
attributes. This is helpful because it allows you to track the information you need 
for each requirement type. For example, marketing requirements may need to track 
customer demand for each requirement, while software requirements may need to 
track estimated hours to implement. After you define attributes, you can assign 
them to custom tabs in each requirement type as needed. To learn more about user-
defined attributes, see “User-Defined Attributes” on page 158. 

CREATING A REQUIREMENT TYPE

There are two ways to create requirement types in CaliberRM: using the 
Requirement Type Creation Wizard or using Expert Mode. Expert Mode uses the 
dialog boxes to create requirement types, and is for those who are familiar with 
defining requirement type information.

Requirement Type Creation Wizard

Requirement types are created in the Requirements Manager. There are seven steps 
to creating a requirement type through the Requirement Type Creation Wizard. The 
wizard launches automatically when you select File > Admin > Requirement 
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Types and click the New button, if you have selected the Wizard option in the 
CaliberRM Options dialog box. Select Tools > Options > Wizards to verify the 
wizard is selected.

To create a requirement type using the Requirement Type Creation Wizard:

1. Select File > Admin > Requirement Types from the CaliberRM menu. The 
Requirement Types dialog box is displayed.

2. Click the New button. Step 1 of the Requirement Type Creation Wizard is 
displayed.

3. Enter a unique name and tag for the attribute. 

The tag is used as a prefix for the requirement ID number, and helps identify 
requirement types in the requirement grid and in reports. Typically, you 
would use a short tag (i.e., “SWR” for Software Requirements).

4. Click Next. Step 2 of the Requirement Type Creation Wizard is displayed as 
shown on the following page.
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5. Enter a description for the requirement type.

6. Click Next. Step 3 of the Requirement Type Creation Wizard is displayed.
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7. Click the New button if you want to create a new custom tab for your new 
requirement type. See “Creating Custom Tabs” on page 147.

8. Click Next. Step 4 of the Requirement Type Creation Wizard is displayed.

9. Choose the appropriate default access level for the requirement type:

None: Does not allow users to see this requirement type at all.

List: Allows users to see only a list of requirements of this type, but not 
the data.

View: Allows users to see the requirements and their data, as well as mod-
ify attributes, but does not allow users to create requirements.

Create: Allows users to see the requirements and their data, and allows 
users to modify and create requirements.

Note: See “Creating a Security Profile” on page 90 for more information on 
requirement type access levels.
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10. Click Next. Step 5 of the Requirement Type Creation Wizard is displayed.

11. Choose the appropriate default delete level for requirements of the new 
requirement type:

None: Does not allow the deletion of any requirements in that requirement 
type.

Owned: Only allows deletion to the requirement the user owns for that 
requirement type.

Any: Allows anyone to delete requirements of this type.

Note: See “Creating a Security Profile” on page 90 for more information on 
requirement type delete levels.

12. Click Next. Step 6 of the Requirement Type Creation Wizard is displayed as 
shown on the following page.
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13. For each attribute listed, select the circumstances for modification. This 
determines whether or not users can modify the attribute in requirements of that 
type.

None: Allows no modification to the particular attribute of the require-
ment type.

Owned: Only allows modification to the particular attribute the user owns 
for that requirement type.

Any: Allows any modification to the particular attribute for the require-
ment type.

Note: See “Creating a Security Profile” on page 90 for more information on 
attribute modification levels.

14. Click Next. Step 7 of the Requirement Type Creation Wizard is displayed as 
shown on the following page.
142 � Creating a Requirement Type  



CHAPTER 10: REQUIREMENT TYPES
15. To select the projects you want to assign the requirement type to, select the box 
to the left of the project name.

16. Click Next. The New Requirement Type Information screen is displayed.
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17. Verify the information you have entered. If the information is correct, click 
Finish. If not, click Back and make the necessary changes.

The requirement type is created.

Creating a Requirement Type Using Expert Mode

There are two steps to creating a requirement type using Expert Mode: defining the 
requirement type and setting the requirement type’s default security access. 

Note: To create a new requirement type using Expert Mode, the option to use wiz-
ards must be cleared in Tools > Options > Wizards.

Defining the Requirement Type

To create a requirement type:

1. Select File > Admin > Requirement Types from the CaliberRM menu. The 
Requirement Types dialog box is displayed.

2. Click the New button. The New Requirement Type dialog box is displayed.
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3. Enter a unique name and a description in the appropriate fields.

4. Enter a tag for the requirement type. 

The tag is used as a prefix for the requirement ID number, and helps identify 
requirement types in the requirement grid and in reports. Typically, you 
would use a short tag (i.e., “SWR” for Software Requirements).

5. You can create a custom tab for your requirement type by clicking the New 
button. See “Creating Custom Tabs” on page 147.

6. You can now set the requirement type’s default security access. See “Setting 
the Default Security Access for a Requirement Type” below for more 
information.

7. Click OK to save the changes, or Cancel to exit the dialog box without saving.

8. Click Close in the Requirement Types dialog box.

Setting the Default Security Access for a Requirement Type

When you create a new requirement type, you can set its default security access. 
This access determines whether users can add, modify or delete requirements of 
this type. For more information on security and security profiles, see “Security” on 
page 89.

To set a requirement type’s default security access:

1. Within a selected requirement type’s dialog box, click the Default Access but-
ton.
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The Default Access dialog box is displayed.

2. Select the option button for the appropriate Access level. Each option allows 
users in the groups assigned to the default security profile the various levels of 
access described below:

None: Does not allow users to see this requirement type at all.

List: Allows users to see only a list of requirements of this type, but not 
the data.

View: Allows users to see the requirements and their data, as well as mod-
ify attributes, but does not allow users to create requirements.

Create: Allows users to see the requirements and their data, and allows 
users to modify and create requirements.

3. Select the option button for the appropriate Delete level: 

None: Does not allow the deletion of any requirements in that requirement 
type.

Owned: Only allows deletion of the requirement the user owns for that 
requirement type.

Any: Allows anyone to delete requirements of this type.
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4. Select the option button for the appropriate Modification level for each 
attribute in the list. This determines whether or not users can modify the 
attribute in requirements of the type.

None: Allows no modification to the particular attribute of the require-
ment type.

Owned: Only allows modification to the particular attribute the user owns 
for that requirement type.

Any: Allows any modification to the particular attribute for the require-
ment type.

5. Click OK to save changes, or Cancel to exit without saving.

Note: CaliberRM enforces security while creating a new requirement. You 
will be unable to modify fields unless permission is granted by your security 
profile. 

CREATING CUSTOM TABS

You can create and delete custom tabs with specific user-defined attributes in   
CaliberRM.

To create custom tabs:

1. Select File > Admin > Requirement Types from the CaliberRM menu.

2. Select a requirement type from the Requirement Types list. The Edit button 
becomes available.

3. Click Edit.
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The window for the chosen requirement type is displayed.

4. Click New in the Custom Tabs section of the requirement type window. The 
New Custom Tab window is displayed.
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5. Enter a name for your new custom tab in the Name field. The name should be 
64 characters or less to avoid display problems.

Note: You have the option to assign an icon for your custom tab by clicking 
the Change Icon button and navigating to the icon you want to use.

6. Select the user-defined attribute(s) from the Available list and move to the 
Selected list by clicking the Move Left button. To choose all of the attributes 
in the list, select the Move All Left button.

To change the attribute order, select attributes in the selected list and click the 
Move Up or Move Down button.

7. Click OK. The New Custom Tab window closes.

8. Click OK to close the window for the requirement type and add the custom tab.

Note: Custom tabs are specific to the requirement type. Therefore, you must 
create a custom tab for each requirement type that you want to contain a cus-
tom tab.

9. Click Close to close the requirement types window.

Note: User-defined attributes are assigned to requirements and displayed on 
custom tabs. If you display the same user-defined attribute on multiple cus-
tom tabs in a single requirement type, the user-defined attribute will be the 
same on all tabs. If you change the data on one tab, the data changes on all 
tabs. 

DELETING CUSTOM TABS

Once you have created a custom tab, you may delete it if necessary.

WARNING: DELETING A CUSTOM TAB MAY REMOVE ATTRIBUTES FROM 
REQUIREMENTS OF THE AFFECTED REQUIREMENT TYPE. IF THE ATTRIBUTE 
IS ON MORE THAN ONE TAB IN A TYPE, THE DATA IS ONLY REMOVED FROM 
THE TAB YOU DELETE. 

THIS IS A RESOURCE INTENSIVE OPERATION IF THERE ARE MANY REQUIRE-
MENTS IN THE TYPE WHERE A TAB IS BEING DELETED. THIS SHOULD NOT 
BE DONE ON AN ACTIVE SYSTEM AS USERS MAY BE AFFECTED.
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To delete a custom tab:

1. Select File > Admin > Requirement Types from the CaliberRM menu. The 
Requirement Types window is displayed.

2. Select the requirement type containing the custom tab from the Requirement 
Types list.

3. Click Edit. The dialog box for the chosen requirement type is displayed.

4. Select the custom tab to delete.

5. Click Delete.

6. Click OK to close the chosen requirement type’s window.

7. Click Close to close the Requirement Types window.

Your custom tab is deleted.

MODIFYING A REQUIREMENT TYPE

WARNING: MODIFYING A REQUIREMENT TYPE MAY AFFECT OTHER 
PROJECTS. 

THIS IS A RESOURCE INTENSIVE OPERATION IF THERE ARE MANY REQUIRE-
MENTS IN THE TYPE WHERE AN ATTRIBUTE IS BEING CHANGED. THIS 
SHOULD NOT BE DONE ON AN ACTIVE SYSTEM AS USERS MAY BE 
AFFECTED.

To modify an existing requirement type:

1. Select File > Admin > Requirement Types from the menu. The Requirement 
Types dialog box is displayed.

2. Select the requirement type to modify. 

3. Click the Edit button. The dialog box for the chosen requirement type is 
displayed.

Note: You may also right-click on the requirement type in the requirement 
tree and select Modify in the pop-up menu to display the requirement type’s 
dialog box.
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4. Modify the requirement type name, tag, description, security access and/or 
custom tab(s).

For instructions on modifying security access, see “Setting the Default 
Security Access for a Requirement Type” on page 145. For instructions on 
modifying custom tabs, see “Creating Custom Tabs” on page 147. 

5. Click OK to save the changes, or Cancel to exit without saving the changes.

6. Click Close in the Requirement Types dialog box.

DELETING A REQUIREMENT TYPE

WARNING: TO PREVENT DATA LOSS IN THE CURRENT PROJECT, AS WELL AS 
OTHER PROJECTS, YOU CANNOT DELETE A REQUIREMENT TYPE THAT IS IN 
USE IN ANY PROJECT. 

THIS IS A RESOURCE INTENSIVE OPERATION IF THERE ARE MANY REQUIRE-
MENTS IN THE TYPE WHERE AN ATTRIBUTE IS BEING CHANGED. THIS 
SHOULD NOT BE DONE ON AN ACTIVE SYSTEM AS USERS MAY BE 
AFFECTED.

To delete a requirement type:

1. Select File > Admin > Requirement Types from the CaliberRM menu. The 
Requirement Types dialog box is displayed.

2. Select the requirement type to delete.

3. Click the Delete button.

A message is displayed verifying that you want to delete the requirement 
type.

4. Click Yes to delete the requirement type, or No to save it.

Note: If the requirement type is in use in any project, you cannot delete it. You 
can, however, remove it from use in a project (see Setting Requirement Types 
Within a Project section below).

5. Click Close in the Requirement Types dialog box. The requirement type is 
deleted.
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SETTING REQUIREMENT TYPES WITHIN A PROJECT 

When you select a new project to work with, a dialog box is displayed asking you to 
choose the requirement types that will be used in that project. You must choose at 
least one requirement type before you can create requirements. 

To set requirement types within a project:

1. Select a project to work with from the drop-down list or select File > Admin > 
Set Requirement Types from the CaliberRM menu. The Project Require-
ment Types dialog box is displayed.

2. Select the box to the left of a requirement type to assign it to the current project.

Note: If the requirement type you want is not listed, you can create a new 
requirement type by clicking the New button (see “Creating a Requirement 
Type” on page 137). 

3. Click OK to save changes, or Cancel to exit without saving the changes.

The requirement types you chose are displayed in the requirement list.
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WARNING: YOU MAY ONLY REMOVE REQUIREMENT TYPES ASSIGNED TO A 
PROJECT IF THE REQUIREMENT TYPE DOES NOT HAVE EXISTING REQUIRE-
MENTS IN THAT PROJECT. OTHERWISE, THE REQUIREMENT TYPE CHECK 
BOX IS DISABLED.

THE REQUIREMENT TYPE VIEW

After you have assigned a requirement type to a project you can select it and view 
the details of the requirement type. 

When you select a requirement type, the following tab set is displayed.

• Description: A read-only description of the requirement type.

• Custom Tabs: A read-only list of the custom tabs assigned to the requirement 
type and the user-defined attributes assigned to the selected custom tab.

• Summary: An editable text field that describes the requirement type for the 
active project.

ADDING A SUMMARY

The Summary tab provides a text area in which you may document information that 
may be specific to this requirement type for the project it is assigned to. You can 
edit this field at any time.
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Attributes are characteristics that help define a requirement. CaliberRM supports 
both system and user-defined attributes. System attributes are those that CaliberRM 
automatically assigns to each requirement. 

The system attributes that CaliberRM stores for each requirement are priority and 
status. The user defines the list of values for these system attributes, so you can use 
the terms that best fit your organization’s needs. 

User-defined attributes are those you create, define and assign to requirement types. 
They can be one of several different types of data, including text, integer, date, 
boolean and users.

SYSTEM ATTRIBUTES

The system attributes that CaliberRM stores for each requirement are status and 
priority. Each of these attributes allow you to choose from a list of values. For 
example, the status list may contain the values “submitted,” “accepted” and 
“rejected.” Or you may have levels for priority ranging from 1 to 5, or you may 
have terms such as “high,” “medium” and “low.”

Within CaliberRM, you can also set an attribute’s default security access (see 
“Setting the Attribute’s Default Security Access” on page 178).

MODIFYING A SYSTEM ATTRIBUTE

WARNING: MODIFYING A SYSTEM ATTRIBUTE’S CHARACTERISTICS IN A 
PROJECT MODIFIES ITS CHARACTERISTICS IN ALL PROJECTS, BUT NOT ITS 
VALUE.

To modify a system attribute in CaliberRM:

1. Select File > Admin > System Attributes from the menu.
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The System Attributes dialog box is displayed.

2. Select the attribute you want to edit in the list, and click the Edit button.

The attribute’s dialog box is displayed.

Note: You cannot modify the name, type or description of system attributes.
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Setting the Standard Options

Within CaliberRM, you can set certain standard options for the system attributes. 
The standard options that can be set are:

Initial value: Determines the source of the attribute’s initial value: inherit 
value from the parent requirement, use default value specified, or force 
user to enter a value.

Increment major revision number: Increments the major revision num-
ber in the requirement’s change history when a change is made to this 
attribute (see “Requirement History” on page 218). A check indicates this 
option is enabled.

Make requirement traceability links suspect: Changes all traceability 
links for the requirement to suspect links when a change is made to this 
attribute. A check indicates this option is enabled.

Customizing Values
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To customize the values shown in the Single Selection List section of the system 
attribute’s dialog box:

1. To rename a list item, select the item in the list and type in the new name.

Note: You may create a new list item by selecting a list item and clicking the 
Insert Before or Insert After button.

2. Repeat Step 1 until you have renamed or created all the list items.

Note: To delete a list item, select the item in the list and clicking the Delete 
button. 

3. Order the list items as desired by selecting items and clicking the Move Up or 
Move Down button.

4. Select the default list item from the drop-down list.

Note: To set the default to blank, do not select an item in the drop-down list.

5. Click OK to save changes, or Cancel to exit without saving changes.

6. Click Close in the System Attributes dialog box.

USER-DEFINED ATTRIBUTES

A user-defined attribute is one that a user defines and assigns to a requirement type. 
For example, GUI requirements may contain an attribute called “screen width” 
while functional requirements may contain an attribute called “response time.” 
Each user-defined attribute contains several standard options that can be set, as well 
as options defined by the attribute type. The standard options that can be set are 
listed below.

• Initial value: Determines the source of the attribute’s initial value: inherit from 
the parent requirement, use default value specified, or force user to enter a 
value.

Note: If you set to Force, a user must have security access to modify this 
attribute or he or she cannot create new requirements of this type. 
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• Increment major revision number: Increments the major revision number in 
the requirement’s change history when a change is made to this attribute. See 
“Requirement History” on page 218. A check indicates this option is enabled.

• Make requirement traceability links suspect: Changes all traceability links 
for the requirement to suspect links when a change is made to this attribute. A 
check indicates this option is enabled.

Attribute Types

User-defined attributes can be one of 13 different types of data and are listed in the 
table below.

Attribute Type Description

Boolean A check box that allows true (checked) or false (cleared) values 
only.

Date An edit box that accepts dates. All dates are formatted with a 
4-digit year.

Duration A spin box that allows you to choose from a range of values. 
The duration time span (days, weeks, etc.) is displayed to the 
right of the spin box.

Float An edit box that can accept any number value. Numbers are 
rounded to three decimal places.

Integer An edit box that accepts only integer values. Values can range 
from -2,147,483,648 to 2,147,483,647.

Multiple selection list A list box that displays a list of items to choose from, where 
multiple items can be selected.

Multiple selection 
group list

A list box that displays a list of groups to choose from, where 
multiple items can be selected. With this attribute comes the 
option to limit the number of groups chosen, and the option to 
allow selection from all groups, or only those assigned to the 
list.
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CREATING AN ATTRIBUTE

There are two ways to create user-defined attributes: using the Attribute Creation 
Wizard or using Expert Mode. Expert Mode uses the dialog boxes to create 
attributes and is for those who are familiar with defining attribute information.

ATTRIBUTE CREATION WIZARD

There are five steps to creating an attribute through the Attribute Creation Wizard. 
The wizard launches automatically when you select File > Admin > User Defined 
Attributes and click the New button, if you have selected the Wizard option in 
CaliberRM Options. Select Tools > Options > Wizards to verify the wizard is 
selected.

Multiple selection 
user list

A list box that displays a list of users to choose from where 
multiple items can be selected. With this attribute comes the 
option to limit the number of users chosen, and the option to 
allow selection from all users, or only those assigned to the list.

Multiple line text field An edit box that displays 1 or more lines and can accept a 
maximum of 10,000 characters.

Single selection list A drop-down list that allows you to choose a single selection 
from the list.

Single text line An edit box that can accept a maximum of 128 characters.

Single selection 
group list

A drop-down list that allows you to choose a single group from 
the list. With this attribute comes the option to allow selection 
from all groups, or only those assigned to the list.

Single selection user 
list

A drop-down list that allows you to choose a single user from 
the list. With this attribute comes the option to allow selection 
from all users, or only those assigned to the list.

Attribute Type Description
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To create a user-defined attribute using the Attribute Creation Wizard:

1. Select File > Admin > User Defined Attributes from the menu. The 
User-Defined Attributes dialog box is displayed.

2. Click the New button. Step 1 of the Attribute Creation Wizard is displayed.

3. Enter a unique name for the attribute.

Note: User-defined attributes that have names identical to CaliberRM key-
words cannot be used in a document. To avoid conflicts, the CaliberRM key-
words should not be used as attribute names. See page 343 for CaliberRM 
keywords.

4. Select the type for the attribute. See “Attribute Types” on page 159 for attribute 
type descriptions.

5. Enter a description for the attribute.

6. Click Next.
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Step 2 of the Attribute Creation Wizard is displayed. The options displayed at 
this step depend upon the attribute type you selected in Step 4.

7. For the selected attribute type, enter the parameters shown on the screen. 

8. Click Next. Step 3 of the Attribute Creation Wizard is displayed.
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9. Choose the appropriate method for obtaining the attribute’s initial value: inherit 
from parent requirement, use default value specified, or force user to enter a 
value.

10. Click Next. Step 4 of the Attribute Creation Wizard is displayed.

11. If you want a change to the attribute to increment the major revision number in 
the change history, select the appropriate check box.

12. If you want a change to the attribute to make the requirement’s traceability 
links suspect, select the appropriate check box.

13. Click Next.
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Step 5 of the Attribute Creation Wizard is displayed.

14. Select the option button for the appropriate attribute modification level. This 
determines whether or not users can modify the attribute in requirements of that 
type.

• None: Allows no modification to attributes of the requirement type.

• Owned: Only allows modification to the attributes the user owns for that 
requirement type.

• Any: Allows any modification to the attributes for the requirement type.

Note: You do not have to assign the attribute to a requirement type to change the 
modification level for that type.
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15. Click Next. The New Attribute Information dialog box is displayed.

16. Verify that the information you have entered is correct. If not, click the Back 
button and make the necessary changes.

17. Click Finish. The attribute is created.

CREATING A USER-DEFINED ATTRIBUTE USING EXPERT MODE

There are four steps to creating a user-defined attribute using Expert Mode: 
defining the attribute, setting the standard options, setting the attribute type options 
and setting the attribute’s default security access.

Note: To create a user-defined attribute, the wizards option must be cleared in 
Tools > Options > Wizards.

Defining the Attribute

To define the attribute:
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1. Select File > Admin > User Defined Attributes from the menu. The User 
Defined Attributes dialog box is displayed.

2. Click New. The New User-Defined Attributes dialog box is displayed.

3. Enter a name and description for the attribute.

Note: User-defined attributes that have names identical to CaliberRM key-
words cannot be used in a document. To avoid conflicts, the CaliberRM key-
words should not be used as attribute names. See page 343 for CaliberRM 
keywords.

4. Select the attribute type from the drop-down list (see page 159 for descriptions 
of the attribute types).

Setting the Standard Options

To set the standard options:
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1. Determine the source of the attribute’s Initial Value: inherit from parent 
requirement, use default value specified, or force user to enter a value.

2. If you want a change to this attribute to increment the major revision number in 
the requirement’s change history, select the Increment major revision 
number check box.

3. If you want a change to this attribute to cause the traceability links to be 
suspect, select the Make requirement traceability links suspect check box. 

Setting the Attribute Type Options

Choose the appropriate attribute type from the following sections to finish creating 
the attribute. Depending on the attribute type selected, the bottom of the User 
Defined Attribute dialog box contains different options.

Boolean

The boolean attribute creates a check box that allows true (checked) and false 
(cleared) values only.

To set the options for this attribute type:

1. If you want the default value to be true, select the Default check box. If you 
want the default value to be false, clear the Default check box.

2. You can now set the attribute’s access. See “Setting the Attribute’s Default 
Security Access” on page 178.

3. Click OK to save changes, or Cancel to exit without saving.
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Date

The date attribute creates an edit box that accepts dates. All dates are formatted and 
stored with a 4-character year.

Note: Date display format is set by selecting Tools > Options > Appearance tab. 
Date can be displayed using Windows long or short date formats.

To set the options for this attribute type:

1. Enter the latest date you want the user to be able to select in the Maximum 
field.

Note: CaliberRM stores all year fields as 4 characters.

2. Enter the earliest date you want the user to be able to select in the Minimum 
field.

3. Select the Default option you prefer:

• Current: the date the attribute is created

• User Defined: a date specified by the user

• Blank: allows a blank default date

4. You can now set the attribute’s access. See “Setting the Attribute’s Default 
Security Access” on page 178.

5. Click OK to save changes, or Cancel to exit without saving.
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Duration

The duration attribute creates a spin box that allows you to choose from a range of 
values. The duration time span (days, weeks, etc.) is displayed to the right of the 
spin box.

To set the options for this attribute type:

1. Select the time span you want to use (years, months, weeks, etc.) by selecting 
the appropriate option button.

2. Enter the minimum duration value.

3. Enter the maximum duration value.

Note: If you leave the minimum and maximum duration values at “0,” there 
will be no minimum or maximum value.

4. Select the default duration value.

5. You can now set the attribute’s access. See “Setting the Attribute’s Default 
Security Access” on page 178.

6. Click OK to save changes, or Cancel to exit without saving.
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Float

The float attribute creates an edit box that accepts any number value, with up to 3 
decimal places.

To set the options for this attribute type:

1. Choose the minimum number value.

Note: CaliberRM rounds decimal values to 3 places.

2. Choose the maximum number value. 

3. Choose the default number value.

4. You can now set the attribute’s access. See “Setting the Attribute’s Default 
Security Access” on page 178.

5. Click OK to save changes, or Cancel to exit without saving.

Integer

The integer attribute creates an edit box that accepts only integer values from 
-2,147,483,648 to 2,147,483,647.

To set the options for this attribute type:

1. Choose the minimum whole number value.

2. Choose the maximum whole number value. 

3. Choose the default number value.
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4. You can now set the attribute’s access. See “Setting the Attribute’s Default 
Security Access” on page 178.

5. Click OK to save changes, or Cancel to exit without saving.

Multiple Selection List

The multiple selection list attribute creates a list box displaying a list of items to 
choose from, with check boxes to mark selection. The order of the attributes in the 
list also determines the sort order.

To set the options for this attribute type:

1. Enter a new list item by clicking on the first blank line in the list box and typing 
in the name.

Note: You may rename a list item by selecting the item in the list and typing in 
the new name.

2. Repeat Step 1 until you have entered all the list items.

Note: You may delete a list item by selecting the item in the list and clicking 
the Delete button. If a requirement contains the value list item that you delete, 
the requirement will retain that value, but you will not be able to apply the 
value to new or modified requirements.

3. Order the list items as desired by selecting items and clicking the Move Up or 
Move Down button.

Click here to 
create a new 
item.

You can also 
click here.
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4. Select the default item(s) by selecting the box to the left of each item in the 
Default Selections list. 

5. You can now set the attribute’s access. See “Setting the Attribute’s Default 
Security Access” on page 178.

6. Click OK to save changes, or Cancel to exit without saving changes.

Multiple Selection Group List

The multiple selection group list attribute creates a list box displaying the list of 
groups to choose from, with check boxes to mark selection. With this attribute 
comes the option to limit the number of groups chosen, and the option to allow 
selection from all groups, or only those assigned to the list. 

To set the options for this attribute type:

1. In the left list box, select the box to the left of each group you want to include 
in the selection list.

2. Set the maximum number of groups the user can choose in the Maximum 
groups list box.

3. If you want the user to have the option of choosing from all groups as well as 
those in the selection list, select the Can select from all groups check box.

4. Select the default group(s) in the right list box by selecting the box to the left of 
each group.
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Note: If you want to select the default group(s) from all groups, and the Can 
select from all groups check box is selected, you can select the Select from 
all groups check box to select any user in any group.

5. You can now set the attribute’s access. See “Setting the Attribute’s Default 
Security Access” on page 178.

6. Click OK to save changes, or Cancel to exit without saving.

Multiple Selection User List

The multiple selection user list attribute creates a list box displaying a list of users 
to choose from, with check boxes to mark selection. With this attribute comes the 
option to limit the number of users chosen, and the option to allow selection from 
all users, or only those assigned to the list. 

To set the options for this attribute type:

1. In the left list box, select the box to the left of each user you want to include in 
the selection list.

2. Set the maximum number of users the user can choose in the Maximum users 
list box.

3. If you want the user to have the option of choosing from all users as well as 
those in the selection list, select the Can select from all users check box.

4. Select the default user(s) in the right list box by selecting the box to the left of 
each user.
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Note: If you want to select the default user(s) from all users, and the Can 
select from all users check box is selected, you can select the Select from all 
users check box to select any user in any group.

5. You can now set the attribute’s access. See “Setting the Attribute’s Default 
Security Access” on page 178.

6. Click OK to save changes, or Cancel to exit without saving.

Multiple Line Text Field

The multiple line text field attribute creates an edit box that displays 1 or more lines 
and can accept a maximum of 10,000 characters. 

To set the options for this attribute type:

1. Choose the minimum number of characters.

2. Choose the maximum number of characters. 

3. Choose the number of lines to display.

4. Enter the default text or leave blank for no text.

5. You can now set the attribute’s access. See “Setting the Attribute’s Default 
Security Access” on page 178.

6. Click OK to save changes, or Cancel to exit without saving.
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Single Selection List

The single selection list attribute creates a drop-down list box that allows you to 
choose a single selection from the list. The user configures the items in the list. The 
order of the attributes in the list also determines the sort order.

To set the options for this attribute type:

1. Enter a new list item by clicking on the first blank line in the list box and typing 
in the name.

Note: You may rename a list item by selecting the item in the list and typing in 
the new name.

2. Repeat Step 1 until you have entered all the list items.

Note: You may delete a list item by selecting the item in the list and clicking 
the Delete button. If a requirement contains the value list item that you delete, 
the requirement will retain that value, but you will not be able to apply the 
value to new or modified requirements.

3. Order the list items as desired by selecting items and clicking the Move Up or 
Move Down button.

4. Select the default list item from the drop-down list box. 

Note: To set the default to blank, do not select an item in the drop-down list 
box.

5. You can now set the attribute’s access. See “Setting the Attribute’s Default 
Security Access” on page 178.

6. Click OK to save changes, or Cancel to exit without saving changes.

You can also 
click here.

Click here 
to create a 
new item.
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Single Selection Group List

The single selection group list attribute creates a drop-down list box that allows you 
to select a single group from the list specified. With this attribute comes the option 
to allow selection from all groups, or only those assigned to the list.

To set the options for this attribute type:

1. Select the box to the left of each group you want to include in the selection list.

2. If you want the user to have the option of choosing from all groups as well as 
those in the selection list, select the Can select from all groups check box.

3. Select the default group from the drop-down list box.

Note: If you want to select the default group from all groups, and the Can 
select from all groups check box is selected, you can select the Select from 
all groups check box.

4. You can now set the attribute’s access. See “Setting the Attribute’s Default 
Security Access” on page 178.

5. Click OK to save changes, or Cancel to exit without saving.
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Single Selection User List

The single selection user list attribute creates a drop-down list box that allows you 
to select a single user from the list specified. With this attribute comes the option to 
allow selection from all users, or only those assigned to the list.

To set the options for this attribute type:

1. Select the box to the left of each user you want to include in the selection list.

2. If you want the user to have the option of choosing from all users, as well as 
those in the selection list, select the Can select from all users check box.

3. Select the default user from the drop-down list box.

Note: If you want to select the default user from all users, and the Can select 
from all users check box is selected, you can select the Select from all users 
check box.

4. You can now set the attribute’s access. See “Setting the Attribute’s Default 
Security Access” on page 178.

5. Click OK to save changes, or Cancel to exit without saving.
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Single Text Line

The single text line attribute creates an edit box that can accept a maximum of 128 
characters.

To set the options for this attribute type:

1. Choose the minimum number of characters.

2. Choose the maximum number of characters. 

3. Enter the default text, or leave blank for no text.

4. You can now set the attribute’s access. See “Setting the Attribute’s Default 
Security Access” on page 178.

5. Click OK to save changes, or Cancel to exit without saving.

Setting the Attribute’s Default Security Access

When you create a new attribute, you can set its default security access. This access 
determines whether users can modify the attribute in each requirement type. For 
more information on security and security profiles, see “Security” on page 89.

To set the attribute’s default access:

1. Within the attribute’s dialog box, click the Access button.
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The Attribute Access dialog box is displayed.

2. Select the option button for the appropriate attribute modification level. This 
determines whether or not users can modify the attribute in requirements of that 
type.

• None: Allows no modification to attributes of the requirement type.

• Owned: Only allows modification to the attributes the user owns for that 
requirement type.

• Any: Allows any modification to the attributes for the requirement type.

Note: You do not have to assign an attribute to a requirement type to change 
the modification level for that requirement type.

3. Repeat Step 2 for the remaining requirement types.

4. Click OK to save changes, or Cancel to exit without saving.

MODIFYING A USER-DEFINED ATTRIBUTE

WARNING: MODIFYING A USER-DEFINED ATTRIBUTE’S CHARACTERISTICS IN 
A PROJECT MODIFIES ITS CHARACTERISTICS IN ALL PROJECTS, BUT NOT ITS 
VALUE.
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To modify a user-defined attribute:

1. Select File > Admin > User Defined Attributes from the menu. The User 
Defined Attributes dialog box is displayed.

2. Select the attribute you want to edit from the list and click the Edit button. The 
attribute’s dialog box is displayed.
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Note: The options at the bottom of the dialog box depend upon the attribute 
type you select in Step 2.

3. Edit the options you want to modify.

Note: To prevent loss of data, the attribute type cannot be modified once the 
attribute is saved.

4. Click OK to save changes, or Cancel to exit without saving changes.

USER-DEFINED ATTRIBUTE ORDERING

Once you have created your user-defined attributes, you can arrange them in the 
order you want them to appear.

Note: You must have CaliberRM Administrator privileges to arrange user-defined 
attribute order.

To arrange your user-defined attributes:

1. Select File > Admin > Requirement Types.

2. Select the requirement type whose user-defined attribute you want to arrange.

3. Click Edit. The requirement type window is displayed.

4. Select the custom tab where the attributes you want to arrange are located.

5. Click Edit. The Edit Custom Tab window is displayed.

6. Select the attribute you wish to move in the selected list.

7. Use the Move Up or Move Down button to move the attribute higher or lower 
in the list.

8. Click OK to save the order.

DELETING A USER-DEFINED ATTRIBUTE

WARNING: DELETING A USER-DEFINED ATTRIBUTE IN A PROJECT DELETES 
IT IN ALL PROJECTS! BEFORE YOU CAN DELETE A USER-DEFINED 
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ATTRIBUTE, YOU MUST REMOVE IT FROM ALL CUSTOM TABS IN ALL 
REQUIREMENT TYPES IN WHICH IT APPEARS.

THIS IS A RESOURCE INTENSIVE OPERATION IF THERE ARE MANY REQUIRE-
MENTS IN THE TYPE WHERE AN ATTRIBUTE IS BEING CHANGED. THIS 
SHOULD NOT BE DONE ON AN ACTIVE SYSTEM AS USERS MAY BE 
AFFECTED.

To delete a user-defined attribute:

1. Select File > Admin > User Defined Attributes from the menu. The User 
Defined Attributes dialog box is displayed.

2. Select the attribute you want to delete from the list.

3. Click the Delete button. A message is displayed verifying that you want to 
delete the attribute.

4. Click Yes to delete the attribute, or No to save it.

5. Click Close to close the User-Defined Attributes dialog box.

ASSIGNING USER-DEFINED ATTRIBUTES TO A REQUIREMENT TYPE

WARNING: MODIFYING A REQUIREMENT TYPE IN A PROJECT MODIFIES IT IN 
ALL PROJECTS.

THIS IS A RESOURCE INTENSIVE OPERATION IF THERE ARE MANY REQUIRE-
MENTS IN THE TYPE WHERE AN ATTRIBUTE IS BEING CHANGED. THIS 
SHOULD NOT BE DONE ON AN ACTIVE SYSTEM AS USERS MAY BE 
AFFECTED.

User-defined attributes are assigned to custom tabs in a requirement type.

To assign user-defined attributes to a requirement type:

1. Select File > Admin > Requirement Types from the menu. The Requirement 
Types dialog box is displayed.

2. Select the requirement type you want to edit.
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3. Click the Edit button. The requirement type’s dialog box is displayed.

4. Select the custom tab you want to assign the user-defined attribute to and click 
the Edit button.

The Edit Custom Tab dialog box is displayed.
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5. Select an attribute from the Available list and click the Move Left button to 
move it to the Selected list.

Note: You can move all attributes at once by clicking the Move All Left but-
ton.

In this database, you can also create a new user-defined attribute by clicking 
the New button. If you want to create a new attribute, see “Creating a User-
Defined Attribute Using Expert Mode” on page 165. Once you have created 
your user-defined attributes, you can arrange them in the order you need them 
to appear by clicking the Move Up or Move Down button.

6. Click OK to save changes to the custom tab, or Cancel to exit without saving 
changes.

7. Click OK in the selected requirement type’s dialog box.
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Chapter 12: Requirements Manager 
Overview

OVERVIEW

CaliberRM is the requirement management component that administers projects, 
requirements and other CaliberRM custom utilities. 

Depending on your installation, you will have all or a subset of the following 
components in your Caliber menu. The table below lists the components in the 
Typical user installation.

Component Description

CaliberRM The Requirements Manager

CaliberRM Toolbar Provides convenience in launching 
applications

Help Files Help

Diagnostic Tool Used in troubleshooting

Document Factory Generates customized reports

Reporting Generates various pre-formatted 
CaliberRM reports

CaliberRM Viewer Provides a pop-up view of a 
requirement without opening the full 
CaliberRM client

Sample Documents Sample data
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USER INTERFACE

CaliberRM contains three views, each of which allows you to perform specific 
tasks. The views available are: 

• Project View

• Requirement Type View

• Requirement View

When you start CaliberRM for the first time, you are prompted to open a project. 
Select a project from the list and click OK. If you are setting up a new project, you 
are prompted to select the requirement types to be used in the project. You can also 
click Cancel and select a project later from the project drop-down list. If you have 
used CaliberRM before, your session opens to the last project you worked on before 
exiting.

When you select a project, the requirement types and requirements associated with 
that project are displayed in the project tree. 

Project 
Tree
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The project tree is a browser-like interface with expandable folders for projects, 
requirement types and requirements. The tab sets, on the right side of the screen, 
change depending on what is selected in the tree. 

Project View

When you select a project in the tree, the following tab set is displayed:

• Project Info tab: Tells you whether security is enabled or disabled and 
whether shared and mapped requirements are allowed. These fields are read-
only unless you have administrator privileges. The description field displays a 
read-only project description. 

• Discussion tab: Allows you to post and/or reply to project level discussions. 
For more information on project level discussions, see “Project Level 
Discussion” on page 285.

Requirement Type View

When you select a requirement type, the following tab set is displayed.

• Description: A read-only description of the requirement type.

• Custom Tabs: A read-only list of the custom tabs assigned to the requirement 
type and the user-defined attributes assigned to the selected custom tab.

• Summary: An editable text field that describes the requirement type for the 
active project.

Note: You must have CaliberRM administrator privileges to edit the Summary tab 
text.
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Requirement View

When you select a requirement, there are seven system requirement tabs used to 
manage and store requirement data. The information contained on each tab is 
discussed in the chapter “Requirements” on page 211. There may also be user-
defined tabs that are set up by your CaliberRM administrator when requirement 
types are created. 

MENUS

In CaliberRM, there are seven menus: File, Edit, View, Requirement, Tools, Report 
and Help. Each menu contains items that enable you to perform certain functions. 
The menus are described in more detail in the following sections.

File Menu

The File menu contains several commands related to project level and 
administrative tasks. The File menu is shown on the following page.

• Details Tab • Validation Tab

• Responsibilities Tab • References Tab

• Discussion Tab • Traceability Tab

• History Tab
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The commands perform the following functions: 

• Open Project: Displays the Project dialog box, which allows you to choose 
from a list of projects.

• Open Baseline: Displays the baselines available for this project and allows you 
to select a baseline. 

• Open Word Document: Opens an existing Word document and allows you to 
create new requirements and reference links from within the document.

• Admin: Displays the Admin sub-menu, which contains commands for 
performing administrative tasks. See “CaliberRM Administrators” on 
page 129.

• User Defined Attributes: Displays the User Defined Attributes dialog 
box, which allows you to create, modify and delete user-defined attributes.

• System Attributes: Displays the System Attributes dialog box, which 
allows you to modify system attributes.
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• Requirement Types: Displays the Requirement Types dialog box, which 
allows you to create, modify and delete requirement types and custom tabs 
within requirement types.

• Security Profiles: Displays the Security Profiles dialog box, which allows 
you to create, modify and delete security profiles.

• Set Requirement Types: Displays the Set Requirement Types dialog box, 
which allows you to specify which requirement types are used in the current 
project.

• CaliberRM Administrators: Displays the Administrators dialog box, 
which allows administrators to specify which users have administrative priv-
ileges within CaliberRM. This setting applies to all projects.

• Baseline Administration: Displays the Baseline Administration sub-menu, 
which contains commands for performing baseline management.

• New Baseline: Displays the New Baseline dialog box, which allows you to 
create a new baseline if you are a baseline administrator.

• Baseline Properties: Displays the Baseline Properties dialog box when a 
baseline is in use. If you do not have baseline administration privileges, the 
information displayed is read-only.

• Baseline Maintenance: Displays the Baseline Maintenance window for 
adding or deleting requirement information in a baseline if you are a base-
line administrator.

• Print: Prints a detailed report for the selected requirement.

• Export to Access: Exports data the user selects for the selected project to 
Microsoft Access.

• Import from Word: Displays the Import from Word Wizard, which allows 
you to select a Word document from which to import requirements into 
CaliberRM. 

• Save Settings: Saves the CaliberRM settings to ensure your settings are the 
same the next time you open your CaliberRM project.
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• Exit: Closes CaliberRM.

• Exit and Log Off: Closes CaliberRM and logs you off of the CaliberRM 
system. Also closes the Framework Administrator if it is running.

Edit Menu

The Edit menu contains several standard commands, including Cut, Copy and 
Paste. 

The commands perform the following functions: 

• Undo: Reverses the previous action performed.

• Cut: Cuts the selected text or requirement.

• Copy: Copies the selected text or requirement.

• Paste: Pastes cut or copied items in the location specified.

• Find in Tree: Enables you to find requirements in the requirement list whose 
names meet specified criteria. For more information on this feature, see 
page 225.

• Search: Enables you to search all requirements in a project, requirement type 
or sub-tree for a matching string in the requirement description. For more 
information on this feature, see page 226.
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View Menu 

The View menu provides access to additional views of the requirement data and 
allows you to view and hide toolbars.

The commands perform the following functions: 

• Back/Forward: Allows you to navigate between previously viewed 
requirements.

• Hierarchical Numbers: Displays the hierarchical numbering scheme in the 
requirement list.

• Serial Numbers: Displays the unique identification number for each 
requirement in the requirement list.

• File Toolbar: Shows/hides the File toolbar. The File toolbar contains the 
Project and Baseline drop-down lists. A check mark indicates that the toolbar is 
displayed.

• Edit Toolbar: Shows/hides the Edit toolbar. The Edit toolbar contains the 
following options: Undo, Cut, Copy, Paste, Find in Tree, Search Description, 
Hierarchical Numbers, Serial Numbers and About CaliberRM. A check mark 
indicates that the toolbar is displayed.
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• Requirement Toolbar: Shows/hides the Requirement toolbar. The 
Requirement toolbar contains the following options: Create Requirement, 
Insert Before, Insert After, Drag and Drop New Requirement, Delete 
Requirement, Save Changes, Cancel Changes, Move Up, Move Down, Map/
Unmap Requirement, Registered Interest and Print. A check mark indicates 
that the toolbar is displayed.

• Tools Toolbar: Shows/hides the Tools toolbar. The Tools toolbar contains the 
following options: Document Factory, Glossary, Requirement Grid, 
Traceability Matrix, Unread Discussions and any custom tools you create. A 
check mark indicates that the toolbar is displayed.

• SCM Toolbar: Shows/ hides the SCM toolbar. The SCM toolbar contains 
options for using an SCM tool, if installed. A check mark indicates that the 
toolbar is displayed.

• Status Bar: Shows/hides the Status bar. A check mark indicates that the 
toolbar is displayed.

Requirement Menu

The Requirement menu contains several items related to requirement creation and 
maintenance. This menu also allows you to change the order of requirements in the 
tree.
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• Create Requirement: Displays the Create Requirement sub-menu, which 
contains commands for creating new requirements.

• Child: Creates a new requirement as a child of the requirement or require-
ment type currently selected.

• Above: Creates a new requirement before and at the same hierarchical level 
as the currently selected requirement.

• Below: Creates a new requirement after and at the same hierarchical level as 
the currently selected requirement.

• Drag and Drop: Allows you to drag and drop a new requirement to any 
level in the selected project.

• Delete Requirement: Allows you to delete unwanted requirements.

• Save Changes: Allows you to save any changes you have made to a 
requirement, requirement type, or user-defined attribute.

• Cancel Changes: Allows you to cancel any changes you have made to a 
requirement, requirement type or user-defined attribute before you save those 
changes.

• Move Up: Changes the order of the requirements by moving the selected 
requirement up.

• Move Down: Changes the order of the requirements by moving the selected 
requirement down.

• Map/Unmap Requirement: Allows you to link or unlink a requirement 
description to or from another requirement’s description.

• Registered Interest: Allows you to be notified of any changes that are made to 
a requirement even if you are not assigned to the requirement.

• Compare Requirement: Allows you to compare any requirement to another 
requirement or requirement version.

• to previous version: Allows you to compare a requirement to a previous 
version of the same requirement.

• to other requirement or version: Allows you to compare a requirement to 
any version of another requirement.
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Tools Menu

The Tools menu allows you to view the Requirement Grid, Traceability Diagram 
and Traceability Matrix. You are also able to access the Document Factory, 
Glossary, SCM commands, Test Wizard, Compare Baselines, Baseline Signatures 
and Unread Discussions., as well as set system options using the Options menu 
item.

The commands under the Tools menu perform the following functions:

• Spelling: Displays the Spelling dialog box, which allows you to check the 
spelling of a requirement definition. 

• Document Factory: Launches the Caliber Document Factory, which allows 
you to generate any type of up-to-date, customized specifications documents 
using Microsoft Word templates. 

• Glossaries: Displays the global glossary in which you can view the definition 
of a term in the glossary by right-clicking on it in the requirement description. 
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• Requirement Grid: Displays the Requirement Grid, which shows all the 
requirements in a filterable list.

• Test Wizard: Launches the Test Wizard, which allows you to create tests for a 
requirement. This provides an easy way to create tests from all of your 
requirements by automating the process of creating tests in TestDirector. 

• Traceability Diagram: Displays the traceability data for one requirement in a 
diagram.

• Traceability Matrix: Displays the Traceability Matrix, which shows all 
requirement relationships.

• Unread Discussions: Displays the Unread Discussion List, which shows all 
unread discussions for the open project.

• CaliberRM Datamart Explorer: Launches CaliberRM Datamart Explorer, if 
installed, which allows you to build advanced queries and analyses of project 
requirements. 

• Compare Baselines: Displays the Compare Baselines dialog box. 

• Baseline Signatures: Displays the Baseline Signatures dialog box.

• Change Password: Displays the Change Password dialog box.

• Source Control: Displays the Source Control sub-menu, that contains options 
for using an SCM tool, if installed. 

• Options: Displays the CaliberRM Options dialog box, which allows you to 
set system options for your CaliberRM client. See page 200 for details on 
CaliberRM Options.
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Changing Your Password

CaliberRM enables administrators to create and enforce user password policies. As 
a result, you may receive messages from CaliberRM about your password. The 
following table lists the password related messages.

If you have change password privileges, you can change your password at any time 
as long as your current password has met the imposed minimum password age, 
and your new password conforms to the password restrictions.

To change your password:

1. Select Tools > Change Password. The Change Password dialog box is dis-
played.

2. Enter your current password in the Old Password field.

3. Enter a new password in the New Password field.

4. Verify the new password by retyping it in the Retype New Password field. If 
the two passwords do not match, you are prompted to re-enter them.

5. Click OK.

Message Action

Your CaliberRM logon password has expired. 
Please choose a new password. 

Click OK and enter new password 
information in Change Password 
dialog box.

Your CaliberRM logon password will expire in 
n days. Do you want to change it now?

Yes - Enter new password in Change 
Password dialog box.

Your CaliberRM logon password has to be 
changed in order to logon. Please change your 
password.

Change your password.

Your CaliberRM account has been disabled. 
Please contact your CaliberRM Administrator 
for more information.

Contact Administrator.
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If the password you are attempting to use fails to meet the imposed criteria, or if 
you are not allowed to change your password, you will receive one of the following 
messages:

Report Menu

The report menu allows you to preview and print standard reports of the 
requirement data. For instructions on printing reports, see “Reports” on page 271.

Message Meaning/Action

You have entered either a duplicate or old 
password.

You have attempted to reuse an old 
password. Choose a different password.

The password you entered is too short. You have attempted to change your 
password to one that is too short. Choose 
a longer password.

The minimum password age has not been 
met. You will not be able to change your 
password now.

Your password is too young to change.

You do not have permission to change your 
password. Please contact your CaliberRM 
administrator.

You cannot change your own password 
due to security settings.
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The commands perform the following functions:

• Detail: Prints the Detail Report, which lists all requirements in the project with 
their data, including name, description, priority, status, owner and user-defined 
attributes.

• History: Prints the History Report, which lists all requirements with their 
change history.

• Discussion: Prints the Discussion Report, which lists all requirements with 
their group discussion messages.

• Status: Prints the Requirement by Status report, that lists all requirements by 
their status.

• Responsibility: Prints the Requirements by Responsibility report, which lists 
all requirements in the project sorted by the responsible user.

• Specification: Generates a requirement specification report in Microsoft Word 
format.

Help Menu

The Help menu displays options for accessing the Help system.

The commands perform the following functions:

• Help Topics: Displays the Help system.

• Using Help: Displays instructions for using the Help system.
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• Technical Support: Displays information about contacting Borland’s 
Technical Support team.

• Borland: Opens an Internet browser and displays the Borland home page.

• About CaliberRM: Displays information about CaliberRM.

CALIBERRM OPTIONS

Under the Tools menu, CaliberRM has several system options that you can set for 
your client. The options are listed by tab order in the following sections.

General Tab

Option Description

Save settings on exit Saves system settings, including last item selected, 
window size and window position, when exiting 
CaliberRM.

Show unread discussion list on 
start

Shows the Unread Discussion List upon launching
CaliberRM.

Mark reference documents as 
“read only” after saving

Helps prevent others from modifying referenced 
documents outside the CaliberRM user interface.

Confirm before saving Displays a confirmation dialog box asking if you want to 
save the requirement you have modified when you select 
a new item. This option is selected by default.

Ask for comment when saving 
requirement

Displays the Comment dialog box when you save 
changes to a requirement.

Show reference-related 
messages

Displays a dialog box every time you create or remove 
references to text within a document.
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Hide Tabs Tab

Allows you to hide or display tabs for specific requirement types by selecting 
the box to the left of the tab for each requirement type on the tab. A check indi-
cates the tab is displayed. Tabs hidden in a requirement type are hidden in all 
projects that use that requirement type.

Appearance Tab

The options on this tab allow you to set the appearance of the following areas of 
CaliberRM.

Option Description

Single-click on selected 
requirement initiates rename

Determines whether or not you can rename a 
requirement in the list by selecting it and then single-
clicking on it, as in Windows Explorer.

Automatically detect 
CaliberRM upgrades on 
startup

Allows users immediate access to available CaliberRM 
upgrades, and provides a URL location for accessing the 
downloads. 

Option Description

Flat Toolbars Displays the toolbar option buttons as flat, instead of raised.

Icons on Menus Shows icons next to commands on the menus. This helps you 
recognize the toolbar buttons.

Resize Windows 
While Moving Splitter 
Bar

Redraws the tabs on the right side of the screen dynamically when 
you move the screen splitter. This may cause some minor 
flickering on your screen while redrawing, depending on your 
computer’s configuration.
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Communications Tab 

This tab allows you to set the following options.

Option Description

Multiline Tabs Allows you to stack your requirement tabs so they are all visible in 
the CaliberRM window.

Highlight glossary 
terms in requirement 
description

Allows you to turn the glossary feature on or off.

Date Format Determines how dates are displayed, in Windows Long or 
Windows Short format.

Tab Options Allows you to set the way your tabs are displayed.

Option Description

Normal Transaction Time-out Determines how long, in seconds, the client waits for a 
response from the server for normal transactions, such 
as displaying project data. If you are running 
CaliberRM over a modem or slow connection, you may 
need to increase this time.

Lengthy Operation Time-out Determines how long, in seconds, the client waits for a 
response from the server for lengthy operations, such 
as running reports. The time needed to build reports 
depends upon the report selected and the amount of 
data to be compiled.

Network Diagnostics Level Determines the level of detail presented when you run 
the network diagnostics utility. This utility can be used 
to troubleshoot communication problems. This option 
should only be changed at the discretion of Borland’s 
product support group.
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Clipboard Tab

This tab determines what data is pasted to the clipboard based on the following 
options.

Wizards Tab

This tab allows you to determine whether requirement types and user-defined 
attributes are created using the appropriate wizard.

Option Description

Paste Only the Copied 
Requirement

Pastes only the requirement that was copied.

Paste the Copied 
Requirement & all Child 
Requirements

Pastes the copied requirement and all of its child 
requirements.

Allow User to Override 
Default Behavior

Allows the user to override the default paste behavior 
specified. If you choose this option, you will always be asked 
if you want to paste child requirements even when pasting a 
requirement that has no child requirements.

Choose directory Specifies the directory in which to place a dragged 
requirement (.crm file).

Option Description

Requirement Types Determines if requirement types are created using the 
Requirement Type Creation Wizard or manually.

User-Defined Attributes Determines if user-defined attributes are created using the 
Attribute Creation Wizard or manually.
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Spelling Tab

This tab allows you to set options regarding the Spelling Checker. A check in the 
box indicates the Spell Checker option is enabled. See page 208 for more 
information about using the Spell Checker. 

Option Description

Always suggest replacements 
for misspelled words

If selected, the spell checker displays suggested 
corrections for misspelled words.

Always check spelling before 
saving Requirements

If selected, the spell checker checks for misspelled 
words when a requirement is saved after any 
modification.

Check spelling only if 
Requirement description 
modified

If selected, the spell checker checks for misspelled 
words when a requirement is saved, but only if the 
description field has been modified. 

Ignore words in UPPERCASE If selected, the spell checker ignores words using all 
uppercase letters.

Ignore words with numbers If selected, the spell checker ignores the spelling of 
words that contain numbers.

Ignore CaliberRM glossary 
words

If selected, the spell checker ignores all words that are 
contained in the CaliberRM glossary.

Dictionary options By selecting the Edit button, you may add, change, or 
remove words from your custom dictionary.

International dictionaries Displays a drop-down list of all dictionaries installed on 
your system. Select a language to use when spelling is 
checked. The items in this list should be spelled exactly 
as they are in the Available Dictionaries section.
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Using Spell Checker

The CaliberRM Spell Checker allows you to check the spelling of a requirement 
description in CaliberRM.

There are four methods available for invoking the Spell Checker:

• Select Tools > Options > Spelling to set the option to automatically check 
spelling upon saving the requirement. The Spell Checker automatically checks 
spelling when you click the Save button or select File > Save Settings from the 
menu. 

• Press the F7 function key.

• Click the Spelling button on the CaliberRM toolbar.

• Select Tools > Spelling from the menu.

When Spell Checker is invoked, the Spelling dialog box is displayed.

Spelling Checker Options

Not in Dictionary: Displays the misspelled word.

Change to: Displays the first word in the Suggestions list, or allows you to type in 
a replacement word.
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Suggestions: Displays a list of suggested replacements for the misspelled word.

Ignore: Click this button to ignore the misspelled word.

Ignore All: Click this button to ignore all instances of the misspelled word.

Change: Click this button to replace the misspelled word with the word in the 
Change to field.

Change All: Click this button to replace all instances of the misspelled word with 
the word in the Change to field.

Add: Click this button to add the word in the Not in Dictionary field to the Custom 
Dictionary.

Suggest: Click this button to populate the Suggestions list with alternatives to the 
word in the Change to text field.

Options: Click this button to display the Dictionary Options dialog box.

Undo Last: Click this button to reverse the last change made by the Spell Checker.

Cancel Button: Click this button to close the Spelling dialog box without making 
any changes.

Dictionary Options

CaliberRM enables you to create a custom dictionary of words. You may add, edit, 
or remove words from your custom dictionary.

To add a word to the Custom Dictionary:

1. Click the Options button in the Spelling dialog box. The Spelling tab is dis-
played.
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2. Click Edit. The Custom Dictionary dialog box is displayed.

3. Click the New button to add a word. A space is created for the new word.

4. Type in the word you want to add to the dictionary and click OK.

Note: To edit a word in the list, double-click it and make changes. To delete a 
word, select it and click the Delete button.

Cache Tab

Management of cache on CaliberRM allows the user to set limits on how much 
memory is consumed by the cache data. The cache is used to keep local copies of 
frequently accessed requirements. You may set one of the following to manage the 
cache on your client.

Option Description

Unlimited Allows CaliberRM to be limited only by available memory. 
This is the default setting.

Click the New button.
Type new word here.
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Custom Tools Tab

Allows you to create custom tools specific to your CaliberRM project. Custom 
tools can be created, assigned an icon you select and placed at a specific location on 
the CaliberRM toolbar for accessibility.

Creating Custom Tools

To create a Custom Tool in CaliberRM:

1. Select Tools > Options from the menu.

2. Click the Custom Tools tab.

3. In the Menu Contents section, click the New button.

4. Type in the name you want to give your custom tool. 

5. Type in the command, executable or document name you want your custom 
tool to execute, in the Command or Document section, or click the Browse 
button to locate the executable.

6. Type in any arguments you want to place on your command in the Arguments 
section.

7. Type in the directory from which you want your command to run in the Initial 
Directory section, or click the Browse button to locate the directory.

Option Description

Never Cache Causes CaliberRM to access the server for each request 
for data. This setting minimizes memory requirements for 
the CaliberRM client at the expense of increased network 
traffic.

Custom Allows you to limit the amount of cache that CaliberRM 
utilizes on your computer.
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8. Select the Prompt for arguments check box if you want your custom tool to 
prompt for the arguments you may have assigned in Step 6.Specify for which 
objects (projects, requirement types or requirements) the custom tool will be 
available in the Tool Enabled section. A check next to the object indicates the 
tool is enabled.

9. Click the Change Icon button if you want to assign or change an icon for your 
custom tool.

10. Click OK. 

The new custom tool icon is now displayed in the Tools toolbar. 
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Requirements are specifications that the application or system you are building 
must meet. Requirements can originate from many sources such as business rules, 
business process models, product marketing, prototypes, development meetings 
and more.

Before you can create requirements in CaliberRM, your CaliberRM administrator 
must first create a project in the Framework Administrator, and create requirement 
types in CaliberRM. Requirements are grouped according to their type.

Each requirement within a project has two numbers associated with it. One is the 
hierarchical number, which is determined by the requirement’s placement within 
the project tree or hierarchy. The hierarchical number changes as requirements are 
added, moved or deleted. The other number is its unique ID (or serial) number. The 
serial number does not change, regardless of the requirement’s position, and it is 
not reused if the requirement is deleted.

In CaliberRM, you have the option of displaying multiple views of your 
requirement data. One view is the Requirement Grid, which shows all requirements 
and their attributes in a filterable grid. See “Requirement Grid” on page 231 for 
more information on the grid. Another view is the Traceability Matrix, which 
shows how requirements are linked together. See “The Traceability Matrix” on 
page 263 for more information on the matrix. You can also use the Trace Diagram 
to view requirement information. See “The Traceability Diagram” on page 259 for 
more information on the diagram.

CREATING A REQUIREMENT

There are three steps necessary to create a requirement: 

• Defining requirement information 

• Assigning attribute values

• Assigning responsible users
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In addition, there are three optional steps: linking reference documents, creating 
traceability links and defining the validation procedure.

CaliberRM enforces security while creating a new requirement, so you are not able 
to modify fields that your security profile does not allow. Only fields that are 
enabled are available for you to change.

Defining the Requirement 

When you create a requirement, you have four options for the placement of the new 
requirement. The menu option you select or the button you click determines the 
placement: 

Create Requirement: Creates a new requirement as a child of the currently 
selected requirement.
Insert Above: Creates a new requirement at the same hierarchical level and 
before the currently selected requirement.
Insert Below: Creates a new requirement at the same hierarchical level and 
after the currently selected requirement. 
Drag-and-Drop New Requirement: Creates a new requirement anywhere in 
the tree (that you have permission to create requirements) by allowing you to 
“drop” the requirement in place. 

To create a requirement and define the requirement information:

1. Click the Drag-and-Drop New Requirement button and click in the require-
ment list in the location you would like to insert the requirement.

Note: The cursor is displayed as a circle with a bar through it if the cursor is 
over an area where you cannot create a requirement.

OR

Select a requirement near where you want to create the new requirement and 
select the appropriate option for creating a requirement from the Requirement 
menu (Child, Above or Below), or click the appropriate Create Requirement 
button. 

The new requirement is created, and the Details tab is displayed.
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2. Enter a name in the Name field and description in the Description field for the 
requirement. 

3. Select the appropriate Status, Priority and Owner from their respective drop- 
down lists.

Note: The default Owner is the user who created the requirement. You may 
assign the requirement to someone else, but you may not be able to modify it 
again after it is saved if you do not have security privileges to do so.

4. Save the requirement by selecting Requirement > Save Changes from the 
menu, or by clicking the Save Changes button. To delete the requirement, 
select Requirement > Cancel Changes from the menu, or click the Cancel 
Changes button.

The first time you save a requirement, that requirement is entered into the 
CaliberRM database and a creation entry (Rev. 1.0) is made in the change history 
record. Each time you change a requirement and save it, you may be prompted to 
enter a comment about the change. The change and the comment are entered in the 
change history record. See “Requirement History” on page 218 for more 
information. To avoid unwanted change history data, fully define the requirement 
before saving it. You can turn the Comment dialog box on or off through the 
CaliberRM Options dialog box.

Assigning Attribute Values 

User-defined attributes help fully define the requirement by allowing users to 
customize the data that is tracked and stored. User-defined attributes are assigned 
by the administrator at requirement type creation. The administrator also creates 
custom attribute tabs when user-defined attributes are present. The attributes appear 
in the tab set. Like other fields in a requirement definition, user-defined attributes 
must be assigned values.

To assign attribute values to a requirement:

1. Select the requirement to which you want to assign values.

2. Click the Attributes tab.
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The User Attributes tab displays all user-defined attributes for the 
requirement. For a description of the different attribute types, see “Attribute 
Types” on page 159.

3. Make the appropriate selections for each of the attributes.

4. Save your changes by selecting Requirement > Save Changes from the menu, 
or by clicking the Save Changes button. To delete changes, select 
Requirement > Cancel Changes from the menu, or click the Cancel Changes 
button.

5. If the Comment dialog box is displayed, enter a comment about the change 
and click OK.

Assigning Responsible Users

Users that are accountable for the completion of a requirement are assigned 
responsibility for that requirement. Typically, several individuals are assigned to 
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each requirement. For example, the business analyst who created the requirement is 
assigned, as well as a developer, tester and manager. When requirements are 
changed, the users assigned to them are notified in order to keep development on 
track. Automatic notification is enabled by an administrator in the Framework 
Administrator. See “Enabling Automatic Notification” on page 59.

To assign users to a requirement:

1. Select the requirement to which you want to assign users. 

2. Click the Responsibilities tab. The Responsibilities tab displays project 
groups and member selection boxes.

Note: The lists are limited by the group membership assigned for the project 
in Framework Administrator. 

3. Expand or collapse a list by clicking the plus or minus sign to the left of the 
group/member name. A darkened check box indicates that at least one member 
of that group has been selected.

4. To select all members of a group, select the check box to the left of that group.

To select only certain members of a group, select the check box to the left of 
each member you want to assign.

Note: To display users first in the tree, select the Display in Member/Group 
order check box. To assign a user that is a member of multiple groups, but 
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only as a responsible member of one of those groups, select that group’s 
check box.

5. Once a user is assigned, CaliberRM notifies that person by email of specific 
events, as defined in Framework Administrator. See “Setting Up Automatic 
Notification” on page 34 for more information on automatic notification.

6. Repeat Steps 3-5 to assign users from each group as needed.

7. Save your changes by selecting Requirement > Save Changes from the menu, 
or click the Save Changes button. To delete changes, select Requirement > 
Cancel Changes from the menu, or click the Cancel Changes button.

8. If the Comment dialog box is displayed, enter a comment about the change 
and click OK.

Note: You can also assign users from the Requirement Grid. See “Modifying 
Requirements from the Grid” on page 237 for more information. 

VALIDATION PROCEDURE

When you create a requirement, it is often helpful for testers to know how to verify 
that the requirement is implemented properly. Therefore, CaliberRM allows you to 
type in a validation procedure for each requirement if you want. The validation 
procedure is “free form,” which means that the procedure can be in any form you 
want, from a paragraph to a numbered list of steps.

To define the requirement validation procedure:

1. Select the requirement for which you want to define the validation procedure.

2. Click the Validation tab. The Validation tab is displayed.

3. Type the validation procedure in the Validation Procedure field.

4. Save your changes by selecting Requirement > Save Changes from the 
menu, or click the Save Changes button. To delete changes, select Edit > 
Cancel Changes from the menu, or click the Cancel Changes button.

5. If the Comment dialog box is displayed, enter a comment about the change 
and click OK.
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COPYING REQUIREMENTS

To copy an existing requirement:

1. Select the requirement you want to copy.

2. Click the Copy button. 

3. Select the requirement to which you want to paste the first requirement. 

4. Click the Paste button to paste the copied requirement. The copied requirement 
is pasted as a child of the selected requirement.

If the Allow user to override default behavior option is selected on the 
Clipboard tab in the CaliberRM Options dialog box, the Paste Children? 
dialog box is displayed. Click the Yes button to paste children, or No to paste 
only the copied requirement. 

The requirement is copied. The new requirement is assigned a different serial 
number than the original requirement.

You can also hold down the Control (CTRL) key, click on the requirement you want 
to copy and drag and drop it into the desired location.

MODIFYING A REQUIREMENT

To modify a requirement:

1. Select the requirement you want to modify. 

Note: If you are not authorized to change the requirement, the data fields 
appear disabled. 

2. Select the tab containing the information you want to modify.

3. Edit the requirement information. 

As soon as you begin editing the requirement, CaliberRM automatically 
locks it to prevent someone else from modifying it at the same time. The 
requirement icon in the requirement list appears with a lock on it. The lock 
remains in place until you either save your changes or cancel them.
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Note: Modified requirements display an asterisk (*) to the right of the field to 
indicate that a change has been made to that requirement field. See “Field 
Changed Indicator” below for information on this feature.

4. To save your changes, select Requirement > Save Changes from the menu, or 
click the Save Changes button. To delete changes, select Requirement > 
Cancel Changes from the menu, or click the Cancel Changes button.

5. If the Comment dialog box is displayed, enter a comment about the change 
and click OK. 

Field Changed Indicator

When you make changes to a requirement, an indicator (*) appears on the right side 
of the field you have changed to indicate that changes have been made to that field. 

You can right-click on the indicator to view a toolbar, which allows you to either 
revert the change to the field’s original setting by clicking the revert button, or close 
the toolbar by clicking the close button.

Note: Data on the References tab and the Traceability tab is not revertible; you 
need to change it back manually. 

REQUIREMENT HISTORY

CaliberRM maintains a history record for each requirement. The history record 
assigns revision numbers and keeps a list of changes for each revision. All changes 

Field Changed Indicator

Revert Close
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made to a requirement, including changes to specific attributes, the requirement 
description, status, priority and more are recorded in the requirement’s history.

Viewing the History Record

To view the history of a requirement, select the requirement and click the History 
tab. The history record is made up of two parts: the Revisions list and the Changes 
list. 

The upper window contains the Revisions list. Each entry in the revisions list 
contains the following fields:

• Rev #: When a change is made, CaliberRM automatically updates the revision 
number. The change may cause a major or minor revision number change. This 
is determined by your CaliberRM administrator when attributes types are 
defined.

• Date/time: The date and time the change was made.

• Changed by: The userid or name of the person who made the change.

• Comment: If a supporting comment is entered at the time the change is saved, 
it is displayed here.

You can sort the revision list in ascending order by revision number, date/time, user 
or comment by clicking on the appropriate header. 

Click the header a second time to sort in descending order.
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The first entry in the list is the requirement creation entry. It is assigned a revision 
number of 1.0. 

The bottom window displays a list of Changes for the revision selected in the upper 
window. Entries in the change list contain the following fields:

• Attribute: the changed field

• Changed from: the original data

• Changed to: the new data

Viewing Change Detail

You can see all details about a particular change in one view by double-clicking on 
the change you have selected, or by clicking the Detail button.
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The History Details dialog box is displayed containing the revision number, the 
date and time changed, the user who made the change, the user comments about the 
change, the field changed, and the original and new data for the field.

COMPARING REQUIREMENTS 

You can compare requirements three ways: to previous versions of the same 
requirement, to another requirement, or to any version of another requirement, and 
print a report of the comparison.
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Comparing a Requirement to a Previous Version

To compare versions of the same requirement:

1. Select Requirement > Compare Requirements > to previous version from 
the menu, or right-click on the requirement in the requirement tree and select 
that option in the pop-up menu.

CaliberRM compares the current version of the requirement with the previous 
version of the requirement, and displays an .html file that informs you of the 
number of differences.

2. Click OK. You can now see the differences between the two versions. The 
differences are identified by shaded rows a red arrow to the left of the 
attribute(s) that differ.

3. You can print the report by selecting File > Print and following normal 
Windows printing procedure.

Comparing a Requirement to Another Requirement or Version

You can also compare a requirement to any version of another requirement.

To compare a requirement to any version of another requirement:

1. Select a requirement you want to use for a comparison.

2. Select Requirement > Compare Requirement > to other requirement or 
version from the menu, or right-click on the requirement in the requirement 
tree and select the option in the pop-up menu.

The Compare Requirements dialog box is displayed as shown on the 
following page.
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3. Select the requirement you want to compare to from the requirement tree or, 
select the requirement version you want to compare to from the Requirement 
Version drop-down list.

The requirement that you choose to compare to appears in the Requirement 2 
section of the Compare Requirements dialog box.

4. Click OK to continue with the comparison, or click Cancel to discontinue the 
comparison.

CaliberRM compares Requirement 1 with Requirement 2, and displays an 
.html file that informs you of the number of differences.

5. Click OK. You can now see the differences between the two requirements. The 
differences are identified by shaded rows a red arrow to the left of the 
attribute(s) that differ.

6. You can print the report by selecting File > Print and following normal 
Windows printing procedure.

CHANGING THE REQUIREMENT ORDER

You can change the requirement order three ways:

• Using the commands in the Edit menu 

• Using the buttons on the toolbar
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• Dragging and dropping the requirements 

• Using the commands in the Edit menu or the buttons on the toolbar, you may 
move requirements only within the parent. You cannot change the hierarchical 
level of requirements using the toolbar buttons, nor can you move a 
requirement to another requirement type. Using drag-and-drop, you can move a 
requirement anywhere you want, even to another requirement type.

Note: You must have Create level access to move a requirement into another 
requirement type, and Delete level access to move a requirement out of a require-
ment type.

To change the requirement order using the commands in the Edit menu, select the 
requirement you want to move and select Edit > Move Up or Edit > Move Down 
from the menu.

To change the requirement order using the toolbar buttons, select the requirement 
you want to move and click the Move Up button or Move Down button.

To change the requirement order using drag-and-drop:

1.  Select the requirement you want to move by clicking and holding down the left 
mouse button.

2.  Drag the requirement to the location you want to move it.

2.1   If you want the requirement to move up one hierarchical level, drag it 
above its parent.

2.2   If you want the requirement to move down one level, drag it on top of 
the requirement you want to be its parent.

2.3   If you want to move the requirement to another requirement type, drag it 
to the desired location within that requirement type.

Note: When moving requirements to another requirement type, only user-
defined attributes that are common to both requirement types will retain their 
values.

3. When the requirement is in the location you want it, release the left mouse 
button.
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The requirement is moved and the hierarchical numbers are automatically 
updated.

SEARCHING FOR A REQUIREMENT BY NAME

To search for a requirement:

1. Select Edit > Find In Tree from the menu or click the Find button. The Find 
in Tree dialog box is displayed.

2. Type the name of the requirement you would like to find, or any portion of the 
name in the Find What field.

Note: The Find function only searches for text in the requirement list. It does 
not search requirement descriptions.

3. If you want to search for a requirement by name, select the Name option 
button. If you want to search for a requirement by ID number, select the ID 
number option button.

4. If you want the search engine to find requirements that match exactly, select the 
Match whole word only check box. 

5. If you want the search engine to match requirement names by case, select the 
Match case check box.

6. Select the direction in which to search (Up from the currently selected 
requirement, or Down). 

7. Click the Find Next button until the requirement you are searching for is 
selected.
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SEARCHING FOR A REQUIREMENT BY DESCRIPTION

You can search for a requirement by matching a text string to one in the 
requirement description. You can search the entire project or you can narrow your 
search to a requirement type or a requirement sub-tree. 

The Search Description dialog box allows you to input the string you are searching 
for and tells CaliberRM where to search.

The choices in the Search from drop-down list are based on what is currently 
selected in the requirement tree. 

To search for a requirement that contains a matching text string in its description:

1. Click the Search button or select Edit > Search Description from the menu.

2. Enter the text you want to search for in the Search for field. 

3. Select the project, requirement type, or requirement you want to search in the 
Search from drop-down menu.

4. Click Search.

The search results are automatically displayed in the Requirement Grid. Click on 
the requirement to show the requirement description. All Requirement Grid 
functionality is available.
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 See “Requirement Grid” on page 231 for instructions on how to use the 
Requirement Grid. 

DELETING A REQUIREMENT

WARNING: IF YOU DELETE A REQUIREMENT, YOU CANNOT RECOVER 
DELETED DATA.

To delete a requirement:

1. Select the requirement you want to delete.

2. Select Edit > Delete from the menu, or click the Delete button. 

A message box is displayed verifying that you want to delete the requirement. 
Child requirements, if present, are deleted as well.
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3. Click Yes to delete the requirement and its children, or No to save it.

4. If the Comment dialog box is displayed, enter a comment about the change 
and click OK. 

DISPLAYING REQUIREMENT IDENTIFICATION NUMBERS

Each requirement within a project has two different numbers associated with it. 
One is the hierarchical number, which is determined by the requirement’s 
placement within the project tree or hierarchy. The hierarchical number changes as 
requirements are added, moved or deleted. 

The other number associated with each requirement is its unique serial (or ID) 
number. The serial number generally does not change, regardless of the 
requirement’s position within a requirement type, but it will change if you move a 
requirement to a different type. It is not reused if the requirement is deleted. Serial 
numbers are composed of the requirement type tag and a number. For example, 
Business Specification types may have the tag “BS.” Serial numbers for Business 
Specification types have the “BS” tag as a prefix for the serial number.

To display the requirement hierarchical numbers, select View > Numbers > 
Hierarchical from the menu, or click the Show Hierarchical Numbers button. 
The hierarchical numbers appear in the requirement list.
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To display the requirement serial numbers, select View > Numbers > Serial from 
the menu, or click the Show Serial Numbers button. The serial numbers appear in 
the requirement list.

REGISTERED INTEREST

Registered Interest is a feature of CaliberRM that allows you to receive email 
notification that a change has been made to a requirement, even if you are not 
assigned as a responsible person for that requirement. 

To register interest in a requirement, select the requirement and click the Register 
Interest button on the toolbar. 

You can also right-click on the requirement in the requirement list and select 
Register/Unregister from the drop-down list.

The requirement that you registered interest in now displays an icon indicating that 
you will receive notification of any changes made to this requirement.

If you want to unregister interest in a requirement, repeat the steps above and the 
icon is removed.
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OVERVIEW

The Requirement Grid is used to display a set of requirements. The grid view 
includes the requirement type, tag, name, status, version, priority, responsible users, 
owner and many other attributes. You can also select a requirement and view its 
description in the lower pane of the Requirement Grid.

The appearance of the information on the grid may be changed by hiding and 
rearranging columns. The requirements can be filtered in the grid to show only 
those meeting the filter criteria. The modified view can be saved and printed.

OPENING THE REQUIREMENT GRID

Open the Requirement Grid by selecting Tools > Requirement Grid or by clicking 
the Requirement Grid button on the toolbar. The Open Requirement Grid dialog 
box is displayed.

There are four ways to display a requirement grid:

• To View all the requirements in this project select this option and see “View 
All Requirements in this Project” on page 232.
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• To Open a previously saved requirement grid view select this option and see 
“Open a Previously Saved Grid” on page 233.

• To Specify search criteria select this option and see “Search for Specific 
Data” on page 233.

• To display the requirement hierarchy numbers in the grid, select the Retrieve 
Hierarchy Numbers check box. Using this feature may slow performance.

View All Requirements in this Project

When you select this option, all requirements in the open project are displayed on 
the grid. You can sort the grid in ascending order by clicking on a column header by 
which you want to sort, and descending order by clicking the header a second time. 

Note: Sorting on a single selection list user-defined attribute sorts items by dis-
play order within the List Box Contents for that particular UDA.
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Open a Previously Saved Grid

Note: For information on how to save a grid view, see page 239.

To display a previously saved view:

1. Select File > Open from the menu, or click the Open button.

The Open dialog box is displayed.

2. Select the file to open.

3. If you want the view to be read-only, select the Open as read-only check box.

4. Click Open to display the view, or Cancel to exit without displaying.

Search for Specific Data

Note: Specify search criteria is another way of launching Search Description. 
See “Searching for a Requirement by Description” on page 226 for more infor-
mation.
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To search for specific criteria:

1. Enter the text in the Search for field or select the text from the Search for 
drop-down list.

2. Enter the name of the project, requirement type or requirement you want to 
search from in the Search from field or select this information from the Search 
from drop-down list.

3. Click Search. The Requirement Grid opens and displays the search results.

THE GRID VIEW

You can sort the grid in ascending order by clicking on any header and in 
descending order by clicking on the header a second time. 

You can choose to have the Requirement Grid always display on top of other 
windows by selecting View > Always on Top from the menu or by clicking the 
Always on Top button. 

You can also refresh the Requirement Grid data by selecting View > Refresh from 
the menu or by clicking the Refresh button.

To display gridlines, select View > Grid and select either Horizontal or Vertical. 
You can also turn gridlines on and off by clicking the Horizontal Grid and 
Vertical Grid buttons.
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Modifying the Requirement Grid View

The Requirement Grid view can be modified by moving and hiding columns. You 
can then save this view for display in the future.

To move the columns, click on a column header and hold down the left mouse 
button while dragging the header to the desired position. An arrow head is 
displayed as you move the header, to show where the column will be placed. When 
the column is in the desired position, release the left mouse button and the column 
is moved.

To hide a column from the Requirement Grid:

1. Right-click on the header of the column to be hidden.

2. Select Hide Column from the pop-up menu.

Note: The column is not deleted, just removed from the view.

To return hidden columns to the grid:

1. Choose a location for the column.

2. Right-click on the column header next to the desired position.

3. Select Insert Before or Insert After in the pop-up menu.

The Insert Column dialog box is displayed.

4. Select the column to be added.

Note: If all columns are already shown in the grid, there are no options to 
select in the Column field.

5. Click OK to add the column, or Cancel to exit without adding the column.
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Filtering the Grid View

You can filter columns in the Requirement Grid to display only the information you 
want to see.

To filter a column in the Requirement Grid, do one of the following:

• Right-click on a column heading, then go to Step 2 (quickest method),

• Select View > Filter from the menu, then go to Step 1, or

• Click the Filter button, then go to Step 1.

The Custom Filter dialog box is displayed.

1. Select the Column you want to filter from the drop-down list.

2. Select an operator from the first Conditions drop-down list (i.e., begins with, 
equals, greater than, etc.).

3. Enter the text to filter on, or select from the drop-down list if applicable.

4. Select the And or Or option button and repeat Steps 3 and 4 to enter a second 
filter condition if desired.

Note: And displays the requirements that meet both criteria. Or displays the 
requirements that meet one or both of the conditions.

5. Click OK to filter, or Cancel to exit without filtering.
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The filtered grid is displayed. The filtered columns are displayed with a filter 
symbol in the header. 

To return to the original view, click the No Filter button. All filters are removed.

GO TO REQUIREMENT

To go to a requirement in the project:

1. Select the requirement in the Requirement Grid list.

2. Select Edit > Go To Requirement from the menu, click the Go To 
Requirement button, or double-click on the requirement.

3. The Details tab of the selected requirement is displayed.

MODIFYING REQUIREMENTS FROM THE GRID

You can modify information on the Requirement Grid. All system and user-defined 
attributes, with the exception of Type, can be updated or modified. 

To modify information on the grid:

1. Select a requirement in the list.

Note: To select a group of requirements, select the first requirement, hold 
down the SHIFT key and select the last requirement. All requirements in 
between will be automatically selected. To select multiple individual require-
ments, hold down the CTRL key and select each requirement. Changing a 
requirement name is automatically disabled when multiple requirements are 
selected.

2. Right-click on the attribute you want to update.

Note: When modifying multiple responsible users simultaneously on the Grid, 
the drop-down selection box displays users assigned to the requirement 

Filter Indicator
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selected last. See ““Modifying Requirement Responsibility on the Grid” on 
page 239” for more information.

A selection window is displayed allowing you to Modify or Go to 
requirement.

3. Select Modify to change the attribute.

A drop-down list appears displaying the values that can be assigned, or you 
just have the option to change the value of the attribute.

WARNING: IF YOU MODIFY AN ATTRIBUTE WITH MULTIPLE REQUIRE-
MENTS SELECTED, ALL SELECTED REQUIREMENTS WILL BE MODIFIED 
TO THE SAME VALUE. IF YOU DO NOT WANT THE ATTRIBUTES TO HAVE 
THE SAME VALUE, SELECT REQUIREMENTS AND MODIFY THE 
ATTRIBUTES INDIVIDUALLY.

4. Click on the new value from the drop-down list to assign the value.

5. Click the Save button to save your modification.
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Modifying Requirement Responsibility on the Grid

To assign and unassign responsible users on the Grid:

1. In the Grid, select the requirement to which you want to assign users.

Note: To select a group of requirements, select the first requirement, hold 
down the SHIFT key and select the last requirement. All requirements in 
between will be automatically selected. To select multiple individual require-
ments, hold down the CTRL key and select each requirement. 

2. Right-click in the Responsibilities column and select Modify.

The Responsible Users drop-down list is displayed.

Note: When modifying multiple responsible users simultaneously on the Grid, 
the drop-down selection box displays users assigned to the requirement 
selected last. 

3. Select the check box to the left of each user you want to assign to the 
requirement(s). You can select all members of a group by selecting the check 
box next to the group. A gray check box next to a group indicates that at least 
one member from that group is selected.
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4. Click Done in the Responsible Users drop-down list.

5. Click the Save button to save your changes. 

To unassign users, clear the check boxes of the user(s) you want to unassign. 

Note: When unassigning a responsible user across multiple requirements, make 
sure the last requirement selected contains that user. The drop-down selection box 
displays users assigned to the requirement selected last. 

SAVING THE GRID VIEW

After you have finished filtering and rearranging the grid view, you may want to 
save it for future use.

To save the Requirement Grid view:

1. Select File > Save As from the menu, or click the Save Profile button. The 
Save As dialog box is displayed.

2. Enter a file name for the view.

3. Click Save to save, or Cancel to exit without saving.
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PRINTING THE GRID VIEW

When you have finished filtering and rearranging the Requirement Grid, you can 
print a report of the data.

To print the Requirement Grid:

1. While viewing the Requirement Grid, select File > Print from the menu, or 
click the Print button. 

The Report Setup dialog box is displayed.

2. Click the Preview button if you want to view the report before printing.

3. Click the Print button. Print using normal Windows printing operations.
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SHARED REQUIREMENTS

Many times the same requirements are used for multiple projects. Often these 
requirements must meet specific standards that are precisely described in the 
requirement description field. Some of these descriptions can be very lengthy. 
Using the shared requirement function, you can share these requirement 
descriptions among projects. This allows you to easily create, modify and update 
common requirements while eliminating repetitious typing where errors can be 
made. Sharing requirements ensures that requirements common to more than one 
project are consistent from one project to another, or within the same project.

How Shared Requirements Work

The terms mapped and shared are used to define the shared requirements process. A 
shared requirement is one whose description field is used by other requirements. A 
mapped requirement is one whose description is linked to a shared requirement.

A typical use of shared requirements is shown and detailed on the following page. 
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Project A contains a set of frequently used requirements. Projects B and C use some 
of the requirements defined in Project A. Instead of re-entering or modifying 
lengthy requirement descriptions in Projects B and C, you can use the shared 
requirement function to map requirements from Projects B and C to those in Project 
A. Now changes and updates made to shared requirement descriptions in Project A 
are automatically made in Projects B and C. The example also shows that Project B 
is set up to share and map requirements, which allows requirements to map to 
shared requirements in the same project. Specifically R4 is mapped to R2. Projects 
B and C show that requirements can map to more than one project.

The following rules apply to requirements that are shared or mapped:

• Only the information contained in the description field of the requirements is 
shared, not the other attributes, history or traceability data.

• Description fields of mapped requirements are disabled and are not editable.

• If mapping is disabled or disconnected, the description becomes independent 
and can be edited. In essence, it is no longer a mapped requirement.

• Requirements that have key references can be shared but cannot be mapped.

Project A - Shared Project B - Shared &
Requirements Enabled  Mapped Enabled

Project C - Mapped
Requirements Enabled

R1 R1-Shared R1-Mapped

R2-Shared R2-Shared R2-Mapped

R3-Shared R3-Mapped R3-Mapped

R4-Shared R4-Mapped R4-Mapped

Requirement 2 in Project C is mapped to requirement 2 in Project A
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• Mapped requirements cannot be shared.

• Shared descriptions cannot be mapped.

ENABLING SHARED REQUIREMENTS

To use shared requirements, an administrator must first enable this functionality at 
the project level.

To verify that shared requirements are enabled for the projects you want to share 
and map, select the Shared Requirements check box on the Project Info tab. This 
is accomplished by completing the following steps.

1. From the project drop-down list, open the project containing the shared 
requirements by clicking on the project name. The Project Info tab is dis-
played.

2. Verify the following information in the Shared Requirements area of the 
Project Info tab.

Note: If you do not have administrative rights, the options are disabled.If 
sharing and/or mapping is not enabled for your project, contact your Cali-
berRM administrator.
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• In the project that contains the requirements you want to map, verify that the 
Requirements in this project can be mapped to shared requirements 
check box is selected. 

• In the project that contains requirements you want to share, verify that the 
Requirements in the project can be shared check box is selected.

• To share and map requirements in the same project, verify that both boxes 
are selected.

MAPPING A REQUIREMENT

To map a requirement to a shared requirement:

1. Open the project that contains the requirement whose description you want to 
map.

2. Select the requirement to map or create a new requirement and leave the 
description field blank.

3. Select Requirement > Map/Unmap Requirement from the menu or click the 
Map/Unmap Requirement button on the toolbar. The Mapped Description 
dialog box is displayed.

4. Select the project that contains the requirement whose description you want to 
share.
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5. Expand the requirement list, locate the requirement whose description you 
want to share and select it.

6. Click the Map/Unmap Requirement button on the toolbar in the Mapped 
Description box.

The shared indicator is displayed to the left of the shared requirement’s name in 
the requirement list.

7. Click the Save button to save your changes, or click the Cancel Changes 
button to cancel your changes.

8. Close the Mapped Description dialog box.

Shared 
indicator 
appears next 
to shared 
requirement.
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CaliberRM returns to the open project. On the Details tab of the mapped and shared 
requirements, an icon is displayed next to the description field indicating that the 
requirement is either shared or mapped. 

CaliberRM keeps track of mapped and shared requirements and allows you to view 
them in a diagram. See“Mapped Requirements Diagram” on page 249 for more 
information.

UNMAPPING A REQUIREMENT

To unmap a requirement:

1. Open the project that contains the requirement whose description you want to 
unmap.

2. Select the requirement to unmap.

3. Select Requirement > Map/Unmap Requirement from the menu, or click 
the Map/Unmap Requirement button on the toolbar.

4. Select the project that contains the shared requirements from the drop-down list 
in the Mapped Description dialog box.

5. Select the requirement currently shared with the requirement selected in Step 2.

Shared/
Mapped 
icon
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6. Click the Map/Unmap Requirement button on the Mapped Description 
toolbar. 

7. Click the Save button to save your changes, or click the Cancel Changes 
button to cancel your changes.

The shared indicator to the left of the shared requirement’s name in the requirement 
list disappears. On the Details tab of the mapped and shared requirements, the 
shared/mapped icon is removed.

MAPPED REQUIREMENTS DIAGRAM

To keep track of shared and mapped requirements, CaliberRM provides a way to 
view them in a diagram. Given a shared or mapped requirement, the graph displays 
the shared requirement and all requirements that map to it.

To display the Mapped Requirements Diagram, select a shared or mapped 
requirement in the tree and click Show Graph on the Details tab.

Show Graph
Button
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The Mapped Requirement Diagram window opens and displays the mapped 
diagram.

The functionality provided in this window is described in the table below.

Menu Item Toolbar Button Description

Zoom > Center
Zoom in or out 25%

Zoom > Point Zoom in or out 25% and make a 
new center point

Zoom > Percentage Drop-down 
Box Select zoom percentage

Zoom > Rectangle
Draw a rectangle and zoom to fit

View > Tag
View/hide all object tags
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About the Diagram

The Mapped Requirements Diagram is a tree-like structure. The root of the tree is 
the shared requirement which is underlined in green, and the nodes of the tree 
represent the mapped requirements. Requirements in the diagram have three 
identifiers that can be switched on and off using the view/hide buttons on the 
toolbar. They are:

• the requirement serial number

• the requirement name (default setting)

• the project name

You can move objects around in the graph to more easily view the objects of 
interest. To move an object, click on the object and drag it to the desired location in 
the diagram. 

View > Name
View/hide all object names

View > Project View/hide project names for 
each object

File > Print No Button Print the diagram

Menu Item Toolbar Button Description
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Double clicking a requirement opens the Properties dialog box.

Right-clicking on a requirement displays a pop-up menu containing two selections: 
Go to and Properties. Go to selects that requirement in the tree and displays the 
Mapped Requirements Diagram for that requirement. Properties displays the 
Properties dialog box, shown above.
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ABOUT TRACEABILITY

Changing an object whether it is a requirement, a test step, or a section of source 
code, can potentially require changes in other elements of the project. CaliberRM 
supports requirement traceability to allow you to see relationships between 
requirements and other related development and testing information. Linking 
related objects together helps to ensure that changes are implemented correctly at 
all levels. 

Requirements can link to:

• Any requirement in the same project and across projects. 

• tasks, topics and change requests in StarTeam.

• CaliberRBT Cause-Effect Graph files.

• Test sets, tests and test steps in TestDirector. 

• Use Cases, classes, methods, packages and business processes in Select 
Enterprise. 

• Software Configuration Management (SCM) objects. 

• other objects supported by custom vendor add-in modules

When you create a traceability link, CaliberRM automatically creates implied links 
to other requirements which may be affected. For example, if there are direct links 
between a software requirement and a GUI requirement, and between the GUI 
requirement and a coding requirement, there is also an implied link between the 
software requirement and the coding requirement. Implied links are displayed in the 
Traceability Matrix as dotted arrows.

When a requirement is changed, links to other objects become suspect. Suspect 
traces are an indicator that other objects might be affected by the changed 
requirement and should be reviewed. Suspect traces are indicated in the 
Traceability Matrix by a red arrow with a black question mark centered on the 
arrow. 
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You can view the Traceability Matrix to see all traceability links at a glance (see 
“The Traceability Matrix” on page 263), or you can view the Traceability Diagram 
to see the traceability links for a specific requirement (see “The Traceability 
Diagram” on page 259).

For information about traceability with a product integration, see the applicable 
white paper located on your CaliberRM product CD-ROM in the  
Integrations\Integration White Papers directory.

CREATING A TRACEABILITY LINK

Traceability links are described as traces from an object and traces to an object.

To create a traceability link:

1. Select the requirement you want to link to another requirement. 

2. Click the Traceability tab. The Traceability tab is displayed.

3. Click the Modify button. The Open a Project dialog box is displayed.
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4. Select a project. Click OK.

The Traceability Modification dialog box is displayed.

5. Expand the requirement list by clicking the plus sign .

6. Navigate the list until you find the requirement to which you want to link.

Note: You can view requirement properties by right-clicking the requirement 
in the list and selecting Properties.

7. Select the requirement in the list and click the Trace From or Trace To button.

8. Repeat Steps 6-7 until you have created all of the traceability links you need for 
the selected requirement. 
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The trace link indicators appear in the requirement list.

9. Click the Save button.

10. If the Comment dialog box is displayed, enter a comment about the change 
and click OK.

11. You can close the Traceability Modification window and return to the 
Traceability tab by clicking the Close button in the top right corner or you can 
leave this window open if you need to create traces for other requirements.

Trace from
Trace to
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The requirement trace links are displayed on the Traceability tab.

12. To save your changes, select Requirement > Save Changes from the menu, or 
click the Save Changes button. To cancel changes, select Requirement > 
Cancel Changes from the menu, or click the Cancel Changes button. 

DELETING A TRACEABILITY LINK

To delete a traceability link, do one of the following:

If you are working on the Traceability tab:

1. Select the requirement with the link you want to delete.

2. Right-click on the trace you want to delete and click Remove.

If you are working in the Traceability Modification dialog box:

1. Select the linked requirement’s project from the drop-down list.

2. Expand the requirement list by clicking the plus sign .

3. Navigate the list until you find the requirement whose link you want to delete.

Traces To

 

Traces From

Requirement 
being traced
to or from
Deleting a Traceability Link � 257



CHAPTER 16: TRACEABILITY
4. Select the requirement in the list and click the Trace From or Trace To button.

5. To save your changes, click the Save Changes button. To cancel changes, click 
the Cancel Changes button.

6. If the Comment dialog box is displayed, enter a comment about the change 
and click OK.

7. Close the Traceability Modification dialog box by clicking the Close button 
in the top right corner.

MODIFYING TRACES ON THE TRACEABILITY TAB

To modify trace link information from the Traceability tab:

1. Select a requirement and click its Traceability tab.

2. Right-click on an object in the Traces To or Traces From area. The following 
options appear in the pop-up menu.

The following commands are available:

• Modify: Opens the Traceability Modification window.

• Go To: Navigates to the Traceability tab of the requirement you have 
selected.

• Remove: Deletes the trace.

• Make Suspect: Makes the link a suspect link.

3. Select a command and save the changes to the requirement when finished.
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THE TRACEABILITY DIAGRAM

Changing a requirement can dramatically impact project flow. The Traceability 
Diagram allows you to quickly analyze an individual requirement to see how the 
change has impacted its relationships with other objects in the project.

Viewing the Diagram

To view the Traceability Diagram for a specific requirement, select Tools > 
Traceability Diagram from the menu, or the click the Traceability Diagram button 
on the toolbar. These items are only available when a requirement is selected in the 
tree. 

The Trace Diagram window opens and displays the traceability links to and from 
the requirement selected in the requirement tree.
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The following table describes the diagram menu items and toolbar buttons.

The selected requirement is located in the center of the diagram and underlined in 
green. Other objects in the diagram include requirements, Select Enterprise, 
TestDirector and SCM objects that are represented by their associated file type 
icon. The trace to objects are located to the right of the target, while the trace from 
objects are located to the left. The arrows represent the direction of the trace.

You can move objects around in the graph to more easily view the objects of 
interest. To move an object, click on the object and drag it to the desired location in 
the diagram. 

To more easily recognize objects in the diagram, there are three identifiers that can 
be switched on and off using the view/hide buttons on the toolbar. They are:

• the object serial number,

Menu Item Toolbar Button Description

Zoom > Center
Zoom in or out 25%

Zoom > Point Zoom in or out 25% and make a 
new center point

Zoom > Percent Drop-Down 
Box Select a zoom percentage

Zoom > Rectangle
Draw a rectangle and zoom to fit

View > Tag
View/hide all object tags

View > Name
View/hide all object names.

View > Project View/hide project names for 
each object.

File > Print No Button Print the diagram.
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• the object name (default setting),

• the project name.

Requirement Objects

Requirements are represented in the diagram by the requirement icon. Double- 
clicking a requirement node selects it in the requirement tree and makes it the focus 
of the diagram. 

Right-clicking a requirement displays a pop-up menu containing two selections: Go 
to and Properties. Go to selects that requirement in the tree and displays the 
Traceability Diagram for that requirement. 

Properties displays the requirement Properties dialog box.

Suspect Links

Suspect links are indicated by a red arrow with a black question mark centered on 
the arrow, as shown on the following page.
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Circular Traces

A circular trace occurs when an object traces back to itself directly or indirectly. 
When CaliberRM detects a circular trace, the diagram for that branch stops and the 
circular trace indicator is displayed on the diagram, as shown on the following 
page.

Suspect Links
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THE TRACEABILITY MATRIX

The Traceability Matrix is used to display all the trace links in one view. You can 
modify the Traceability Matrix to show only the links you need to see. There are 
several options for modifying the matrix view: filtering by project and object, 
viewing requirements by tag only, viewing only row-to-column or column-to-row 
links. You can save the view you have modified and print a report of the data 
selected. 

Opening the Traceability Matrix

To open the Traceability Matrix window, select Tools > Traceability Matrix from 
the menu, or click the Traceability Matrix button. The Traceability Matrix 

Circular Traces
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window opens and displays the last active matrix view (if it was saved) or the 
default matrix.

The default view contains all requirements in the open project in rows and columns. 
The direction of the arrow indicates the direction of the trace. You can modify the 
view to see the trace links that interest you. 

THE MATRIX VIEW

There are many options for viewing the Traceability Matrix. The following table 
details the matrix options, toolbar buttons and their functions.

Menu Item Toolbar Button Description

Edit > Auto Size Sets the column width.

View > Refresh Refreshes the matrix data.
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SAVING TRACEABILITY MATRIX VIEWS

To save the Traceability Matrix view:
1. Select File > Save from the menu, or click the Save button. 

View > Always on Top Displays the matrix on top of all 
open windows.

View > Requirement by 
Tag

Allows you to view requirements 
by their tag instead of their names.

View > Row to Column Displays objects in rows as tracing 
to objects in columns.

View > Column to Row Displays objects in columns as 
tracing to objects in rows.

View > Implications Displays implied links.

View > Vertical Columns Allows you to toggle between 
vertical and horizontal column 
headings. Vertical is the default.

View > No Traces Displays requirements without 
traces as dark gray in the rows and 
columns.

View > Object Icons Displays objects icons in rows and 
columns.

View > Filter Displays the Traceability Filter 
dialog box.

Menu Item Toolbar Button Description
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The Save As dialog box is displayed.

2. Select a location to save your file.

3. Enter a File name for the view.

4. Click Save to save, or Cancel to exit without saving.

OPEN A PREVIOUSLY SAVED MATRIX VIEW

To open a saved Traceability Matrix view:

1. Select File > Open from the Traceability Matrix menu, or click the Open but-
ton. 

The Open dialog box is displayed as shown on the following page.
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2. Select the view you want to open.

3. Click Open to display the view, or Cancel to exit without opening the view.

FILTERING THE TRACEABILITY MATRIX

You can filter the Traceability Matrix to show specific objects, including 
requirement, test, modeling and SCM. The filter requirements option allows you to 
display information from multiple projects. Requirements from projects to which 
you do not have administrative privileges appear on the matrix but are labeled as 
“secured.”
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To filter CaliberRM requirement objects:

1. Select View > Filter from the menu, or click the Filter button. The 
Traceability Filter window opens to the CaliberRM Projects tab.

2. Select the project to appear in the rows, then select the project to appear in the 
columns.

3. Select the requirement types to appear in the rows, then select the requirement 
types to appear in the columns.

The items you select are listed in the Rows Filter and Columns Filter areas at 
the bottom of the Traceability Filter dialog box. These are the items that will 
appear in the matrix.

4. Click OK. The filtered view is displayed.
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MODIFYING TRACE LINKS IN THE TRACEABILITY MATRIX

To create, modify or delete traceability links within the Traceability Matrix:

1. Locate the requirements on the matrix that you want to create, modify or delete 
a link between.

2. Double-click on the matrix square that corresponds to both requirements. The 
Trace dialog box is displayed.

The requirement listed in the From field is the row requirement and the one 
in the To field is the column requirement

3. Select the Traces option button to create a trace link.

4. Select the Suspect Trace option button to make an already active trace suspect. 

5. Select the Does not trace option button to delete a trace link.

6. Click OK to make the change, or Cancel to exit without changing.
Modifying Trace Links in the Traceability Matrix � 269



CHAPTER 16: TRACEABILITY
If any implied links were created due to the change, they are displayed on the 
matrix.

7. To save your changes, select File > Save Traceability from the menu, or click 
the Save Traceability button. 

PRINTING THE TRACEABILITY MATRIX

When you have finished filtering and rearranging the Traceability Matrix to display 
only the data you want to see, you can print a report of that data.

To print the Traceability Matrix:

1. With the matrix open, select File > Print from the menu, or click the Print but-
ton. The Project Report Setup dialog box is displayed.

2. If you want to preview the report before printing, click the Preview button.

3. Click the Print button. Print using normal Windows printing operations.
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OVERVIEW

CaliberRM provides seven standard requirement reports: Detail, History, 
Discussion, Status, Responsibility and Specification that you can preview, print, or 
export. 

Note: CaliberRM also supports the Caliber Document Factory, which enables 
you to generate customized documents using Word templates.

To generate a CaliberRM report, select Reports from the CaliberRM menu, then 
select the type of report you want to generate. 

DETAIL REPORT

The Detail report lists the details of all requirements in the open project or the 
details of an individual requirement. Details include: name, description, priority, 
status, owner and user-defined attributes. An example Detail report is shown on the 
following page.
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To view the Detail report:

1. Select Reports > Detail from the menu. The Detail Report Setup dialog box 
is displayed.

2. Select the requirement type you want to include in the report, or select all types.

3. Select the sort order for the requirements.

4. To export the report, click the Export button. See “Exporting Reports” on 
page 281 for detailed information about the Export feature.
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To preview the report, click the Preview button. See “Report Preview” on 
page 282 for detailed information about the Preview feature.

To print the report, click the Print button and follow the normal Windows 
printing procedure.

HISTORY REPORT

The History report lists all requirements in the project with their change history 
data.

To view the History report:

1. Select Reports > History from the menu. The History Report Setup dialog 
box is displayed as shown on the following page.
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2. Select the requirement type to be included in the report, or select all types.

3. To export the report, click the Export button. See “Exporting Reports” on 
page 281 for detailed information about the Export feature.

To preview the report, click the Preview button. See “Report Preview” on 
page 282 for detailed information about the Preview feature.

To print the report, click the Print button and follow the normal Windows 
printing procedure.

DISCUSSION REPORT

The Discussion report lists all requirements in the project with their group 
discussion messages.
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To view the Discussion report: 

1. Select Reports > Discussion from the menu. The Discussion Report Setup 
dialog box is displayed.

2. Select the requirement type to be included in the report, or select all types.

3. To export the report, click the Export button. See “Exporting Reports” on 
page 281 for detailed information about the Export feature.

To preview the report, click the Preview button. See “Report Preview” on 
page 282 for detailed information about the Preview feature.

To print the report, click the Print button and follow the normal Windows 
printing procedure.
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STATUS REPORT

The Status report lists all requirements in the project sorted by the status.

To view the Status report:

1. Select Reports > Status from the menu. 

The Requirements by Status Report Setup dialog box is displayed.

2. Select the primary and secondary sort fields in the drop down lists.

3. If you want the description to be included, select the Include description field 
check box. 
276 � Status Report  



CHAPTER 17: REPORTS
4. To export the report, click the Export button. See “Exporting Reports” on 
page 281 for detailed information about the Export feature.

To preview the report, click the Preview button. See “Report Preview” on 
page 282 for detailed information about the Preview feature.

To print the report, click the Print button and follow the normal Windows 
printing procedure.

RESPONSIBILITY REPORT

The Responsibility report lists all requirements in the project and is sorted by the 
responsible user. An example Responsibility report is shown below.

To view the Responsibility report:

1. Select Reports > Responsibility from the menu. 

The Requirements by Responsibility Report Setup dialog box is displayed 
as shown on the following page.
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2. Click the Include description field check box to include the description text in 
the report.

3. If you want to include all CaliberRM users, go to Step 6.
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If you want to select specific users, click the Select Users button to display 
the list of available users.

4. Select the users you want to include from the Available list. 

Note: Use the SHIFT key to select a range of users, or the CTRL key to 
select multiple users individually.

5. Click the Move Right button.

Note: You can move all users in the list by clicking the Move All Right but-
ton.

6. To export the report, click the Export button. See “Exporting Reports” on 
page 281 for detailed information about the Export feature.

To preview the report, click the Preview button. See “Report Preview” on 
page 282 for detailed information about the Preview feature.

To print the report, click the Print button and follow the normal Windows 
printing procedure.
Responsibility Report � 279



CHAPTER 17: REPORTS
SPECIFICATION REPORT

The Specification report generates a requirement specification report in Microsoft 
Word format. You can export that report in Word format. An example Specification 
report is shown below.

To view the Specification report:

1. Select Reports > Specification from the menu. The Requirement Specifica-
tion Report Setup dialog box is displayed. 

2. Select the Requirement Type to be included in the report. The default is All 
Types.
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3. Select the appropriate check box to add Serial Numbers, Hierarchical Numbers, 
and Requirement Names to the report.

4. Select the layout you would like to use:

5. To export the report, click the Export button. See “Exporting Reports” on 
page 281 for detailed information about the Export feature.

To preview the report data, click the Preview button. See “Report Preview” 
on page 282 for detailed information about the Preview feature.

To print the report, click the Print button and print using the normal 
Windows printing procedure.

EXPORTING REPORTS

To export reports:

1. In the report Report Setup dialog box, click the Export button. The Save As 
dialog box is displayed as shown on the following page.

TableOutline
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2. Choose a location in which to save your file.

3. Enter a File name and type.

4. Click Save.

When the export is complete, CaliberRM prompts you to open the file.

REPORT PREVIEW

The Report Preview contains several options for viewing your report preview, and 
allows you to print the data. 

The toolbar features (listed in order from left to right) perform the following 
functions:

First Page: Displays the first page of the report.

Previous Page: Displays the previous page.
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Current Page number: Displays what page is currently being viewed.

Next Page: Displays the next page.

Last Page: Displays the last page of the report.

Cancel: Cancels the loading process of the records. 

Print: Displays the Print dialog box, which allows you to choose the printer, 
pages to print and number of copies to print.

Printer Setup: Displays options for setting up your printer.

Magnification: Zooms in or out.

Total: Displays the total number of records in the report.

Percent Read: Displays the percentage of records displayed in the preview.

Records Read: Displays the number of records displayed in the preview.
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OVERVIEW

CaliberRM enables project teams to provide feedback on requirements and projects 
through the Group Discussion feature. This collaborative feature enables team 
members to enter and reply to comments to help define, refine and prioritize 
requirements. 

There are two levels of discussions: 

• Project level discussion messages and replies are stored by project on the 
project Discussion tab. 

• Requirement level discussion messages and replies are stored by requirement 
on the requirement Discussion tab.

PROJECT LEVEL DISCUSSION

Project level discussion is available for each project. You can access it by selecting 
the project name in the requirement list and clicking the Discussion tab. See 
“Reading a Message” on page 288 for more information about reading messages.

REQUIREMENT LEVEL DISCUSSION

There are three ways to determine that a requirement has an unread discussion item:

• the unread discussion indicator in the requirement tree

• the unread discussion list

• the unread discussion indicator associated with the message entry on the 
Discussion tab
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Unread Discussion Indicator

When a requirement has a discussion item that has not been read, an unread 
discussion indicator is located to the left of the requirement name in the 
requirement list. When you read the message, the indicator disappears.

Unread Discussion List

The unread discussion list is a list of requirements that have unread messages. You 
can set CaliberRM to automatically display this list when you open a project. 

To set this option:

1. Select Tools > Options from the CaliberRM menu. The Options dialog box is 
displayed.

2. Select the General tab.

3. Select the Show unread discussions upon loading projects check box.

4. Click OK.

When you open a project in CaliberRM, the Unread Discussions dialog box 
appears if there are any unread discussions in the project. 
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You have the option to sort requirements by name or owner by clicking the header 
in the Unread Discussions dialog box, and see only those that you own by select-
ing the Only show Requirements that I own check box.

To read an unread discussion:

1. Double-click the message you want to read, or select the message in the list, 
and click the Select button.

CaliberRM displays the requirement with the unread discussion.

2. Select the Discussion tab and read the message. For information about reading 
messages, see “Reading a Message” on page 288.

After reading the message, you may go back to the Unread Discussion List and 
select another requirement.

You can turn off this option at any time by clearing the Show unread discussions 
upon loading projects check box. 

Click the header to sort by 
Requirement or Owner.
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Viewing the Unread Discussion List

If you prefer not to have the unread discussions list display automatically upon 
opening a project, you may still view unread discussions.

To view unread discussions at any time while you are logged into a project in 
CaliberRM:

1. Select Tools > Unread Discussions or press the CTRL-D keys. The Unread 
Discussion List dialog box is displayed. 

2. Double-click the message you want to read, or select the message in the list, 
and click the Select button.

CaliberRM goes to the requirement with the unread discussion.

3. Select the Discussion tab and read the message.

READING A MESSAGE

The Discussion tab displays all messages posted for the selected requirement. You 
can sort messages in ascending order by subject, author or date by clicking on the 
appropriate header. Clicking a second time sorts messages in descending order.

Unread messages on the Discussion tab have an indicator that is illuminated green. 
Once you have read the message, the indicator becomes gray.

To read a message:

1. Click the Discussion tab for the requirement with the unread message.

2. Select the message you want to view from the list displayed. You can collapse 
or expand replies by clicking on the plus sign (+) or minus sign (-) to the left of 
the subject.

The text of the message is displayed in the message text area as shown on the 
following page.
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POSTING A NEW MESSAGE

To post a new message:
1. Select the requirement for which you want to post a message.

2. Click the Discussion tab.

3. Click the Post New button. The New Message dialog box is displayed as 
shown on the following page.
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4. Enter a subject in the subject field.

5. Enter a message in the message box.

6. To post your message, select File > Post Message from the menu, or click the 
Post Message button. To exit without posting the message, select File > Close 
from the menu.

REPLYING TO A MESSAGE

To reply to a message:

1. Click the Reply button. The New Reply Message dialog box opens with the 
subject field filled in automatically.

2. Type your message in the message box.

3. To post your message, select File > Post Message from the menu, or click the 
Post Message button. To exit without posting the message, select File > Close 
from the menu. 
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UPDATING THE MESSAGE LIST

When you select a requirement, its group discussion list contains all current 
messages. However, if a message is added while you are in the Discussion tab, you 
may not automatically receive that message. 

To update the message list, click the Refresh button on the Discussion tab.
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OVERVIEW

Document references are used by CaliberRM to provide additional information for 
a requirement. Referenced documents may include a specifications document, 
meeting notes, a screen shot or anything else that might be of use in defining or 
understanding requirements. 

CaliberRM supports an unlimited number of document references for each 
requirement, and can support any file type with an associated application, such as 
Word, Excel, Power Point, graphics files, HTML files, URLs so you can reference a 
Web site and more. CaliberRM also allows you to enter a text reference, so you can 
reference a book, periodical, or anything that is not online.

There are two types of document references. Key references and non-key 
references. A key reference might be the source document from which a 
requirement is derived. You can link text within the reference to become the 
requirement description. Key references must be Word documents. CaliberRM 
supports Word 97 and 2000. Each requirement can have only one key reference. 
Non-key references are simply supporting documents related to the requirement. 

You can copy and paste or drag and drop documents from Windows Explorer or 
selected Word text into the References tab in CaliberRM to create new references.

Note: Document References should be stored on the Network on a shared drive. 
Users can use a mapped network drive or a universal naming convention (UNC) 
to access the file.

CREATING A DOCUMENT REFERENCE

To create a document reference for a requirement:

1. Select the requirement for the reference.
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2. Select the References tab.

3. Click the New File button. The Add Reference Files dialog box is displayed.

4. Select the file(s) you would like to add.
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Note: If you want to add a file other than a Word document, change the Files of 
Type selection to All Files.

5. Click the Add button to add the file(s) to the list.

6. If the reference is a Word or Excel file, you can link to specific text or cells 
within the document (see “Linking Text Within a Reference” below).

7. To save your changes, select Requirement > Save Changes from the menu, or 
click the Save Changes button. To cancel changes, select Requirement > 
Cancel Changes from the menu, or click the Cancel Changes button.

8. If the Comment dialog box is displayed, enter a comment about the change 
and click OK.

LINKING TEXT WITHIN A REFERENCE

When you create a reference to a Word document, CaliberRM allows you to link 
directly to text within that document. When you open the document within 
CaliberRM, the selected text is displayed automatically, regardless of its location in 
the document. The text you select becomes the reference description. If the 
reference is a Word document, and is set as a key reference, this text becomes the 
requirement description also.

To link document text within a reference:

1. Click the New File button. When the Add Reference Files dialog box opens, 
choose a file and select the Open Immediately option button.

OR, if you want to link text within an existing referenced document,

1. Double click the document reference in the list on the References tab.

 Word opens in the CaliberRM right window. The CaliberRM toolbar is 
displayed in the status bar, making both CaliberRM and Word menus 
available. See the graphic on the following page.
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Note: This works the same for Excel files. 

2. Select the text in the document to which you want to link.

3. Select Requirement > New Reference from the menu, or click the Create 
New Reference button.

Note: To delete a link to document text, select the linked text and select 
Requirement > Delete Reference from the menu, or click the Delete Refer-
ence button. If you delete a link to text in the document, the reference docu-
ment is removed from the list.

4. To save the document, select File > Save from the menu, or click the Save 
Document button. 

5. To close the document, select File > Close from the menu, or click the Close 
Window button in the CaliberRM menu. 

The text linked to is displayed as the reference description. If the document is 
an Excel file, the cells linked to are displayed as the description.

To create multiple links to text in the document, repeat Steps 2 through 4. 
Each link is displayed as a separate document reference. 

Word menu

CaliberRM 
menu
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6. To save your changes to the requirement, select Requirement > Save Changes 
from the menu, or click the Save Changes button. To delete changes, select 
Requirement > Cancel Changes from the menu, or click the Cancel Changes 
button.

7. If the Comment dialog box is displayed, enter a comment about the change 
and click OK.

SETTING A DOCUMENT REFERENCE AS THE KEY REFERENCE

When a document reference is set as the key reference, the linked text associated 
with that reference automatically becomes the requirement description. 

Note: The description is not editable when it is a key reference.

To set a document as the key reference:

1. Right click on the document.

2. Select Set as Key Reference in the pop-up menu.

Note: If another document is set as the key reference, the key reference is 
automatically transferred to the document you have selected.

3. To save your changes to the requirement, select Requirement > Save Changes 
from the menu, or click the Save Changes button. To delete changes, select 
Requirement > Cancel Changes from the menu, or click the Cancel Changes 
button.

4. If the Comment dialog box is displayed, enter a comment about the change 
and click OK.

To clear the key reference, right click on the key reference document and select 
Clear Key Reference from the pop-up menu and save the change.
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CREATING A REQUIREMENT FROM A DOCUMENT

CaliberRM allows you to open an existing Word document and create requirements 
from the document. This is helpful when there are existing requirement documents 
to be incorporated into a CaliberRM project. When creating a requirement from a 
document, several options are available: 

• creating a requirement with the text specified as a key reference 

• creating a requirement with the text specified as a non-key reference 

• creating a requirement without a reference to the document 

• importing a group of requirements (see “Importing Requirements from 
Microsoft Word” on page 387 for more information).

WARNING: IF YOU HAVE SPECIFIED THE INITIAL VALUE OF AN ATTRIBUTE 
AS “FORCE USER TO ENTER VALUE,” YOU WILL BE FORCED TO ENTER THIS 
VALUE FOR EACH REQUIREMENT AS IT IS CREATED, ALLOWING YOU TO 
CREATE ONLY ONE REQUIREMENT AT A TIME. HAVE YOUR ADMINISTRATOR 
TEMPORARILY CHANGE THE ATTRIBUTE’S INITIAL VALUE TO “USE DEFAULT 
VALUE” OR “INHERIT FROM PARENT” BEFORE CREATING MULTIPLE 
REQUIREMENTS FROM A WORD DOCUMENT.

To create a requirement from within a Word document:

1. Select a requirement type or requirement. 

Note: The new requirement is created as a child of or inserted before/after 
the selected requirement.

2. Select File > Open Word Document from the menu. 

As shown on page 296, Word opens in the right window of CaliberRM, and 
the menus and toolbars change to Word menus and toolbars. The CaliberRM 
toolbar is displayed in the status bar making both CaliberRM and Word 
commands available.

3. Select the text to use as the requirement description.
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4. To create the requirement, perform one of these steps:

• To create a new requirement without a reference to the document, click the 
appropriate Create Requirement button at the bottom left side of the 
screen.

• To create a new requirement with the selected text as a non-key reference, 
hold the SHIFT key and click the appropriate Create Requirement 
button at the bottom left side of the screen.

• To create a new requirement with the selected text as a key reference, hold 
the CTRL key and click the appropriate Create Requirement button at 
the bottom left side of the screen.

The new requirement is created, and you can create additional links to text 
within the document.

5. To save the document, select File > Save from the menu, or click the 
CaliberRM Save Document button. 

6. To close the document, select File > Close from the menu, or click the Close 
Document button. 

The selected text becomes the requirement description. You can finish 
defining the requirement (see “Requirements” on page 211).

7. To save your changes to the requirement, select Requirement > Save Changes 
from the menu, or click the Save Changes button. To delete changes, select 
Requirement > Cancel Changes from the menu, or click the Cancel Changes 
button.

8. If the Comment dialog box is displayed, enter a comment about the change 
and click OK.
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MODIFYING A REFERENCED DOCUMENT

WARNING: MODIFYING A REFERENCED DOCUMENT OUTSIDE OF 
CALIBERRM MAY AFFECT LINKS. FOR THIS REASON, WE RECOMMEND 
THAT YOU PLACE ALL DOCUMENTS RELATED TO THE PROJECT IN A SECURE 
DIRECTORY.

To modify a referenced document:

1. Double click on the document to modify.

As shown on page 296, Word opens in the right window of CaliberRM, and 
the menus and toolbars change to Word menus and toolbars. The CaliberRM 
toolbar is displayed in the status bar making both CaliberRM and Word 
commands available. If the document is another file type, CaliberRM starts 
the associated application in a separate window.

2. Make changes to the document as needed.

3. You can link to text or cells in Word or Excel files to specify exactly what to 
reference (see“Linking Text Within a Reference” on page 295).

4. To save Word or Excel documents, select File > Save from the menu, or click 
the CaliberRM Save Document button. Save files of other types within their 
associated applications.

5. To close Word or Excel documents, select File > Close from the menu, or click 
the Close Document button. Close other applications normally.

6. To save your changes to the requirement, select Requirement > Save Changes 
from the menu, or click the Save Changes button. To delete changes, select 
Requirement > Cancel Changes from the menu, or click the Cancel Changes 
button.

7. If the Comment dialog box is displayed, enter a comment about the change 
and click OK.
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DELETING A DOCUMENT REFERENCE

Note: Deleting a document reference does not delete the document itself, just the 
link to it.

To delete a document reference:

1. Select the document reference to remove.

2. Click the Remove button on the References tab, or right click on the document 
and select Remove in the pop-up menu.

A message is displayed verifying that you want to delete the reference.

3. Click Yes to delete the reference, or No to save it.

4. To save your changes to the requirement, select File > Save Changes from the 
menu, or click the Save Changes button. To delete changes, select 
Requirement > Cancel Changes from the menu, or click the Cancel Changes 
button.

5. If the Comment dialog box is displayed, enter a comment about the change 
and click OK.
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OVERVIEW

Baselines allow you to label a set of requirements at specific versions. Baselining is 
an option that can be used only if you choose to do so. You must have baseline 
administrator privileges to create, manage and delete baselines. For instructions on 
making a user a baseline administrator, see page 79.

CaliberRM also features the Electronic Signature for Baselines functionality. This 
optional feature allows certain users, called signatories, to electronically sign a 
locked baseline by entering login credentials. For more information on this feature, 
see page 313.

You can view baseline information in the Framework Administrator. Select the 
project that contains the baselines you want to view and select the Project 
Baselines tab.

The tab displays information about each baseline:

• Baseline Name: The name of the baseline.
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• Initialization Date: The date and time the baseline was initialized. Dates are 
displayed using the CaliberRM appearance setting for date format. To change 
the appearance, select Tools > Options > Appearance tab.

• Last Modified Date: The date and time of the last modification made to the 
baseline.

• Lock Status: Indicates if the baseline is locked or unlocked. Only a baseline 
administrator can modify an unlocked baseline. A locked baseline cannot be 
managed or unlocked.

• Date Locked: The date and time the baseline was locked.

CREATING A PROJECT BASELINE

Creating a baseline defines the baseline’s characteristics, not its contents. 

You can create baselines in CaliberRM or the Framework Administrator. 

Creating a Baseline in CaliberRM

In CaliberRM, you must be a baseline administrator to create baselines.

To create a baseline in CaliberRM:

1. Select File > Baseline Administration > New Baseline. 
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The New Baseline dialog box is displayed.

For each baseline, there are three tabs that contain information about the 
baseline: Properties, Signatories, and Signature Meaning.

2. On the Properties tab, enter a name and description for the baseline.

3. If you want all users that are assigned or interested in a requirement to receive 
email notification when that requirement is added to or removed from the 
baseline, select the Send Baseline Maintenance Change Notifications via 
Email check box.

Note: The Lock Baseline check box is disabled when creating a new base-
line. It only becomes enabled after you initialize the baseline. 

4. Select the Signatories tab.
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Note: Baseline signatories are only required if you are using the Electronic 
Signature for baselines feature. For information, see “Electronic Signatures 
for Baselines” on page 313.  

The tab displays a list of people, called Signatories, who can sign a locked 
baseline. 

5. Click Modify to add users to the list. 
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The Add Baseline Signatories dialog box is displayed.

6. Select the users you want to add as signatories for the baseline:

• To select signatories from existing members of the project, select the 
Members of this baseline’s project option button.

• To select from signatories in an existing baseline, select the Signatories of 
the following baseline option button. The baseline drop-down list is 
enabled. Select the baseline that contains the signatories you want to add 
to the new baseline.

The top pane contains all members of the project or existing signatories from 
an existing baseline. From this list, select the users you want to add as 
signatories by selecting the check box next to the user’s name. The bottom 
pane provides a preview of the signatory list.

Note: Use the SHIFT key to select a range of users, or the CTRL key to 
select additional users.

7. Click OK.

8. Select the Signature Meaning tab.
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Note: This step is only required if you are using the Electronic Signature for 
baselines feature. See “Electronic Signatures for Baselines” on page 313 for 
more information on this feature.

Each baseline has attached to it a list of signature meanings for electronic 
signatures. Each baseline must contain at least one signature meaning value. 
When a user “signs” a baseline, he/she selects a signature meaning for the 
signature. The default signature meaning is Approved. All existing baselines 
created prior to version 5.1 receive the Approved signature meaning, and all 
new baselines default to the Approved signature meaning.

Note: The Approved signature meaning does not appear in the list until you 
select OK.

9. To create a new signature meaning, select a signature meaning in the list, and 
click either the Insert Before or Insert After button. 

10. Type a name for the signature meaning in the blank list entry. You can 
rearrange signature meanings in the list by selecting a signature meaning and 
clicking the Move Up or Move Down button.

You c
click h

Click here to 
create a new 
signature 
meaning.
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Note: To delete a signature meaning, select the signature meaning in the list 
and clicking the Delete button. You must have at least one signature meaning. 
CaliberRM does not allow you to delete the last remaining signature meaning 
from the list.

11. You can also import the signature meaning list from another baseline. To do so, 
click the Import button. The Import Signature Meanings dialog box is 
displayed.

12. Select a baseline from the drop-down list.

13. Click OK.

14. Click OK to save the new baseline.

15. Click the Save button to save the project. The New Baseline window closes 
automatically and the new baseline is listed in the Baseline drop-down list on 
the menu.

Creating a Baseline in Framework Administrator

To create a baseline in the Framework Administrator:

1. Select View > Projects from the menu, or click the Project View button.

2. Select the project for which you want to add a baseline.

3. Click the Project Baselines tab.

4. Click the New button. The New Baseline dialog box is displayed.
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5. Complete Steps 2 through 15 starting on page 305.

INITIALIZING A BASELINE

Once you have created a baseline, you must initialize it. That is, you have to 
populate the baseline with requirement information. You must be a baseline 
administrator to initialize a baseline.

To initialize a baseline:

1. In CaliberRM, select a baseline from the Baseline drop-down list or select 
File > Open Baseline from the menu. The Initialize a Baseline dialog box is 
displayed.

2. Select the desired baseline to initialize from the Starting point drop-down list.

3. If you want to baseline the current state of the project without performing 
baseline maintenance, click OK. 

4. If you want to perform baseline maintenance, select the Proceed to baseline 
maintenance after pressing OK check box, then proceed to the section 
“Modifying a Baseline” on page 311.

Note: When a baseline is initialized or modified, traceability, references, and 
discussion are not baselined.
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MODIFYING A BASELINE

You may add or remove requirements from a baseline, or change the version of a 
requirement associated with a baseline. You must be a baseline administrator to 
modify a baseline.

To modify a baseline:

1. Initialize a baseline as described on page 310.

2. Select File > Baseline Administration > Baseline Maintenance from the 
menu. The Baseline Maintenance window is displayed. It contains the 
requirement tree with check boxes next to the requirements contained in the 
baseline.

3. Select or clear requirements as desired. Selected requirements are included in 
the baseline. A check indicates the requirement is selected.

Note: You can also select a different version of a requirement by right click-
ing on it and changing the version number to the version you intend to 
baseline.
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4. Click the Save button to save your modified baseline.

Note: When a baseline is initialized or modified, traceability, references, and 
discussion are not baselined.

LOCKING A BASELINE

WARNING! ONCE YOU LOCK A BASELINE, YOU CANNOT UNLOCK IT. THE LOCK 
BASELINE CHECK BOX BECOMES DISABLED ONCE YOU SELECT IT.

Once you have completed all baseline maintenance, you can lock a baseline. Once 
you lock a baseline, you cannot make modifications to it. However, signatories can 
sign the baseline, modify signatures, and assign meanings to it once it is locked. 
You must be a baseline administrator to lock a baseline.

To lock a baseline:

1. In CaliberRM, select a baseline from the Baseline drop-down list or select 
File > Open Baseline from the menu.

2. Select File > Baseline Administration > Baseline Properties from the menu. 
The Baseline Properties dialog box is displayed.

3. On the Properties tab, select the Lock Baseline check box. The Lock Baseline 
warning is displayed.

4. Click Yes to lock the baseline, or No to cancel the action.

5. Click OK. The baseline is locked and the Lock Baseline check box becomes 
disabled.

When a baseline is locked, all signatories for the baseline receive email notification 
informing them the baseline is ready to be signed. Signatories added after a baseline 
is locked also receive notification.

DELETING A BASELINE

You must be a baseline administrator to delete a baseline. You cannot delete a 
locked baseline.
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Note: You must clear the requirements and requirement types from the baseline 
before the baseline can be deleted. This is accomplished using baseline modifica-
tion.

To delete a baseline:

1. In the Framework Administrator, select View > Projects from the menu or 
click the Project View button.

2. Select the project that contains the baseline you want to delete.

3. Click the Project Baselines tab. The baseline list is displayed.

4. Select the baseline you want to delete. The Delete button becomes enabled.

5. Click the Delete button. A message is displayed verifying that you want to 
delete the baseline.

6. Click Yes to delete the baseline, or click No to keep the baseline.

7. Click the Save button to preserve the deletion.

ELECTRONIC SIGNATURES FOR BASELINES

Baseline signatures are the electronic equivalent of a “sign off sheet” that is used to 
approve a set of requirements prior to development work taking place.

Baseline signature functionality is accessed using the CaliberRM Tools > Baseline 
Signatures menu item or clicking the Baseline Signatures button. 
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Selecting this menu item displays the Baseline Signatures window. 

From this window, you can view details about a signed baseline, add a new 
signature, view and print signature reports, and compare baselines.

Depending on the status of the signature, the signatures are displayed in various 
colors and font styles:

• If you have signed the baseline, your signature entry is the window text color, 
usually black. You can double-click the entry to view signature details.

• If you have not signed the baseline your signature entry is the window’s text 
color and bold. You can double-click the entry to add your signature.

• If another user has not signed the baseline, his/her signature entry is gray and 
bold.

• If another user has signed the baseline, his/her signature entry is the window 
text color, usually black.
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Adding a Signature

To sign a baseline:

1. In CaliberRM, select a baseline from the Baseline drop-down list or select 
File > Open Baseline from the menu.

2. Select Tools > Baseline Signatures from the CaliberRM menu. The Baseline 
Signatures window is displayed.

3. Click the Add Signature button. 

Note: The Add Signature button is only enabled if the baseline is locked and 
you are a signatory for the baseline.

The New Signature dialog box is displayed.

4. If you want to add or change your title, enter it in the Title box.

5. Assign a Signature Meaning to the signature using the drop-down list.

6. In the Authentication section, verify your User ID and enter your Password.
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7. If you want to add a comment, enter it in the Comment box. The maximum 
length allowed for a comment is 5000 characters.

8. Click OK. The Baseline Signature warning dialog box is displayed, verifying 
that you want to sign the baseline.

9. If you do not want to receive the warning in the future, select the Do not show 
this warning in the future check box.

10. Click OK. Your signature now appears in the Baseline Signatures window.

Signatories can sign a baseline multiple times, however, once a signature is added it 
cannot be replaced or deleted.

Signature Details

You can view the details of baseline signatures using the Details button in the 
Baseline Signatures window. Select a signed baseline in the list and click this 
button to display the Baseline Signature window.
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The window displays information about the baseline, such as the project, the 
version of the baseline, and dates the baseline was initialized, locked and signed. It 
also displays signature information such as the signatory, the signatory’s title, 
signature meaning and comments.

Signature Reports

You can view a report of a baseline’s signatures by selecting the Signature Report 
button in the Baseline Signatures window. The report is launched in your web 
browser.

The report is sorted using the same sort order as the signature list in the Baseline 
Signatures window.

You can also view signature information in reports using the CaliberRM Document 
Factory. See page 343 for more information on this feature.
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COMPARING BASELINES

You can compare baselines to review baseline changes or project progress.

To compare two baselines:

1. Select Tools > Compare Baselines from the menu. The Compare Baselines 
dialog box is displayed.

Note: You can also access the Compare Baselines dialog box by selecting 
Tools > Baseline Signatures, then clicking the Compare Baselines button in 
the Baseline Signatures window. 

2. Select the two baselines you want to compare from the respective drop-down 
lists.

3. Click OK. A comparison of the baselines is displayed in an .html file, shown 
on the following page.
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You can select one of three ways to view the data:

• Show Baseline Comparison: Displays differences according to the 
hierarchical structure of the requirements. 

• Show Only Baseline Differences Grouped by Requirement Type: 
Displays differences by Requirement Type.

• Show Only Baseline Differences Grouped by Difference Type: 
Displays differences by Difference type.

• Missing: A requirement exists in one baseline, but not the other.

• Moved: A requirement has been moved.
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• Moved and Versioned: A requirement has been moved and is a 
different version.

• Versioned: A requirement is a different version.

4. You can print the report by selecting File > Print and following normal 
Windows printing procedure.
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DRAG-AND-DROP FILE CREATION

CaliberRM allows you to use a drag-and-drop operation to create a file shortcut 
from a requirement. The file shortcut is created by dragging a requirement outside 
of the requirement tree window and dropping it into any window that accepts an 
Object Linking and Embedding (OLE) file (e.g., Microsoft Word or a web browser 
such as Internet Explorer or Netscape Navigator, etc.).

The file created is identified by the RM icon and has the requirement’s name as the 
file name and a .crm file name extension.

The file contains the ServerName, ProjectID and RequirementID. 

You can also use a drag-and-drop operation to move a previously created .crm file 
into a project. To move a .crm file, click on the file and drag and drop it into the 
desired location in the requirement tree. 

You can select the directory in which the file is placed by selecting Tools > Options 
from the CaliberRM menu and modifying the file location specified on the 
Clipboard tab. 

Note: Depending on where the file is dropped, a link may be created to the loca-
tion where the .crm file was actually created (i.e. the destination location listed 
above).The Windows Temp Directory is the default location for the .crm files.

When you double click on a .crm file, CaliberRM is launched and the requirement 
is displayed. You can also reassociate your .crm files to automatically launch the 
Requirement Viewer.

REQUIREMENT VIEWER

Requirement Viewer is a utility that can open a .crm file and provides a “quick 
view” of a requirement. 
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Note: Although it is not necessary to log in as a CaliberRM client to use Require-
ment Viewer, you must be logged on to the CaliberRM server where the .crm file 
is located. 

STARTING REQUIREMENT VIEWER

To launch the Requirement Viewer:

1. Navigate to the location where you installed CaliberRM. The default location is 
C:\Program Files\Borland\CaliberRM.

2. Locate the CaliberRMViewer.exe file and double-click it. The Requirement 
Viewer window is displayed.

3. Open a .crm file by selecting File > Open Requirement. 

4. The Open dialog box is displayed. Navigate to the location of the .crm file you 
want to open. Click Open.
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When you open the selected file, the requirement information is displayed.

From this window, you can:

• Launch CaliberRM by selecting File > Launch CaliberRM, or by clicking the 
Launch CaliberRM toolbar button. CaliberRM starts and with the project 
containing the specified requirements open and the requirement selected.

• Print the requirement by selecting File > Print, or by clicking the Print button, 
and use the standard Windows print features.
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• Customize the look of the requirement by selecting View > Customize Fonts. 
You can use this option to set the character formats and color for each 
requirement label and data. 

• Font size Color: opens a standard Windows character formats dialog

• Background Color: provides choices for the background color of the selected 
display

• Apply To List Type: displays a dialog box that allows you to apply font and 
background color shown in the Sample display to all fields of the selected List 
Types.

• Default Font: resets the format of the selected Sample display to 12 point 
Arial with alternating yellow and white background color

• Load Default Fonts: resets all samples to 12 point Arial with alternating 
yellow and white background color.
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Chapter 22: Document Factory

The Caliber Document Factory enables you to generate any type of up-to-date, 
customized specifications documents using Microsoft Word templates. In Word, 
you can create templates containing fields that correspond to CaliberRM 
requirement attributes. You can then use the Caliber Document Factory to populate 
the template with data from any project. Using filter criteria in the template fields, 
you can even specify what requirement data is included in the document. Document 
Factory generates .doc, .txt and .rtf files. 

HOW DOCUMENT FACTORY WORKS

The first step in generating a Document Factory document is to create a Microsoft 
Word template. Templates contain any printable data you want to appear in the 
document including column headers, labels and page numbers. Templates also 
contain Document Factory commands, keywords and operators.

• Commands control the selection, order and grouping of the requirements in the 
document.

• Keywords are placeholders that correspond to CaliberRM project and 
requirement information. They specify the data that is put into the document. 
They must be entered into a template exactly as they appear in CaliberRM.

• Operators allow you to apply very specific criteria when searching for groups 
of requirements.

You can format your template to create the look you desire including tables of 
contents, headers and footers and page numbers. You can apply most character and 
paragraph formatting available in Word to the entire template, including the 
keywords. When the template is complete, you can run Document Factory to 
populate the template with data from a project.
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There are several sample templates included with CaliberRM. If installed, they are 
located in Program Files\Borland\CaliberRM\Samples (or where you installed 
CaliberRM). There are also many sample templates and output in “Document 
Factory Sample Templates and Outputs” on page 443.

COMMANDS

Document Factory uses a set of special commands referred to as $Commands to 
populate and format the document. The $Commands are non-printing and do not 
appear in the completed document. Some commands, like $Begin_list/$End_list, 
are used in pursuant process lists of information, such as a list of traceability links 
or a list of users responsible for a requirement. $Commands alone do not cause data 
to be placed in the document. They must be used in conjunction with keywords.

Note: $Commands are not case sensitive, and uppercase letters are not required 
for proper operation; however, adopting a formatting style and using it consis-
tently adds to the readability of your templates.

Function Usage See... Purpose

$PROJECT{ } Optional page 329 Specifies the project name for 
the document. 

$BASELINE{ } Optional page 329 Specifies the baseline to be 
used for the document. 

$BEGIN_SECTION Required page 330 Marks the beginning of a 
section. Most commands 
must be enclosed in a 
$BEGIN_SECTION/
$END_SECTION command.

$END_SECTION Required page 330 Marks the end of a section. 
Must be used with 
$BEGIN_SECTION.
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$FILTER{ } Optional page 331 Specifies that only data that 
meets the criteria specified by 
its arguments is included in 
the section.

$SORT{ } Optional page 334 Specifies the order 
requirements are sorted. 

$INDENTION_LEVEL{ } Optional page 335 Specifies the maximum 
number of levels a section will 
be indented.

$INDENTION_SIZE{ } Optional page 335 Specifies how far, in inches, 
each level is indented.

$BEGIN_LIST Optional page 336 A command loop used with 
keywords to produce lists. 
Data is pre-formatted.

$END_LIST Optional page 336 Marks the end of a list. Must 
be used with $BEGIN_LIST.

$BEGIN_HISTORY Optional page 336 A command loop used with 
history revision keywords. 
Allows you to format the data.

$END_HISTORY Optional page 336 Marks the end of the history 
revision loop. Must be used 
with $BEGIN_HISTORY.

$BEGIN_CHANGES Valid only if 
$BEGIN_
HISTORY/
$END_
HISTORY is 
used

page 336 A command loop used with 
history changes keywords. 
Allows you to format the data.

$END_CHANGES page 336 Marks the end of the history 
changes loop. Must be used 
with $BEGIN_CHANGES.

$BEGIN_TRACES( ) Optional page 337 A command loop used with 
the traceability keywords. 
Allows you to format the data.

Function Usage See... Purpose
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$END_TRACES Optional page 337 Marks the end of the 
traceability loop. Must be used 
with $BEGIN_TRACES.

$CALCULATE{ } Optional page 339 Performs calculations on 
specified keywords. 

$BEGIN_DISCUSSIONS Optional page 340 A command loop used to 
format requirement discussion 
data. Used with discussion 
keywords.

$END_DISCUSSIONS Optional page 340 Marks the end of the 
requirement discussion loop. 
Must be used with 
$BEGIN_DISCUSSIONS.

$BEGIN_PROJECT_
DISCUSSIONS

Optional page 341 A command loop used to 
format project discussion 
data. Used with discussion 
keywords.

$END_PROJECT_
DISCUSSIONS

Optional page 341 Marks the end of the project 
discussion loop. Must be used 
with $BEGIN_PROJECT_
DISCUSSIONS.

$BEGIN_GLOSSARY Optional page 341 A command loop used to 
include glossary information. 
Used with glossary keywords.

$END_GLOSSARY Optional page 341 Marks the end of the glossary 
loop. Must be used with 
$BEGIN_GLOSSARY.

$RGVFile Optional page 342 A command loop used to 
apply a Requirement Grid 
filter within a section. 

Function Usage See... Purpose
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$PROJECT{ } 

This command specifies the project to be used for the document. If you are creating 
a project specific template you may want to include this command in your template. 
If you do not include this command in your template, Document Factory prompts 
you to choose a project. The project name must appear the same as it does in the 
project drop-down list.

Note: Only one project may be specified in a template. 

Syntax

$PROJECT{Automated Teller Machine}

$BASELINE{ } 

This command specifies the baseline used for the document. If a baseline is not 
specified, the current version of requirements is used. If you specify a baseline, it 
must be initialized in CaliberRM before Document Factory can reference it. The 
name must appear as it does in the Baseline drop-down list.

Syntax

$BASELINE{Version 2}

$BEGIN_SIGNATURES Optional A command lool used to 
include baseline signature 
information. Used with 
signature keywords.

$END_SIGNATURES Optional

Function Usage See... Purpose
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$BEGIN_SIGNATURES/$END_SIGNATURES

You can include baseline signature information in Document Factory using these 
commands in conjunction with baseline keywords. The $Begin_Signatures/
$End_Signatures command should only be used outside of a $Begin_Section/
$End_Section loop.  See page 354 for a list of $Begin_Signatures/$End_Signatures 
keywords.

Syntax

$BEGIN_SIGNATURES

<<first_name>><<last_name>>, <<title>>
<<signature_date>>
<<meaning>>
<<comment>>

$END_SIGNATURES

$BEGIN_SECTION/$END_SECTION 

These commands are used together to specify a section. A section typically contains 
a set of requirements of the same requirement type, but sections can be based on 
other criteria as well. The arguments in the $Filter command determine the group of 
requirements included in a section. If you do not filter on a particular set of 
requirements, Document Factory uses all requirements in the project. The 
keywords that can be used in a section are listed on page 345.

Rules about a section

• A template may contain many sections; however, you can not have a section 
within a section. 

• All $Commands except $Project and $Baseline must be used within in a 
$Begin_section/$End_section command. 

• There can be only one instance of each type of command in a section.
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Syntax

$FILTER{ }

The $Filter command is used to specify the group of requirements included in a 
section. It must be the first command in the section. If no $Filter is used, Document 
Factory includes all requirements in the project.

$Filter commands are expressed as:

expression1 compare operator expression2 where:

$BEGIN_SECTION

$FILTER{type = ‘Business Requirements’}

$SORT{hierarchy}
$INDENTION_LEVEL{.3}
$INDENTION_SIZE{.5}

$BEGIN_LIST
<<references>>
<<responsibilities>>
$END_LIST

$CALCULATE{keyword1 * keyword2 as result}

<<name>>(<<tag>><<id_number>>)
<<description>>
<<traces>>
<<history>>

$END_SECTION
Commands � 331



CHAPTER 22: DOCUMENT FACTORY
Expression1 is one of the following keywords:

Compare operator is one of the following operators:

Expression2 is a keyword value expressed as:

• Text string: expressed as ‘Business Requirements’

type status

tag priority

id_number hierarchy

version user-defined attributes

Operator Meaning Examples

= Equals priority = high

> Greater than risk > 50

< Less than number of days < 30

>= Greater than or equal to risk >= 75

<= Less than or equal to total time <= 10

<> Not equal to owner <> asmith

Like Matches a pattern name like *xxx*

Not Like Does not match a pattern tag not like ‘BR’

Between In a range limit between 10 and 50

Not Between Not within a range total not between 5 and 10

In In a set number in (‘1,2,3)

Not In Not in a set serial not in (88,89,90)
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• Numbers: integers or float expressed as Number of Days = 50

• Dates: expressed as date = #11-22-01# 

• Boolean: expressed as yes or no, no quotes

You can use wild cards in searches that use the like condition. The wild card 
characters are listed below:

You can combine search conditions by using the following logical operators:

• and – both expressions must be true to return a value

• or – either condition must be true to return a value

Character Meaning Examples

* (asterisk) A string of characters of any 
length, or possibly no 
characters

ser*
String beginning with ser

? (question 
mark)

One character ‘???d’
Four characters ending with a d

# (pound sign) One digit ‘a?##
String starting with an a, followed by 
one letter and two digits

[a-g] Range of characters ‘[m-s]##’
String starting with a letter between m 
and s, followed by two digits

[!a-g] Outside a range of characters ‘[!m-s]’
String starting with a letter before m 
and after s.

[*] or [?] or [#] Placing a special character in 
brackets means to take it 
literally rather than giving it a 
special meaning
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Syntax

$BEGIN_SECTION
$FILTER{type = ‘Business Requirements’}
$END_SECTION

Other examples of $Filter commands are shown below:

$FILTER{priority = ‘high’}

$FILTER{status <> ‘accepted’}

$FILTER{priority = ‘high’ and status = ‘accepted’}

$FILTER{owner = ‘smith’ or owner = ‘abaker’}

$FILTER{date = #11-22-01# and status = ‘accepted’}

$FILTER{risk between 50 and 100}

$SORT{ }

The $Sort command determines the order in which requirements appear in a 
section. Keywords used as arguments in the $Sort command can be labeled as ASC 
for ascending order or DESC for descending order. Ascending is assumed if neither 
is specified. 

Syntax

$BEGIN_SECTION
$FILTER{type = ‘Business Requirements’}
$SORT{hierarchy}
$END_SECTION

The $Sort command can also be used as shown in the examples below:

$SORT{priority}
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$SORT{priority, start date, owner}

$SORT{priority ASC, start date DESC}

If multiple arguments are used in the sort list, requirements are sorted first by the 
first argument in the list. If there are multiple requirements meeting that criteria, 
they are then sorted by the second argument, and so on.

The following keywords can be used in a sort command:

Note: You cannot sort on: description, validation, references, responsibility, 
traces, text-field UDAs, User List UDA, Group List UDA or Multiple Selection 
List UDA.

$INDENTION_LEVEL{ } AND $INDENTION_SIZE{ }

If $Indention_Level is specified, requirements in the section are indented according 
to their hierarchy in the tree. $Indention_Level specifies the maximum levels deep 
the section is indented. $Indention_Size specifies how many inches each indent is. 
As projects may contain many hierarchical levels, it is a good idea to limit the 
number of indents. These commands can only be used in conjunction with a 
$Sort{hierarchy}command.

The syntax is shown on the following page.

type status

tag priority

id_number hierarchy

version user-defined attributes
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Syntax

$BEGIN_SECTION
$FILTER{type = ‘Business Requirements’}
$SORT{hierarchy}
$INDENTION_LEVEL{3}
$INDENTION_SIZE{.5}
$END_SECTION

$BEGIN_LIST/$END_LIST

The $Begin_List/$End_List command provides a pre-formatted display of data 
that appears in list format in CaliberRM. This applies to <<references>>, 
<<responsibilities>>, and Multiple Selection User-Defined Attributes. Using these 
keywords without enclosing them between the $Begin_List/$End_List commands 
results in the data presented in a comma delimited format. The keywords used with 
this command are listed on page 347.

Note: You can still format the information with bolding, underlining, etc. 

Syntax

Responsibilities:
$BEGIN_LIST
<<responsibilities>>
$END_LIST

$BEGIN_HISTORY/$END_HISTORY and $BEGIN_CHANGES/
$END_CHANGES

A history record contains two sets of lists: a list of revisions and a list of changes 
for each revision. Two command loops are required to process the lists in the 
history record. $Begin_History/$End_History instructs Document Factory to loop 
through the history revision list, while $Begin_Changes/$End_Changes loops 
through the list of changes for each revision. Using this set of commands, you can 
336 � Commands  



CHAPTER 22: DOCUMENT FACTORY
customize the content and the look of the history data in your document. The 
keywords used with these commands are listed on page 348.

Syntax

$BEGIN_SECTION
$FILTER{type = ‘Business Requirements’}
$SORT{hierarchy}
$BEGIN_HISTORY
Rev#:<<major_version>><<minor_version>>User:<<userid>>
Name:<<user_name>>
<<Comment>>

$BEGIN_CHANGES
Changed Field:<<field_changed>>
From:<<from_value>> To:<<to_value>>
$END_CHANGES

$END_HISTORY
$END_SECTION

$BEGIN_TRACES/$END_TRACES( )

You can customize the content and the look of the traceability data in your 
document by using the $Begin_Traces/$End_Traces command.

$Begin_Traces/$End_Traces takes a string of identifiers that specify the trace and 
object types to be included in the document. There are three categories of 
identifiers: 

• Trace direction: to or from traces

• Trace type: direct or implied

• Object type: requirement, TestDirector (to traces only), Select Enterprise and 
SCM 

The option string can contain a combination of identifiers. The identifiers can be in 
any order and separated by any type of separator.
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If no option string is supplied, Document Factory assumes the following default:

$BEGIN_TRACES(TO_TRACES,FROM_TRACES,DIRECT_TRACES,
ALL_OBJECTS)

The table below details the trace identifiers.

Identifier Description

TO_TRACES To traces

FROM_TRACES From traces

DIRECT_TRACES Direct traces 

IMPLIED_TRACES Direct and implied traces

REQUIREMENT_OBJECTS Requirement objects

TD_SET_OBJECTS TestDirector sets

TD_TEST_OBJECTS TestDirector tests

TD_TEST_IN_SET_OBJECTS TestDirector test in set objects

TD_STEP_OBJECTS TestDirector step objects

TD_STEP_IN_SET_OBJECTS TestDirector step in set objects

SE_BUSINESS_PROCESS_
OBJECTS

Select Enterprise Business Process 
Objects

SE_PACKAGE_OBJECTS Select Enterprise Package Objects

SE_CLASS_OBJECTS Select Enterprise Class Objects

SE_CLASS_METHOD_OBJECTS Select Enterprise Class Method 
Objects

SE_USE_CASE_OBJECTS Select Enterprise Use Case Objects

SCM_OBJECTS SCM objects
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ECT
The data extracted for each object is determined by the keywords used within the 
command. The applicable keywords are listed on page 349.

Syntax

$CALCULATE{ }

The $Calculate command instructs Document Factory to perform a mathematical 
calculation on the specified keywords. The arguments to $Calculate must be 
formatted as keyword1 [*+-/] keyword2 as result. Keyword1 and keyword2 are 
separated by an operator (multiply, add, subtract, divide), then the word “as” 
followed by the result. Result is any name that you want to use. It can then be used 
elsewhere in the document like a keyword to display the results of the calculation. 

There can be only one $Calculate command in a section, but you can specify 
several calculations in one $Calculate command separated by commas.

The syntax is shown on the following page.

RBT_OBJECTS CaliberRBT objects

ALL_OBJECTS All objects

Identifier Description

$BEGIN_SECTION
$BEGIN_TRACES(TO_TRACES,FROM_TRACES,DIRECT_TRACES,ALL_OBJ
<<Trace_Name>> <<Trace_Direction>> <<Trace_Suspect>>
$END_TRACES

$END_SECTION
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Syntax

$BEGIN_SECTION
$CALCULATE{days + overtime hours as total_time}
Number of hours: <<total_time>>

$END_SECTION

$BEGIN_DISCUSSIONS/$END_DISCUSSIONS

You can format the content of your requirement discussion information using the 
$Begin_Discussions/$End_Discussions command and certain keywords. You can 
also use the $Indention_Level and $Indention_Size for indenting discussions. See 
page 352 for a list of $Begin_Discussions/$End_Discussions keywords.

Syntax

$BEGIN_SECTION
$FILTER{type = 'Hardware Requirements'}

<<hierarchy>><<name>>( <<tag>><<id_number>>)

Project Discussions: 
$BEGIN_DISCUSSIONS
Tag:  <<discussion_req_tag>>
Subject:  <<subject>>
From:  <<from>>
Is Read:  <<is_read>>
Date:  <<discussion_date>>
Body:  <<body>>
$END_DISCUSSIONS

$END_SECTION
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$BEGIN_PROJECT_DISCUSSIONS/$END_PROJECT_DISCUSSIONS

You can format the content of your project discussion information using the 
$Begin_Project_Discussions/$End_Project_Discussions command and certain 
keywords. You can also use the $Indention_Level and $Indention_Size for 
indenting discussions. See page 315 for a list of $Begin_Project_Discussions/
$End_Project_Discussions keywords.

Note: The $Begin_Project_Discussions/$End_Project_Discussions command 
does not have to be used in a $Begin_Section/$End_Section. 

Syntax

$PROJECT{Automated Teller Machine}  
Project name: <<project>>                         
 Project description:
<<project_description>>

Project Discussions:
$BEGIN_PROJECT_DISCUSSIONS
Subject:  <<subject>>
From:  <<from>>
Is Read:  <<is_read>>
Date:  <<discussion_date>>
Body:  <<body>>
$END_PROJECT_DISCUSSIONS

$BEGIN_GLOSSARY/$END_GLOSSARY

You can format the content of your glossary information using the 
$Begin_Glossary/$End_Glossary command and certain keywords. See page 353 
for a list of $Begin_Glossary/$End_Glossary keywords.

The syntax is shown on the following page.
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Syntax

$PROJECT{Automated Teller Machine}
User name:    <<userid>>         Project name: <<project>>                         
Project description:  <<project_description>>

$Begin_Glossary
Term:  <<Term>>  Definition: <<Definition>>
$End_Glossary

$RGVFILE

You can apply a Requirement Grid filter to your Document Factory reports using 
the $RGVFile command. If a $Filter command is used in the same section as the 
$RGVFile command, Document Factory combines the two queries. If a $Sort 
command is used in the same section as the $RGVFile command, the resulting 
document will display data from both commands, in an order determined by which 
command is used first in the template.

When using the $RGVFile command, you do not need to specify the project in the 
template. Document Factory will use the project specified in the .rgv file you are 
using. If you do specify a project in the template, it must be the same project in the 
.rgv file.

The syntax is shown on the following page.
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Syntax

$BEGIN_SECTION
$RGVFILE{C:\Program Files\Borland\CaliberRM\ATM-Accepted Reqs 
Sorted by Priority.rgv}

<<hierarchy>><<name>>( <<tag>><<id_number>>)

$END_SECTION

KEYWORDS

Keywords are placeholders in the template that correspond to specific fields in a 
CaliberRM project. Document Factory replaces the keyword in the template with 
the actual data from its corresponding field. Some keywords correspond to a single 
entry, while others correspond to lists of data. Keywords must be enclosed by 
brackets, e.g. <<hierarchy>>.

Keywords are also used as arguments to some $Commands. When used as 
arguments, keywords are not enclosed in brackets.

Note: User-defined attributes that have names identical to CaliberRM keywords 
cannot be used in a document. To avoid conflicts, these keywords should not be 
used as attribute names. 

Global Keywords

The following keywords are global, meaning they can be used anywhere in the 
document, including headers and footers:

Keyword Description

<<project>> The name of the project

<<project_description>> The description of the project

<<userid>> The ID of the user creating the document
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The graphic on the following page shows how the global keywords relate to the 
fields in CaliberRM.

<<userid>>

<<project>>

<<project_description>>
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$BEGIN_SECTION/$END_SECTION Keywords

The following keywords are specific to requirements and can only be used in a 
section.

Keyword Description

<<type>> The name of the requirement type

<<hierarchy>> The requirement hierarchy number

<<id_number>> The unique ID number

<<status>> The requirement status

<<priority>> The requirement priority

<<description>> The requirement description

<<tag>> The tag for the requirement type

<<name>> The requirement name

<<version>> The project version number

<<owner>> The requirement owner

<<validation>> The validation procedure

<<UDA Name>> Any user-defined attribute; these must be 
entered exactly as they appear in CaliberRM

<<Calculated Field Name>> Result of a $Calculate command

<<history>> All history data for a requirement

<<traces>> All traceability data for a requirement

<<references>> The drive, directory and the file link for all the 
document references assigned to a 
requirement

<<responsibilities>> The list of all users responsible for the 
requirement
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The graphic below shows how the $Begin_Section/$End_Section keywords relate 
to the fields in CaliberRM.

<<created_by>> The userid of the user who created the 
requirement 

<<created_on>> The date/time that the requirement was 
created

Keyword Description

 

A.  <<type>>
B.  <<hierarchy>>
C.  <<id_number>>
D.  <<status>>
E.  <<priority>>

F.  <<description>>
G.  <<tag>>
H.  <<name>>
I.  <<version>>
J.  <<owner>>
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$BEGIN_LIST/$END_LIST Keywords

The following keywords are used to generate lists of information.

$BEGIN_HISTORY/$END_HISTORY Keywords

The <<history>> keyword extracts all history data for a requirement.

$Begin_History/$End_History scans each entry in the revision list and extracts 
data for the keywords specified in the template.

These keywords can only be used within the $Begin_History/$End_History 
command loop. 

Keyword Description

<<references>> Used within a $Begin_List/$End_List command; 
extracts the document reference list for a 
requirement, found on the References tab.

<<responsibilities>> The keyword is used within a $Begin_List/
$End_List command; extracts the responsibilities 
list for a requirement, found on the 
Responsibilities tab.

Multiple Selection User-Defined 
Attributes

Any multiple selection user-defined attribute can 
be used in a $Begin_List/$End_List command. 

Keyword Description

<<major_version>> Major version number

<<minor_version>> Minor version number

<<datestamp>> Date of the change

<<timestamp>> Time of the change

<<userid>> Logon ID of user who made the change
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$BEGIN_CHANGES/$END_CHANGES Keywords

$Begin_Changes/$End_ Changes scans each entry in the changes list and extracts 
data for the keywords specified in the template.

These keywords can only be used within the $Begin_Changes/$End_Changes 
command loop. 

<<user_name>> First and last name of user who made the change

<<comment>> Reason for the change

Keyword Description

<<field_changed>> attribute - what changed

<<from_value>> old attribute value

<<to_value>> current attribute value

Keyword Description
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The graphic below shows how the commands and keywords relate to the fields on 
the History tab in CaliberRM.

$BEGIN_TRACES/$END_TRACES Keywords

The <<traces>> keyword extracts all trace data for a requirement. 

The following keywords are used to extract and format specific data, and can only 
be used within a $Begin_Traces/$End_Traces command.

Keyword Description

<<Trace_ReqTag>> tag number of trace to or from object

<<Trace_Name>> name of trace to or from object

 A, B C D E,F G

H I J

A. << major_version>>
B.  <<minor_version>>
C.  <<datestamp>>
D.  <<timestamp>>
E.  <<userid>>
F.  <<user_name>>
G.  <<comment>>
H.  <<field changed>>
I.  <<from_value>>
J.  <<to_value>>

Revision List

Changes List
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The graphics on the following page show how the commands and keywords for 
traceability relate to the traceability fields in CaliberRM on the Traceability tab 
and in the Traceability Matrix.

<<Trace_Suspect>> indicates whether the trace is suspect

<<Trace_TestStatus>> indicates pass/fail status (TD Only)

<<Trace_DirectImplied>> indicates whether the trace is a direct or 
implied trace

<<Trace_Direction>> indicates the direction of the trace

<<Trace_Project>> the project in which the requirement being 
linked to or from is located

Keyword Description
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The <<traces>> 
keyword extracts all 
trace data for a 
requirement.

$Begin_Traces/
$End_Traces scans 
each entry and 
extracts data for the 
keywords specified in 
the template.

A           B                        C                   D,E                 F

A.  <<trace_name>>
B.  <<trace_direction>>
C.  <<trace_reqtag>>
D.  <<trace_teststatus>>
E.  <<trace_suspect>>
F.  <<trace_project>>
G.  <<trace_directimplied>>

G
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$BEGIN_DISCUSSIONS/$END_DISCUSSIONS Keywords

The <<discussions>> keyword extracts the list of all requirement discussions. Data 
includes the requirement tag, discussion subject, the user who initiated the 
discussion and the discussion date.

Note: The <<discussions>> keyword does not have to be used within a 
$Begin_Discussions/$End_Discussions command loop.

The following keywords are used to extract and format specific data, and can only 
be used within a $Begin_Discussions/$End_Discussions command.

$BEGIN_PROJECT_DISCUSSIONS/$END_PROJECT _DISCUSSIONS 
Keywords

The <<project_discussions>> keyword extracts the list of all project discussions. 
Data includes the discussion subject, the user who initiated the discussion and the 
discussion date.

Note: The <<project_discussions>> keyword does not have to be used within a 
$Begin_Project_Discussions/$End_Project_Discussions command loop.

Keyword Description

<<discussion_req_tag>> the requirement identifier; includes the type 
tag and id

<<subject>> the subject of the discussion

<<from>> user who initiated the discussion

<<is_read>> indicates if current user has read the 
discussion

<<discussion_date>> date the discussion was saved

<<body>> the message text of the discussion
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The keywords below are used to extract and format specific data, and can only be 
used within a $Begin_Project_Discussions/$End_Project_Discussions command 
loop.

$BEGIN_GLOSSARY/$END_GLOSSARY Keywords

The <<glossary>> keyword extracts a pre-formatted list of glossary information. 
This keyword outputs all glossaries assigned to the selected project in their 
specified order. Data includes glossary terms and their definitions.

Note: The <<glossary>> keyword should not be used within a $Begin_Section/
$End_Section command loop.

Note: The <<glossary>> keyword does not have to be used within a 
$Begin_Glossary/$End_Glossary command loop.

The following keywords are used to extract and format specific data, and can only 
be used within a $Begin_Glossary/$End_Glossary command.

Keyword Description

<<subject>> the subject of the discussion

<<from>> user who initiated the discussion

<<is_read>> indicates if current user has read the 
discussion

<<discussion_date>> date the discussion was saved

<<body>> the message text of the discussion

Keyword Description

<<glossary_name>> the name of the glossary

<<term>> the term
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$BEGIN_SIGNATURES/$END_SIGNATURES Keywords

These keywords can only be used within the $Begin_Signatures/$End_Signatures 
command loop. 

The <<signatures>> keyword used alone produces a pre-formatted list of baseline 
signatures formatted as:
<<signature_date>><<signature_time>><<first_name>><<last 
name>><<meaning>>

CREATING TABLES IN DOCUMENT FACTORY

Once you are familiar with commands, keywords, and creating Document Factory 
templates, you may want to include more complex formatting, such as tables. 

<<definition>> the term’s definition

Keyword Description

<<title>> the signatory’s title

<<first_name>> the signatory’s first name

<<last_name>> the signatory’s last name

<<user_id>> the signatory’s user ID

<<meaning>> the signature meaning

<<comment>> the signatory’s comments

<<signature_date>> the date the baseline was signed

<<signature_time>> the time the baseline was signed

Keyword Description
354 � Creating Tables in Document Factory  



CHAPTER 22: DOCUMENT FACTORY
Tables provide a neat, efficient way to display your output data. You can include 
tables in your Document Factory documents by adding tables to your templates. 

Refer to the following example as a guideline for creating tables in Document 
Factory.

1. Start with a simple template, like the example shown below.

2. Place your cursor before $End_Section. Select Table > Insert > Table from the 
menu. Add a two row table with three columns. 
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From
this
3. Add $Begin_Section through $Sort (including the space after $Sort) to the first 
column of the second row.

4. Add column headings and corresponding attribute keywords, as displayed in 
the graphic on the following page. In the example, <<name>>, <<status>> and 
<<description>> are used.

 this to 
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Note: The column headings and attributes are highlighted only to show you 
where they are placed.

5. Select Tools > Options from the menu. On the View tab, under Formatting 
Marks, select the Paragraph marks check box. Click OK.

6. Highlight the paragraph mark after the $Sort statement. Select Format > Font 
from the menu. On the Font tab, under Effects, select the Hidden check box. 
Click OK. The <<name>> keyword moves up to the $Sort line.

Note: If you do not hide the last paragraph mark, each requirement is printed 
in a single row table.

7. Repeat Step 5 to hide the remaining paragraph marks.

8. Select the entire first (heading) row and select Table > Heading Rows Repeat 
from the menu. This ensures that each new page has a heading row.

9. Select the second row and select Table > Table Properties from the menu. On 
the Row tab, make sure that the Allow row to break across pages check box is 
not selected. Click OK.

10. Click File > Save As from the menu. Save your document as a .dot file, which 
you can use to run Document Factory.

The final template and its output are shown on the following page.
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FINAL TEMPLATE

OUTPUT
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CREATING A DOCUMENT USING DOCUMENT FACTORY

To create a document using Document Factory:

1. To start Document Factory, do one of the following:

• select Programs > CaliberRM > Caliber Document Factory from the 
Windows Start menu,

• click the Document Factory button on the StarTeam toolbar, 

• click the Document Factory button on the CaliberRM main toolbar, or 

• select Tools > Document Factory from the menu.

If you are already logged on, go to Step 3. If you are not logged on, Caliber 
Document Factory prompts you to log on.

2. Enter your Server name, User Id and Password and click Next.
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3. Step 2 of the Caliber Document Factory is displayed.

Select a file from the list in the Template box. The drop-down list allows you 
to make a selection from the most recently used templates. By default, there 
are five files in the list. This number is determined by your administrator.

OR 

Click the Browse button to navigate to the desired template file. The default 
location is C:\Program Files\Borland\CaliberRM\samples. 

You can open the selected template to check it or make any edits before 
running Document Factory. Click the Word icon next to the Template box to 
open the selected template file in Microsoft Word. 

4. In the Save Document As box, enter a path and name for your new document, 
click the Browse button to navigate to a previously created document or leave 
blank.

You can open the selected Word file by clicking the Word icon next to the 
Save Document As box. 
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5. Click Next. Step 3 of the Caliber Document Factory is displayed.

6. Choose the date format that you would like to use: Short Date or Long Date.

7. Choose Once for the method of replacing fields if the template contains only 
one occurrence of each keyword used. This option replaces only the first 
instance of the keyword. 

If you use a keyword more than once in a section, choose the Multiple option 
to replace all occurrences of the keyword with the actual data. This option 
replaces all instances of the field, but takes longer to process the data.
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8. Click Next. Step 4 of the Caliber Document Factory is displayed.

9. Choose the data from which you would like to create the document:

• Use data from the active project. If you choose this option, you can also 
choose to save the current data to use again with a different template.

• Use previously saved data.

10. Click Finish. 
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The Caliber Document Factory processes the data. 

Note: If you used a template that was not project-specific, you are asked to 
choose the project during this processing phase.

11. When the data has been processed, the CaliberRM Document Factory asks if 
you would like to open your document. 

RUNNING DOCUMENT FACTORY FROM THE COMMAND LINE

Document Factory can be run from the MS-DOS command line, allowing you to set 
up scheduled document generation. For example, you can set Document Factory to 
produce a detailed specifications document at the end of every month, or a high-
level report of requirement status at the end of every week.

1. Select Start > Programs > Command Prompt to get to a DOS command 
prompt.

2. At the C:\> prompt enter: cd Program Files\Borland\CaliberRM, to change 
the directory to where the Docfactory.exe file resides.
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Note: Change directory to that of your CaliberRM executable file if different 
from above.

3. At the prompt, enter the following command:

docfactory /Project <project> /Template <template> /SaveAs <filename> 
/Merge <o> /Date <s> /Server <server> /User <user> 
/Password <password> /Auto <YES/NO>

where:

/Project <project>: The name of the project. If the project name consists of 
more than one word separated by spaces, the name must be enclosed in 
double quotes, e.g. “Automated Teller Machine”.

/Template <template>: The path and name of the template.

/SaveAs <filename>: The path and name of the file to save as. This file may 
be a .doc, .txt or .rtf file. If the project name consists of more than one word 
separated by spaces, the name must be enclosed in double quotes.

/Merge <o>: Indicates the merge method used. The <o> instructs Document 
Factory to replace the fields just once (the default). Using <m> replaces 
multiple fields.

/Date <s>: Instructs Document Factory to use the Short Date format. If not 
specified, Document Factory uses the Long Date format.

/Server <server>: The name of the CaliberRM server to obtain the data 
from.

/User <user>: The user ID to use for logging on to the server.

/Password <password>: The user password.
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/Auto <YES/NO>: Instructs Document Factory to not just fill in the values 
for you, but to actually run the Document Factory and terminate when 
complete. If you enter no, you will get the Document Factory screens.

Example:

docfactory /Project “Automated Teller Machine” /Template ATM.dot 

/SaveAs ATM.doc / Merge o /Date s /Server dagobah /User asmith

/Password mypass /Auto YES
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OVERVIEW

CaliberRM has two tools that enable customers to manage their requirements using 
the Web – CaliberRM Web and CaliberRM WebView. Each of these tools allow 
project teams to connect to a CaliberRM server through a standard browser. 

Note: To use either CaliberRM Web or CaliberRM WebView, you may be required 
to download the Java Plug-In.

CALIBERRM WEB

CaliberRM supports a full-featured browser-based Web client except the following:

• All CaliberRM administrator functionality (File > Admin)

• Traceability Matrix (Tools menu)

• Reports (Reports menu)

• Document Factory (CaliberRM System Toolbar and Tools menu)

• Export to Access (File > Export to Access)

• Importing Documents from MicroSoft Word (File > Import from Word)

• Custom Tools (Tools > Options)

• Drag and Drop requirements out of CaliberRM

• External integrations are limited to read-only data. For example, TestDirector 
objects appear in the Traceability Diagram and Traceability Tab. You can right- 
click on a TestDirector object and view its details. However, you can not create 
new traces.
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USING CALIBERRM WEB

To access CaliberRM Web:

1. Open a standard browser such as Netscape Navigator or Internet Explorer.

2. Enter the name or IP address of the server you want to connect to in the 
Address or Location field, depending on your browser. You may browse the 
URL of the Web server where Caliber RM Web is installed instead if you 
prefer.

Note: If your Caliber Administrator has changed the location of the 
CaliberRM Web index page or has moved the links to a custom page, you 
need to enter that location instead. 

The CaliberRM Web index page is displayed.

3. Click the CaliberRM Web link. 

Note: You may be required to download the Java Plug-In.
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The first time you attempt to use CaliberRM Web, the following window is 
displayed.

4. Click the Always button. The Login screen is displayed.

5. Enter your CaliberRM server Host, your User name and Password in the 
appropriate fields.

6. Click Logon. The system verifies your information, and logs you on to the 
server.
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You are now in CaliberRM Web and can perform most of the tasks you can perform 
in the standard CaliberRM client. 

Refer to page page 367 for a list of features that you may not use in CaliberRM 
Web.

USER INTERFACE

The CaliberRM Web user interface is similar to that of the standard CaliberRM 
client. You can view all CaliberRM tabs and access most of the standard CaliberRM 
project information; however, the menu options are limited and exclude all items 
listed on page 367.
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Menus

The CaliberRM Web menus have some of the same options as those in the standard 
CaliberRM client. All of the options are discussed in detail in the section “Menus” 
on page 188.

The File menu allows you to open a new project, open a baseline, refresh the 
project data, and exit the Web client. 

The Edit menu provides the same functionality as the standard CaliberRM client.
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The View menu allows you to view the hierarchical or serial numbers and specify 
which toolbars to display. A check mark beside a toolbar option indicates that it is 
selected.

The Requirement menu provides the same functionality as the standard 
CaliberRM client. See page 193 for details about these options. 
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The Tools menu has some of the same functions as the standard CaliberRM client, 
but it does not contain options for certain features and integrations. See page 195 
for details about these options. 

Under the Tools menu, CaliberRM Web Options provides an additional tab called 
Add-In that allows you to add additional dictionaries for the Spelling Checker 
feature..
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Adding and Removing Dictionaries

You may add or delete dictionaries for use with the Spell Checking feature.

To add or remove dictionaries:

1. Select Tools > Options from the CaliberRM Web menu.

2. Select the Add-In tab.

3. Click Add. The Add Dictionary dialog box is displayed.

4. Select a dictionary and click Add, or double-click the dictionary to add it. 

5. Repeat Steps 3 and 4 for additional dictionaries you want to add.

Note: Although you may add multiple dictionaries, you must specify only one 
dictionary when using the Spell Checker.

6. Select the dictionary you want the Spell Checker to use and click OK.

7. To remove a dictionary, repeat Steps 1-2. Select the dictionary you want to 
remove and click Remove. Click OK when finished.
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The Help menu provides the same functionality as the standard CaliberRM client. 
See page 199 for details on these options.

CALIBERRM WEBVIEW

CaliberRM WebView allows project teams to review and collaborate on 
requirements. Users can enter comments about the requirements using the 
Discussion feature. This feature helps revise and prioritize requirements.

CaliberRM WebView provides easy access to the group discussion feature for those 
who may provide valuable input to the project, but do not need fully functional 
clients. 

USING CALIBERRM WEBVIEW

To access CaliberRM WebView:

1. Open a standard browser such as Netscape Navigator or Internet Explorer.

2. Enter the name or IP address of the server you want to connect to in the 
Address or Location field, depending on your browser. You may browse the 
URL of the Web server where CaliberRM WebView is installed instead if you 
prefer.
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Note: If your Caliber Administrator has changed the location of the 
CaliberRM WebView index page or has moved the links to a custom page, you 
will need to enter that location instead. 

The CaliberRM Web index page is displayed.

3. Click the CaliberRM WebView link. 

4. Click the CaliberRM Web link. 

Note: You may be required to download the Java Plug-In.
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The first time you attempt to use CaliberRM Web, the following window is 
displayed.

5. Click the Always button. The Login screen is displayed.

6. Enter your CaliberRM server Host, your User name and Password in the 
appropriate fields.

7. Click Logon. The system verifies your information, and logs you on to the 
server.

You are now in CaliberRM WebView and can view requirements and enter 
discussion messages.
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USER INTERFACE

The CaliberRM WebView user interface is similar to that of the standard 
CaliberRM client. You can view all CaliberRM tabs; however, the menu options are 
limited. With the correct permissions you can post messages in the group 
discussion. For instructions on entering group discussion messages, see “Group 
Discussion” on page 285.

CaliberRM WebView does not allow you to create or edit references, view the 
requirement grid or the traceability matrix.

Menus

CaliberRM WebView contains some of the same menus as the standard CaliberRM 
client. The menus have many of the same options as those in the standard 
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CaliberRM client. All of the CaliberRM menu options are discussed in detail in the 
section “Menus” on page 188.

The File menu allows you to open a new project, open a baseline, refresh the 
project data, and exit the WebView. 

The Edit menu allows you to search for requirements by name or description.

The View menu allows you to view the hierarchical or serial numbers and specify 
which toolbars to display. A check mark beside a toolbar option indicates that it is 
selected.
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The Tools menu gives you the option to view unread discussions, view the Baseline 
Signatures window (administrators only) change your password and specify the 
look and feel of CaliberRM WebView through the Options dialog box.

Under the Tools menu, CaliberRM WebView Options provides an additional tab 
called Add-In.

This tab allows you to add additional dictionaries for the Spelling Checker feature.  
See “Adding and Removing Dictionaries” on page 374 for information on adding 
dictionaries.
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The Help menu provides the same functionality as the standard CaliberRM client. 
See page 199 for details on these options.

The options on the toolbar are: Refresh, Open Project, Open Baseline, Find in Tree, 
Search Description, Show Hierarchical Numbers, Show Serial Numbers, Unread 
Discussions and About CaliberRM.
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OVERVIEW

You can export CaliberRM project data to Microsoft Access by selecting which 
tables you want to export from a list of available tables. The data is exported into 
Access table format(s).

Note: See “Appendix B: Export to Access Tables” on page 429 for the complete 
list of available tables to export. 

There are two methods for exporting project data:

• by selecting File > Export to Access from the menu,

OR

• by running Export to Access from the command line.

Using Export to Access from the Menu

To export data:

1. Select File > Export to Access from the menu.
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The Database Export Setup dialog box is displayed.

2. Select the check box to the left of the table to include the table for export, or 
clear the check box to exclude the table from export. The default setting is to 
export all tables. To view the fields in a particular table, select the table. 

3. If you want to show the relationship between the tables, select the Join check 
box.

4. Click Export.
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The Save As dialog box is displayed.

5. Navigate to the destination directory of the file and enter a file name and type. 

6. Click Save. 

CaliberRM exports the data into the file and format you have specified.

Command Line Export

You can initiate an Export To Access process by running CaliberRM from the 
command line. When executed from the command line, all tables are exported. 
This command can be used in a batch file to run exports in off-peak hours. 

To execute an Export To Access process from the command line:

1. Select Start > Programs > Command Prompt to get a DOS command 
prompt.

2. At the C:\> prompt enter: cd Program Files\Borland\CaliberRM, to change 
the directory to where the CaliberRM.exe file resides.
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Note: Change directory to that of your CaliberRM executable file if different 
from above.

3. At the prompt, enter the following command:

CalibrRm -export <none> -project <projectname> -filepath <filepath> -
host <hostname> -user <userid> -security <password>

Where:

• -export: Used to signify that a command line export to Microsoft Access is 
being executed. No value is needed, however, this switch must be present to 
start the export.

• -project: Indicates the project from which data is exported. If this switch is 
not present, the last project used is the default.

• -filepath: Used to select the file path to place the database generated from 
the export. If this switch is not present, the data is placed in the Windows 
temporary directory with a file name of CaliberRM.mdb.

• -host: Used to enter the host or server name for logon purposes. If this 
switch is not present, the last server logged on to is used by default.

• -user: Used to enter the user name for logon purposes. If this switch is not 
present, the last user name logged on is used by default.

• -security: Used to enter the password for logon purposes. If this switch is 
not present, the password from the Caliber Toolbar is used.

The switches are case sensitive and are processed from left to right. Only the first 
letter of the switch must be present for it to be processed. A switch can be preceded 
by a ‘-’ or a ‘/’. 

While the export is taking place, CaliberRM remains minimized and a status 
window is displayed:

When the export is complete, you are prompted to open the database.
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Microsoft Word

OVERVIEW

You can import requirement names and descriptions from a Microsoft Word 
document into a CaliberRM project using the Import From Word Wizard.

The Import process requires the following information:

• The Microsoft Word file name (e.g., Requirements.doc).

• The requirement naming convention. You can either import requirement names 
or have Import automatically assign the requirement names. Import uses the 
document name as the base name followed by an incremental number for each 
requirement.

• You can import requirement names if the requirement names in your document 
are in the same, specific format. Requirement names can be formatted in three 
different ways:

• Paragraph style: You may use default paragraph styles (e.g, Heading 1, 
etc.) or custom paragraph styles (e.g., Requirements, etc.).

• Delimited text: Import uses the set of delimiters (e.g., commas, tabs, etc.) 
you specify.

• Keywords: Import can recognize multiple keywords.

• The requirement description format. If you are importing requirement names 
by paragraph style, you can import requirement descriptions by extracting the 
text between paragraph styles used for requirement names, or indicating a 
paragraph style for requirement descriptions.

Note: If you are importing names using delimiters or keywords, requirement 
descriptions can only be imported by paragraph style.
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Supplied with this information, Import analyzes the Microsoft Word document and 
extracts the requirement information. When completed, Import previews the new 
requirements before placing them in the project tree.

Once you have reviewed the new requirements and made any necessary changes, 
you can select the location for the new requirements and save them.

To import a Microsoft Word document into CaliberRM:

1. Select File > Import From Word from the CaliberRM menu. The Import 
from Word wizard is displayed.

2. Enter the path and name of the Microsoft Word file or click the Browse button 
to navigate to the file.

Indicate how you want to name the requirements. Select either the Retrieve 
the requirements names from the document option button, or the 
Automatically name the requirements using a base name and a 
sequential number option button. Enter a base name here. If you do not 
enter a name, Import uses the Microsoft Word document name as the base 
name by default.
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3. Click Next.

4. If you are importing requirement names by style, in the top pane, select the 
paragraph style(s) that are specific to requirement names. Styles define the 
appearance of various text elements within the document, such as headings and 
body text. The styles listed are those found in your Microsoft Word document. 
You may select any or all styles from the list.

5. In the bottom pane, indicate how to recognize requirement descriptions:

• The Import all text between the above selected Text styles as the require-
ment description option can only be used if you are importing requirements 
names by style.

• If you are not importing requirement names by style, select the Import only 
the Text styles below as the requirement description option. Select the 
styles that are specific to requirement descriptions.
Overview � 389



CHAPTER 25: IMPORTING REQUIREMENTS FROM MICROSOFT WORD
6. Click Next.

7. If you are importing requirement names by paragraph style, select the Import 
all text, ignoring delimiters option button.

OR

Select the Only import text enclosed in the following delimiters option 
button. The Beginning and Ending fields become available. Enter the 
beginning and ending delimiter in the appropriate area.
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8. Click Next.

9. If you are importing requirement names by paragraph style, select the Import 
all text, ignoring keywords option button. Go to Step 13.

10. If you are importing requirement names by keywords, choose the Only import 
text containing the following keywords option button. Enter the keywords in 
the available field, separating each keyword by a comma. Phrases containing 
these keywords will be imported as requirement names.

11. Click Next.

Import from Microsoft Word begins processing the document based on your 
choices from the above steps. Once processing is completed, Import from 
Microsoft Word displays a list of new requirements for each criteria that was 
met, as shown on the following page.
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Note: Import from Microsoft Word also creates child requirements based on 
the paragraph style hierarchy in your document.

You can right-click in the preview tree to make any or all of the following 
changes:

• Delete a requirement.

• Rename a requirement.

• Show or hide vertical and/or vertical lines.

• You can edit the name and description fields by selecting the field, then 
clicking once to place the cursor in the appropriate field.

• You also have drag-and-drop functionality in the preview that allows you to 
move the new requirements and place them in any desired order.
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12. Click Next once you have reviewed the new requirements and have made any 
necessary changes. The CaliberRM requirement list is displayed.

13. Choose the location for the newly created requirements by selecting a 
requirement. Select one of the following options: Insert Above, Insert Below, 
or Insert as Children.

14. Click Finish to complete import. The Import is Complete dialog box is 
displayed.

15. Click OK.
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You can export and import project data by using the RM Export and the RM Import 
utilities. These utilities enable customers to move data from one CaliberRM server 
to another.

RM EXPORT 

You may export a project or requirement information from a Caliber server into an 
ASCII file. That file may be imported into the same or another Caliber server and 
other applications. 

Note: You must be in the Administrator group to export Caliber information. 

The export utility provides a way of selecting requirements, requirement types, 
users, groups, user-defined attributes and project information, referred to as objects, 
for export. After an export, a log file is created that contains information about what 
was exported and any error messages.

The export utility creates a separate ASCII file for each type of object exported. 
You specify the name and path for the exported data. The export utility creates a 
directory or “data set,” using the name and path specified. It then creates individual 
files for each type of object exported. The exported data contains object names only 
and does not contain coded data. The data files adhere to a particular format that is 
covered in detail in “Appendix C: RM Export Object Format” on page 437. 

It is possible to create a data file in the correct format for import using programs 
other than CaliberRM’s export utility. If the import utility is used to import data 
created by programs other than CaliberRM’s export utility, it is the user’s 
responsibility to ensure that the data is accurate and properly formatted. 

WARNING: IT IS POSSIBLE TO IMPORT CORRUPTED OR INCORRECT DATA WITH 
THE IMPORT UTILITY. BORLAND STRONGLY RECOMMENDS THAT YOU BACKUP 
YOUR DATABASE BEFORE USING THE IMPORT UTILITY. BORLAND IS NOT 
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RESPONSIBLE FOR THE RESULTS OF IMPORTING DATA CREATED BY PROGRAMS 
OTHER THAN THE CALIBERRM EXPORT UTILITY.

Export Data for Import to a Caliber Server

To export data from a server for later import to the same or another Caliber server:

1. Select Start > Programs > CaliberRM > RM Export from your Windows 
workstation. 

Note: This feature is only available if you chose a Custom installation when 
you installed CaliberRM, and installed this feature.

The Export Logon Information screen is displayed. 

Note: This window does not display if you are already logged on to 
CaliberRM. If you are already logged on, you may proceed to Step 6.

2. Enter your Server name or IP address, User name and Password.
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3. Click Next. The Profile screen is displayed.

4. Select the No profile needed option button, or the Use a previously stored 
profile option button if you have previously created a profile that you want to 
use.

5. Click Next.
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The Import Option screen is displayed.

6. Select the Yes, pre-format the export for a CaliberRM import option button.

Note: The option to customize the export is made available to advanced users 
who want to import requirement data into a different application. For more 
information on building a customized export, see “Export Data for Import to 
Another Application” on page 401.

7. Click Next.
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The Select Object screen is displayed.

Note: By choosing the pre-format option in Step 6, selecting certain objects 
at this step causes others to be automatically selected, as shown in the table 
below.

By default, the requirements object is pre-selected and is all that is required 
for importing into another project.

EXPORT SELECTION DEPENDENCIES

AUTOMATIC SELECTIONS

Users Groups Types UDAs Reqts Projects

Users X

Groups X

Types X

UDAs

Reqts X X X X

Projects X X X X
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WARNING! EXPORTING A PROJECT DOES NOT EXPORT BASELINES, DEPART-
MENTS AND REQUIREMENT HISTORY.

Note: If you click the Project Descriptions object, only Project Descriptions 
will be exported. RM Export will export descriptions for all existing projects 
in the current database. These projects will be created during the import if 
they do not previously exist. Borland recommends that you export the 
requirements object only and manually create the project in which to import. 
RM Import offers an option to create a new project during the import process.

8. Click Next. The Data Set screen is displayed.

9. Create a name for your data set. Click the Browse button to navigate to a 
desired location in which to save your data set. A folder with this name is 
created and appended to your data set path. If you would like to save this 
profile for use later, click the Save Profile button and select a location in which 
to save it. 

Note: The Advanced button changes your delimiters and qualifiers that sepa-
rate your data within the export/import files. This is not recommended for an 
export that will be imported into CaliberRM. See “Export Data for Import to 
Another Application” on page 401 for more information on this aspect of the 
feature.
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10. Click Finish. The Export screen is displayed. You are prompted to select a 
project from which you would like to export data.

11. Select a project from the Select Project screen drop-down list and click OK.

The export completes.

12. Click Close.

You may now use the Data Set to import information to another server or to another 
project. 

Export Data for Import to Another Application

To export data for import to another application, complete the following steps:

1. Complete Steps 1-5, starting on page 396. The Import Option screen is dis-
played. 

Select the No, I will customize my report option button.
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2. Click Next. The Select Objects screen is displayed.

3. Select the object(s) you want to export.

4. Click Next. The Object Selection Option screen is displayed, as shown on the 
following page.
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5. Select the Yes option button if you would like to customize your export in more 
detail. Click Next, and go to Step 6 under the section “Object Field Selection” 
on page 406.

OR

Choose the No, I accept the default field selections option button, click 
Next, and continue with Step 6 on the next page.
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The Data Set screen is displayed.

6. Create a name for your data set and the data set path. Click the Browse button 
to navigate to a desired location. A folder with this name is created and 
appended to your data set path. 
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7. If you want to change your delimiters and qualifiers, click the Advanced 
button. The Advanced Settings screen is displayed.

8. Select the delimiters, qualifiers and date/time formats you would like in your 
export. The options you select are displayed in the window so that you may see 
how the information is separated.

9. Click OK. 

10. If you would like to save this profile for later use, click the Save Profile button 
in the Data Set screen, and select a location in which to save the profile. 

11. Click Finish. The Export screen is displayed. 

12. Select the project that contains the objects you want to export from the Select 
Project screen drop-down list and click OK.

The export completes.

13. Click Close.

You may now use the Data Set to import information to another application.
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Object Field Selection

If you chose to customize your object fields in Step 5 on page 403, complete the 
following steps:

6. Click Next in the Object Selection Option dialog box.

The Select Fields screen is displayed. 

7. Select an object from the drop-down list, then select the fields you would like 
to export or clear any you do not want to export. Complete this step for each 
object type that you are exporting. See “Appendix C: RM Export Object 
Formats” on page 437 for information about the object fields you may select.

8. Click Next.

9. Complete the export by following Steps 6-13 starting on page 404.
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Export Directory Structure

An example file directory structure of a data set after an export is shown below.

Export.log File

This file is a record of what was exported and where it was saved. It is referred to as 
the Export Log. The first record of the export file is a header that describes the 
format of the records to follow. 

Export_Info.txt File

Each object field exported from CaliberRM is delimited by quotations (“ ”) and the 
text is separated by commas (,) called qualifiers. This file is a record of the type of 
delimiters and qualifiers used during your export. 

Group, ReqType, Requirement, UDA, User .txt files

These files represent the data that was exported for each object. All files do not 
have to be present. 
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RM IMPORT

You may import a project or other objects to a Caliber server by specifying the path 
and name of the import data. This is normally a directory created by RM Export.   

The import data contains object names, not coded data. But the files used for import 
must adhere to a certain format. These formats are detailed in “Appendix C: RM 
Export Object Formats” on page 437. 

When you import certain objects, objects of other types may be created by the 
import utility as needed. The utility attempts to recreate the object as it existed in 
the original data; however, if the data is not available, an appropriate object with the 
correct name is created automatically. For example, if an imported requirement is 
owned by “smith,” the import utility searches the import data for a definition for 
“smith.” If “smith” does not exist, a userid “smith” is created automatically with 
minimal data.

IMPORT USING DATA FROM A TYPICAL CALIBERRM EXPORT

WARNING! BASELINES, DEPARTMENTS AND REQUIREMENT HISTORY ARE 
NOT AVAILABLE FOR AN RM IMPORT.

To import requirements into a project in CaliberRM using data from a previous 
CaliberRM export:

1. Select Start > Programs > CaliberRM > RM Import from your Windows 
workstation. The CaliberRM Logon dialog box is displayed.

Note: The logon window does not display if you are already logged on to 
CaliberRM. Proceed to Step 4.

2. Enter your server Host name, User name and Password.

3. Click Logon. 
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The Caliber Import Utility screen is displayed.

4. Type in the path of the directory that contains the files to be imported, or click 
the Browse button to select the directory containing the data set.

Note: Selecting the Advanced check box allows you to match data in your 
import files to fields in CaliberRM. For example, if user bjones exists in 
Project A, but you want user tjohnson to replace bjones in Project B that you 
are importing to, this feature allows you to replace bjones with tjohnson dur-
ing import. For information on performing an Advanced import, see “Per-
forming an Advanced Import” on page 411.

5. Click Next.
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The Caliber Import Utility-Select Project screen is displayed.

6. Select the Import to existing project option button and select a project from 
the drop-down list, or choose the Import to a new project option button and 
create a new project name.

7. Click Next. The Caliber Import Utility-Importing screen is displayed and 
importing begins. The utility searches and matches all of the project data. 

8. Click the Import button to import the information. The utility imports the data 
as a log file to the data set you selected in Step 4.

9. Click Close.

Note: Importing may be a lengthy process if there is a large amount of data to 
import. Importing should be done during low-use hours to avoid impacting 
other users.
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Performing an Advanced Import

To perform an Advanced import:

1. Select Start > Programs > CaliberRM > RM Import from your Windows 
workstation. The CaliberRM Logon dialog box is displayed.

2. Enter your server Host name, User name and Password.

Note: The logon window does not display if you are already logged on to 
CaliberRM. Proceed to Step 4.

3. Click Logon. The Caliber Import Utility screen is displayed.

4. Navigate to the directory that contains the files to be imported by clicking the 
Browse button.
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5. Select the Advanced check box and click Next. The Select Import File screen 
is displayed.

6. Navigate to the Import file you would like to import by clicking the Browse 
button. This is usually a text file contained in a data set created by using 
RM Export.

7. Select the type of file you are importing from the drop-down list box.

8. Click Next.
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9. If you selected a Requirement import file in Step 7, you are prompted to 
choose a project or create a new project in which you want to import the 
requirements. Make a selection and click Next. 

The Delimiter screen is displayed, and the information is parsed.
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If the text in the information parsing box is not set up as columns as shown 
above, the delimiter and text qualifier do not match those that are specified 
for the import. Set your delimiters and text qualifiers in the file using the 
drop-down list boxes until columns are displayed. If you choose delimiters or 
qualifiers that are not valid, you get an error message.

10. Click Next. 

If you chose to import a User import file in Step 7, go to Step 11.

If you chose to import a Group import file in Step 7, go to Step 14. 

If you chose to import a Requirement, Requirement Type or UDA import 
file in Step 7, go to Step .

11. The Caliber Import Utility - User screen is displayed.

This step allows you to match or replace any users that are members of each 
group. For example, if user jwilson exists in Project A, but you want user 
bjeffereys to replace jwilson in Project B that you are importing to, this 
feature allows you to replace jwilson with bjeffereys during import.
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12. To match or replace a user, select the user you want to match from the left 
panel, then select the replacement user from the right panel and click the Move 
Left button. Complete this step for all users you want to match or replace. 

13. Click Next, and proceed to Step .

14. The Caliber Import Utility - Group screen is displayed.

This step allows you to match or replace any groups that are assigned to your 
projects. For example, if the Administrators group exists in Project A, but 
you want the Engineering group to replace Administrators in Project B that 
you are importing to, this feature allows you to replace Administrators with 
Engineering during import.

15. If you want to match or replace a group, select the group you want to match 
from the left panel, then select the replacement group from the right panel and 
click the Move Left button. Complete this step for all groups you want to 
match or replace. 

16. Click Next.
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The Importing screen is displayed.

The utility searches and matches all of the project data. 

17. Click the Import button to import the information. The utility imports the data 
as a log file to the data set you selected in Step 4.

18. Click Close.

Note: Importing may be a lengthy process if there are is a large amount of 
data to import. Importing should be done during low-use hours to avoid 
impacting other users.
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Import Directory Structure

The original data set that is used during the import process now contains a log file 
called Import.log that contains information about what objects were imported and 
from where. 

An example file directory structure after a CaliberRM data set import is shown 
below:
RM Import � 417





Chapter 27: Project Integrations

This chapter details the steps required to include a vendor add-in to CaliberRM. 

Please visit www.myrequirements.com/caliberrmsdk for sample programs and 
technical documentation on the CaliberRM SDK.

For information on setting up the TestDirector, Select Enterprise, SCC, or Estimate 
Professional integrations, please visit the CaliberRM Customer Zone at 
www.starbase.com/support/logintosupportonline.asp, or contact support.

CALIBERRM VENDOR ADD-IN MODULE

The CaliberRM Vendor Add-In Module allows you to create LiveLink integrations 
between external applications and CaliberRM. 

The add-in module is a registered COM server that acts as a communication bridge 
between the CaliberRM client and an external application. It provides the ability to 
create traces to external objects and view external object information from the 
CaliberRM client.

ADDING A VENDOR ADD-IN MODULE TO CALIBERRM

To add a vendor add-in module:

1. Open Framework Administrator and select a project.
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2. Select the External Traceability tab.

Click the New button. The New Integration dialog box is displayed. 

3. Type in a unique Vendor Name (this name appears on the Traceability 
Modification tab), Library Name (the first word in the COM component’s 
ProgID), Configuration File location and choose an icon.

Note: To browse for the file, click the Browse button. To view the file, click 
the Notepad button.

4. Click OK to create the new integration. 

The new integration is added to the Disabled Integration(s) list for all the 
projects in the CaliberRM database.
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5. To enable the integration, select the integration in the Disabled Integration(s) 
list and click the Move Left button.

Note: You may add all integrations at once by clicking the Move All Left but-
ton.

The images below are examples of a MS Project add-in module. 
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The Add-In menu option appears in the Traceability Modification window.

Click the View Builder button to invoke the add-in server’s view builder.

ENABLING OTHER INTEGRATIONS

Note: Before you can enable and add TestDirector, Select Enterprise, Estimate 
Professional or SCM tools, you must configure your system. For detailed instruc-
tions about configuring and using these integrations, please visit 
www.starbase.com/support/logintosupportonline.asp, or contact support.

1. Open Framework Administrator and select a project.
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2. Select the External Traceability tab.

3. Select the integration you want to enable from the Disabled Integrations list 
and click the Move Left button.

Note: You may add all integrations at once by clicking the Move All Left but-
ton.
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Error Message Meaning

Can't Establish Connection. 
Sorry, your client is 
incompatible with the 
current servers.

The client you are connecting with is out of date with the 
server. Most likely the server has been upgraded and your 
client now needs upgrading.

Invalid user ID or password. Can't log in because the user ID or password is invalid.

User not authorized. The operation failed because the connected user does not 
have the security privileges required for the operation.

No available license. The operation failed because there are no more licenses 
available.

The term could not be 
added, because it already 
exists in the glossary.

You tried to add a term to the glossary that already exists.

The term does not exist in 
the glossary.

You tried to look up a term in the glossary that doesn't exist 
any more. Someone must have deleted it.

The baseline already 
exists.You are trying to 
create a baseline that 
already exist.

You are trying to create a baseline that already exists.

The object requested is 
currently locked by [name]

The specified user has the requirement or other object 
locked. You cannot modify the object until it is released.

You have entered either a 
duplicate or old password.

You've tried to change your password to one that is the 
same as your old password or one of you old passwords.

The password you entered 
is too short.

You've tried to change your password to a password that is 
not long enough. Use a longer password.
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The minimum password 
age has not been met. You 
will not be able to change 
your password now.

You cannot change your password because it is too young.

You do not have permission 
to change your password. 
Please contact your 
CaliberRM administrator.

You cannot change your own password due to security 
settings.

Your CaliberRM account 
has been disabled. Please 
contact your CaliberRM 
Administrator for more 
information.

You cannot log on because your account has been 
disabled.

Your CaliberRM login 
password has expired. You 
will have to choose a new 
password.

You cannot log on because your password has expired.

Your CaliberRM login 
password has to be 
changed in order to login. 
Please contact your 
CaliberRM Administrator for 
more information.

You must change your password before continuing. 

The requirement being 
linked to is linked to another 
requirement. Please 
choose a different 
requirement to link to.

You cannot map to a requirement that is mapped to another 
requirement.

The requirement you are 
trying to delete has other 
requirements linked to it. 
You can't delete a shared 
requirement.

You cannot delete a shared requirement.

Error Message Meaning
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The requirement you are 
modifying is currently 
shared with another 
requirement and cannot be 
shared again.

A requirement can not be mapped to more than one 
requirement.

A child or descendant 
requirement is reserved.

The operation failed because a child or other descendant 
requirement is currently locked.

Requirement type cannot 
be deleted because it 
contains requirements in 
one or more projects.

You cannot delete a requirement type that has 
requirements.

The object is in use. The operation failed because the current requirement or 
other object is in use.

The baseline is locked. The operation failed because the baseline is locked.

The object is locked. The operation failed because the requirement or other 
object is locked.

The object has been moved 
or deleted.

The requirement or other object requested no longer exists.

Warning 
Message Meaning

Your CaliberRM 
license will expire in n 
days.

Your CaliberRM license is about to expire. 

Your CaliberRM login 
password will expire in 
n days. Do you want to 
change it now?

Your password is about to expire. 

The requirement 
version does not exist.

You requested a requirement version that does not exist.

Error Message Meaning
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Depth out of range. The client passed an invalid argument to the server.

Requirement ID 
already used.

The client tried to create a requirement with a duplicate ID.

Invalid list position. The client passed an invalid argument to the server.

General 
Message Meaning

Unknown attribute 
type.

CaliberRM cannot recognize the type of an attribute.

User not logged in. The operation failed because the connected user is not logged in.

Last transaction may 
be incomplete, please 
check your work.

Due to network or server difficulties the last operation did not 
complete. 

Invalid Filter type The server could not understand the request. Contact Borland 
support. 

The database rejected 
a request. 

The database rejected a request. 

The object is not 
reserved.

Your operation failed because the requirement or other object 
was not locked first. 

Unmatched user 
defined type and 
value.

The client sent the server a mismatch of data.

An error has occurred 
in a plug in adapter.

Some error occurred with a plug in adapter.

Caliber Internal Error: 
93-U

Some error unknown to the system has occurred.

Warning 
Message Meaning
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Baseline Custom Tab

Field Name Type Size Field Name Type Size
id_number Number 4 req_type Number 4

baseline_type Text 255 name Text 255

name Text 255

description Text 255 Department
email_addr Text 255 Field Name Type Size
baseline_lock_status Text 255 id_number Number 4

status Integer 2

Custom-Tab UDA Map name Text 255

Field Name Type Size description Memo N/A

req_type_id_
number

Number 4

name Text 255 Discussion
UDA_id_number Number 4 Field Name Type Size

requirement_id Number 4

Document Reference subject Text 255

Field Name Type Size date Date/Time 8

document_
reference

Number 4 user_id Text 255

id_number Number 4 body Memo N/A

file Text 255 depth Number 4

description Memo N/A
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Glossary Group

Field Name Type Size Field Name Type Size

term_name Text 255 id_number Number 4

definition Text 255 group Text 255

Member Project

Field Name Type Size Field Name Type Size

id_number Number 4 id_number Number 4

group Text 255 project_name Text 255

member Text 255 description Memo N/A

email_addr Text 255

ProjectBaselineMap test_director_
integration_enabled

Yes/No 1

Field Name Type Size select_enterprise_
integration_enabled

Yes/No 1

project_id_number Number 4 scm_integration_
enabled

Yes/No 1

baseline_id_
number

Number 4

ProjectGroup-SecurityProfileMap ProjectGroup-SecurityProfileMap

Field Name Type Size Field Name Type Size

group_id Number 4 group_id Number 4

security_profile_id_
number

Number 4 user-id Number 4

project_id_number Number 4
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Requirement Change Requirement Info

Field Name Type Size Field Name Type Size

id_number Number 4 id_number Number 4

revision_index Number 4 name Text 255

field_id Text 255 type Text 255

old_value Memo N/A owner Text 255

new_value Memo N/A status Text 255

priority Text 255

Requirement Revision version Text 255

Field Name Type Size description Memo N/A

id_number Number 4 validation Memo N/A

revision_index Number 4 tag Text 255

index Text 255 hierarchy Text 255

rev_number Text 255 index Number 4

user_name Text 255 name_tag Text 255

date_name Text 255

Requirement Type

RequirementTypeUDA-Map Field Name Type Size

Field Name Type Size id_number Number 4

req_type_id_
number

Number 4 version Number 4

uda_id_number Number 4 name Text 255

description Memo N/A

tag Text 6

id_number Number 4
Field Name � 431



APPENDIX B: EXPORT TO ACCESS TABLES
SecurityProfile SecurityProfile-Requirement Type

Field Name Type Size Field Name Type Size

id_number Number 4 sec_profile_id_number Number 4

name Text 255 req_type_id_number Number 4

description Memo N/A access Text 255

delete Text 255

SecurityProfile-UDA

Field Name Type Size

sec_profile_id_
number

Number 4

req_type_id_
number

Number 4

uda_id_number Number 4

access Text 255

Trace From Trace To

Field Name Type Size Field Name Type Size

trace_from_id_
number

Number 4 trace_to_id_number Number 4

id_number Number 4 id_number Number 4

from_name Text 255 from_name Text 255

suspect Text 255 suspect Text 255
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UDA UDA Boolean Info

Field Name Type Size Field Name Type Size

id_number Number 4 uda_id_number Number 4

name Text 255 presentation_type Text 255

description Memo N/A true_label Text 255

type Text 255 false_label Text 255

causes_version_
change

Yes/No 1 default_value Yes/No 1

inherit_inital_value_
from _parent

Yes/No 1

change_makes_
traceability_links_
suspect

Yes/No 1

UDA Duration Info

system_attribute Yes/No 1 Field Name Type Size

mandatory_set_on
create

Yes/No 1 uda_id_number Number 4

granularity Text 255

UDA Float Info min_value Number 4

Field Name Type Size max_value Number 4

uda_id_number Number 4

min_value Double 4 UDA Group Info

max_value Double 4 Field Name Type Size

default_value Double 4 uda_id_number Number 4

is_expandable_list Yes/No 1

selection_item Number 4

default_value Number 4
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UDA Group List Default Info UDA Group List Selection Info

Field Name Type Size Field Name Type Size

uda_id_number Number 4 uda_id_number Number 4

is_expandable_list Yes/No 1 is_expandable_list Yes/No 1

max_groups_in_list Number 4 max_groups_in_list Number 4

default_item Number 4 selection_item Number 4

UDA Long Info UDA Multiple Selection List Info

Field Name Type Size Field Name Type Size

uda_id_number Number 4 uda_id_number Number 4

min_value Number 4 ordinality Number 4

max_value Number 4 selection_item Text 255

default_value Number 4

UDA Multiple Selection List Default UDA Single Selection List Info

Field Name Type Size Field Name Type Size

uda_id_number Number 4 uda_id_number Number 4

default_item Number 4 presentation_type Text 255

ordinality Number 4

selection_item Text 255

default_item Number 4
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UDA Text Field UDA Text Line

Field Name Type Size Field Name Type Size

uda_id_number Number 4 uda_id_number Number 4

min_length Number 4 min_length Number 4

max_length Number 4 max_length Number 4

num_lines_
displayed

Number 4 input_mask Text 255

default_value Text 255 default_value Text 255

UDA User UDA User List Selection Info

Field Name Type Size Field Name Type Size

uda_id_number Number 4 uda_id_number Number 4

is_expandable_list Yes/No 1 is_expandable_list Yes/No 1

selection_item Number 4 selection_item Number 4

default_item Number 4

UDA Date Info

UDA User List Default Field Name Type Size

Field Name Type Size uda_id_number Number 4

uda_id_number Number 4 min_time Number 4

is_expandable_list Yes/No 1 max_time Number 4

default_value Number 4 default_value Text 255
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UDA Values

Field Name Type Size

UDA_id_number Number 4

min_length Number 4

max_length Number 4

input_mask Text 255

User

Field Name Type Size

id_number Number 4 User Groups

user_id Text 255 Field Name Type Size

first_name Text 255 id_number Number 4

last_name Text 255 name Text 255

email_addr Text 255 description Memo N/A

department Number 4 email_addr Text 255

location Text 255

phone_num Text 255 User-Group Map

fax_num Text 255 Field Name Type Size

pager_num Text 255 user_number Number 4

must_change_
password

Yes/No 1 group _id_number Number 4

can_not_change_
password

Yes/No 1

password_never_
expires

Yes/No 1

account_disabled Yes/No 1
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Each object that is available for export has within it various fields that you may 
choose to further customize your export. Each of these fields correspond to a field 
in CaliberRM. The objects you may select and their respective fields are detailed in 
the following tables.

PROJECT FIELD FORMAT

Field Type
Maximum 

Length 
(characters)

Description

name string 64 the name of the project

description string 10,000 the project description

email_addr string 32 the email address associated 
with the project

groups string 1024 the groups assigned to the 
project

requirement 
types

string 1024 the requirement types assigned 
to the project
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REQUIREMENT FIELD FORMAT

Field Type
Maximum 

Length 
(characters)

Description

order string 9 a sequence number that 
identifies the requirement in the 
import file; not imported, but used 
for establishing traceability

hierarchy string 16 determines the hierarchical 
structure of the requirements

type string 64 the type of the requirement

name string 64 the name of the requirement

description string 10,000 the requirement description

owner string 64 the requirement owner

test_description string 10,000 the validation procedure of the 
requirement

status string 32 the status of the requirement

priority string 32 the priority of the requirement

document 
references

string 1024 document references assigned to 
the requirement

group_member_info string 1024 responsible members from each 
group; has the following format:
group1^user1~user2~|group2^us
er3~user4~

trace_from string 1024 items the requirement traces 
from
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trace_to string 1024 items the requirement traces to

uda_values string 10,000 the values for the user-defined 
attributes assigned-has the 
following format: 
udalabel1:udavalue1|udalabel2:u
davalue2|udalael3:udavalue3

REQUIREMENT TYPE FIELD FORMAT

Field Type
Maximum 

Length 
(characters)

Description

name string 64 the name of the requirement type

description string 10,000 the description of the requirement

tag string 6 the tag associated with the requirement 
type

custom tabs string 1024 the custom tabs assigned to the 
requirement type-has the following format: 
tab1^attribute1~attribute2~attribute3~|tab
2^attribute1~attribute2~attribute3~

REQUIREMENT FIELD FORMAT

Field Type
Maximum 

Length 
(characters)

Description
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USER FIELD FORMAT

Field Type
Maximum 

Length 
(characters)

Description

user_id string 64 the user’s ID

first_name string 64 the user’s first name

last_name string 64 the user’s last name

email_addr string 64 the user’s email address

dept string 64 the user’s department

location string 64 the user’s primary office location

phone_num string 16 the user’s phone number

fax_num string 16 the user’s fax number

pager_num string 16 the user’s pager number

groups string 1024 the groups the user is assigned to-
has the following format: 
group1|group2|group3|

UDA FILE FORMAT

Field Type
Maximum 

Length 
(characters)

Description

name string 64 the name of the UDA

description string 10,000 the UDA description

type string 64 the type of UDA
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* To be properly formatted, this file must be created by an running an export. Borland does not 
advise generating this file by any other method.

causes_version_cha
nge

string 1 indicates whether a change 
creates a new major version; if 
no, displays as a 0 in the text 
file, if yes, displays as a 1

inherit_initial_
value_from_
parent

string 1 indicates whether the 
attribute’s initial value comes 
from parent requirement; if no, 
displays as a 0 in the text file, 
if yes, displays as a 1

change_makes_
traceability links 
_suspect

string 1 indicates whether a change 
makes traceability links 
suspect; if no, displays as a 0 
in the text file, if yes, displays 
as a 1

system_attribute string 1 not used for import

mandatory_set_on_
create

string 1 value required for new 
requirement

type_info string 1024 describes the attributes for 
that type of UDA-format is 
UDA*

UDA FILE FORMAT

Field Type
Maximum 

Length 
(characters)

Description
UDA File Format � 441



APPENDIX C: RM EXPORT OBJECT FORMATS
GROUP FIELD FORMAT

Field Type
Maximum 

Length 
(characters)

Description

name string 64 the name of the group

description string 1024 the group description

email_addr string 64 the email address associated with 
the group

members string 1024 the members of the group formatted 
like: user1|user2|user3|user4
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Appendix D: Document Factory Sample 
Templates and Outputs

SAMPLE TEMPLATES

This appendix contains sample templates with their corresponding output. Most of 
the templates are partial templates to show how a particular command or operator 
works. The generated documents have been edited to display the first entry of the 
generated document due to size restrictions. All of the templates reference the 
sample project called Automated Teller Machine.

Sample Number Template Description

Sample 1, page 444  Full template using many commands.

Sample 2, page 446 Filter example using the logical and with the in comparison

Sample 3, page 448 Filter example using logical and with the between comparison

Sample 4, page 450 Filter example using the like comparison with a wildcard.

Sample 5, page 451 Filter example using the like comparison and the logical or with 
multiple wildcards.

Sample 6, page 453 Shows how to use the <<history>> keyword.

Sample 7, page 455 Shows how to use $Begin_History/$End_History.

Sample 8, page 457 Shows how to use the <<traces>> keyword with default string.

Sample 9, page 458 An example of how to use $Begin_Traces/$End_Traces with a 
specified string of identifiers.

Sample 10, page 460 An example of the $Calculate command.
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SAMPLE 1

$PROJECT{Automated Teller Machine}
Business Requirements
$BEGIN_SECTION
$FILTER{type = ‘Business Requirements’}
$SORT{hierarchy}

<<hierarchy>><<name>> (<<tag>><<id_number>>)
<<description>>
Change History
$BEGIN_HISTORY
Revision <<major_version>>.<<minor_version>> on <<datestamp>> by 

<<user_name>>
$BEGIN_CHANGES
Item Changed:<<field_changed>>
Changed From:<<from_value>>
Changed To:<<to_value>>
$END_CHANGES
$END_HISTORY

Traces
$BEGIN_TRACES (TO_TRACES,DIRECT_TRACES,ALL_OBJECTS)
<<Trace_ReqTag>> <<Trace_Name>> <<Trace_Suspect>> <<Trace_Direction>>
<<Trace_DirectImplied>> 
$END_TRACES
$END_SECTION
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OUTPUT  1

Business Requirements

1 ATM Alerts (BR77)
The ATM shall maintain alerts as to the operating status.

Change History
Revision 1.0 on 11/18/99 by Caliber Administrator
Revision 1.1 on 11/18/99 by Caliber Administrator
Item Changed:Owner
Changed From:admin
Changed To:abaker

Traces
 BR78 Replenishment Alert  TO Direct 
 HS96 ATM Machine  TO Direct 
 SS100 Cash Depletion Rate  TO Direct 
 SS101 Paper Depletion Rate  TO Direct 
 SS102 Status Query  TO Direct 
 SS103 Alert Signal  TO Direct 
 BR79 Tamper Alert  TO Direct 
 SS104 Tamper Signal  TO Direct 
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SAMPLE  2

$PROJECT{Automated Teller Machine}

$BEGIN_SECTION

$FILTER{type = ‘Business Requirements’ and id_number in (89, 
90,92,77)}
<<type>>
<<hierarchy>> <<name>> (<<tag>><<id_number>>)

Owner:<<owner>>          Status:<<status>>              Priority:<<priority>>
Project Version: <<version>>

$END_SECTION
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OUTPUT  2

Business Requirements
1 ATM Alerts (BR77)

Owner:abaker              Status:Submitted                       Priority:High
Project Version: 1.1

Business Requirements
8 Capacity (BR89)

Owner:jandrews              Status:Accepted                       Priority:High
Project Version: 1.1

Business Requirements
9 Deposit Transaction (BR90)

Owner:wpeterson              Status:Accepted                       Priority:Medium
Project Version: 1.1

Business Requirements
10 Transfer Transactions (BR92)

Owner:gjones              Status:Submitted                       Priority:Medium
Project Version: 1.1
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SAMPLE 3

$PROJECT{Automated Teller Machine}

 $BEGIN_SECTION

$FILTER{type = ‘Business Requirements’ and Start Date between #06-01-00# 
and #09-01-00#}

<<hierarchy>> <<name>> (<<tag>><<id_number>>)

Owner:<<owner>>              Status:<<status>>                       Priority:<<priority>>
Project Version: <<version>>

Start Date: <<Start Date>>
$END_SECTION
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OUTPUT  3

2 24x7 (BS80)
Owner:bsmith              Status:Pending                       Priority:High
Project Version: 1.1
Start Date: Monday, August 07, 2000

3 Verify Balance (BS81)
Owner:fsandifer              Status:Deferred                       Priority:Low
Project Version: 1.0
Start Date: Tuesday, August 15, 2000

4 Accessibility (BS82)
Owner:sbowman              Status:Accepted                       Priority:Low
Project Version: 1.1
Start Date: Saturday, July 01, 2000

5 Receipt (BS84)
Owner:wpeterson              Status:Pending                       Priority:High
Project Version: 1.1
Start Date: Thursday, June 29, 2000
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SAMPLE 4

OUTPUT 4

$PROJECT{Automated Teller Machine}
Automated Teller Machine

$Begin_Section
$Filter{type='Business Requirements' and hierarchy like '1' or hierarchy like '1.*'}
$Sort{hierarchy}

<<hierarchy>> <<tag>>     <<name>> 
<<description>>

$End_Section

AUTOMATED TELLER MACHINE

1 BR     ATM Alerts 
The ATM shall maintain alerts as to the operating status.

1.1 BR     Replenishment Alert 
ATMs shall send an alert to the IT department when the ATM needs replenish-
ment. When the ATM has less than a 4 hour supply of cash and receipt paper, 
under normal depletion rates, the ATM will notify the IT department so the appro-
priate service person can be dispatched.

1.1 HW     Power Supply 
There shall be a power supply capable of supporting a 110 volt input and a 3 Amp 
load or 220 volts and a 5 Amp load.

1.2 BR     Tamper Alert 
ATMs shall send an alert to the IT department when the ATM has been tampered 
with. In the event that the ATM is opened without the key and security code, the 
ATM will alert the IT department immediately so the appropriate action can be 
taken.
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SAMPLE 5

$PROJECT{Automated Teller Machine}
$BEGIN_SECTION
$FILTER{Name like ‘*ac*’ or Name like ‘a*a’ or Name like ‘*s’ }
<<type>>
<<hierarchy>> <<name>> (<<tag>><<id_number>>)
Owner: <<owner>>              Status: <<status>>                       
Priority:<<priority>>
Project Version: <<version>>

$END_SECTION
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OUTPUT  5

Business Requirements
1 ATM Alerts (BS77)
Owner: abaker              Status: Submitted                       Priority: High
Project Version: 1.1

Business Requirements
4 Accessibility (BS82)
Owner: sbowman              Status: Accepted                       Priority: Low
Project Version: 1.1

Hardware Requirements
1 ATM Machine (HS96)
Owner: wpeterson              Status: Accepted                       Priority: High
Project Version: 2.1

Software Requirements
11.4 SF Capacity (SS114)
Owner: vcarter              Status: Accepted                       Priority: Medium
Project Version: 1.2

Software Requirements
14 Withdrawal from Account (SS118)
Owner: wpeterson              Status: Submitted                       Priority: Medium
Project Version: 1.1
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SAMPLE 6

$PROJECT{Automated Teller Machine}
$BEGIN_SECTION
$FILTER{type = ‘Business Requirements’}
<<hierarchy>> <<name>> (<<tag>>)
<<history>>
$END_SECTION
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OUTPUT  6

1.1 Replenishment Alert (BS)
Revision #: 1.0  Changed by:admin
Date/Time:Thursday, November 18, 1999 12:56:22 PM
Comment:

Revision #:1.1 Changed by:admin
Date/Time:Thursday, November 18, 1999 02:13:46 PM
Comment:
Owner
From Value: admin
To Value: gjones

Revision #: 1.2 Changed by:admin
Date/Time:Thursday, November 18, 1999 04:37:40 PM
Comment:
Owner
From Value: gjones
To Value: abaker

1.2 Tamper Alert (BS)
Revision #: 1.1 Changed by:admin
Date/Time:Thursday, November 18, 1999 02:13:44 PM
Comment:
Owner
From Value:admin
To Value:jandrews
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SAMPLE 7

$PROJECT{Automated Teller Machine}
ATM BUSINESS REQUIREMENTS
$BEGIN_SECTION
$FILTER{type = ‘Business Requirements’}     
<<name>> (<<tag>>)
$BEGIN_HISTORY
Rev#: <<major_version>>.<<minor_version>> 
Date: <<datestamp>>  Time:<<timestamp>> 
User: <<user_name>>
$BEGIN_CHANGES
Changed Field: <<field_changed>>
From: <<from_value>>
To: <<to_value>>
$END_CHANGES
$END_HISTORY
$END_SECTION
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OUTPUT 7

ATM BUSINESS REQUIREMENTS

Replenishment Alert (BS)
Rev#: 1.0 
Date: 11/18/99  Time: 12:56:22 PM 
User: Caliber Administrator

Rev#: 1.1 
Date: 11/18/99  Time: 02:13:46 PM 
User: Caliber Administrator
Changed Field: Owner
From: admin
To: gjones

Rev#: 1.2 
Date: 11/18/99  Time: 04:37:40 PM 
User: Caliber Administrator
Changed Field: Owner
From: gjones
To: abaker

Tamper Alert (BS)
Rev#: 1.0 
Date: 11/18/99  Time: 12:58:24 PM 
User: Caliber Administrator
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SAMPLE 8

OUTPUT 8

$PROJECT{Automated Teller Machine}
$BEGIN_SECTION
$FILTER{type = ‘Business Requirements’}
<<hierarchy>> <<name>> (<<tag>><<id_number>>)

<<Traces>>
 
$END_SECTION

1.2 Tamper Alert (BS79)

SS103 Alert Signal  Requirement Automated Teller Machine  Direct TO
SS98 Service Mode  Requirement Automated Teller Machine  Direct TO
BS77 ATM Alerts  Requirement Automated Teller Machine  Direct FROM
SS104 Tamper Signal  Requirement Automated Teller Machine  Direct TO

2 24x7 (BS80)

SS98 Service Mode  Requirement Automated Teller Machine  Direct TO
SS102 Status Query  Requirement Automated Teller Machine  Direct TO
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SAMPLE 9

$PROJECT{Automated Teller Machine}
$BEGIN_SECTION
$FILTER{type = 'Business Requirements'}
<<hierarchy>> <<name>> (<<tag>><<id_number>>)
$Begin_Traces 

Requirement Tag: <<Trace_ReqTag>>
Trace Name: <<Trace_Name>> 
Trace ObjectType: <<Trace_ObjectType>>    
Trace_Project: <<Trace_Project>>     
Trace_Suspect: <<Trace_Suspect>>  
Trace_Directimplied: <<Trace_DirectImplied>> 
Trace_Direction: <<Trace_Direction>>

$End_Traces
$END_SECTION
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OUTPUT 9

1.1 Replenishment Alert (BS78)

Requirement Tag: SS99
Trace Name: Replenishment Prediction 
Trace Object Type: Requirement    
Trace Project: Automated Teller Machine     
Trace Suspect:   
Trace Direct/Implied: Direct 
Trace Direction: TO
 
Requirement Tag: SS100
Trace Name: Cash Depletion Rate 
Trace Object Type: Requirement    
Trace Project: Automated Teller Machine     
Trace Suspect:   
Trace Direct/Implied: Direct 
Trace Direction: TO
 

1.2 Tamper Alert (BS79)

Requirement Tag: SS103
Trace Name: Alert Signal 
Trace Object Type: Requirement    
Trace Project: Automated Teller Machine     
Trace Suspect:   
Trace Direct/Implied: Direct 
Trace Direction: TO
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SAMPLE 10

$PROJECT{Automated Teller Machine}
ATM SOFTWARE REQUIREMENTS
$BEGIN_SECTION
$FILTER{type = 'Software Requirements'}
<<hierarchy>> <<name>> (<<tag>><<id_number>>)
Owner:<<owner>>              Status:<<status>>                      Priority:<<priority>>
Project Version: <<version>>
$CALCULATE{Low Effort + Expected Effort as TotalEffort1}
Estimates:
Low Effort:<<Low Effort>> + Expected Effort: <<Expected Effort>> = Total Effort 
<<TotalEffort1>>
$END_SECTION
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OUTPUT 10

ATM SOFTWARE Requirements

1 Service Mode (SS98)
Owner: fsandifer              Status: Submitted                       Priority: Medium
Project Version: 1.1
Estimates: Low Effort:4 + Expected Effort: 5 = Total Effort: 9

2 Replenishment Prediction (SS99)
Owner: jandrews              Status: Accepted                       Priority: Medium
Project Version: 1.1
Estimates: Low Effort:5 + Expected Effort: 9 = Total Effort 14

3 Cash Depletion Rate (SS100)
Owner: amitchell              Status: Accepted                       Priority: Medium
Project Version: 1.1
Estimates: Low Effort:12 + Expected Effort: 15 = Total Effort27

4 Paper Depletion Rate (SS101)
Owner: gjones              Status: Submitted                       Priority: Medium
Project Version: 1.1
Estimates: Low Effort:2 + Expected Effort: 5 = Total Effort 7
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Appendix E:  CaliberRM Diagnostics Tool

The CaliberRM Diagnostic Tool allows you to determine the current configuration 
of your CaliberRM system, such as the status of the server, the status of the 
database and the server owner. This information helps you perform troubleshooting 
to find the cause of any communication problems that may occur when you connect 
to the CaliberRM or Framework Administrator servers. 

Note: Please run the diagnostics check, and have the results available before 
calling Borland’s Product Support. See “Borland Support” on page 7.

DIAGNOSTICS

To run the Diagnostic Tool:

1. From the Windows Start menu, select Programs > CaliberRM > Diagnostic 
Tool. 
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The Caliber Diagnostic Tool dialog box is displayed.

2. In the Host field, enter the name of the server on which you want to perform a 
diagnostic check.

3. Enter your userid and password in the appropriate boxes.

4. Click the Run Diagnostics button.

The diagnostics check begins, and the results are displayed.

You can save the results as a text file by clicking the Save Results button. The 
results can be printed (e.g., through Notepad) before calling Borland support,
emailed to Borland’s Product Support or compared against the results of other tests 
to resolve problems and discrepancies.

5. Click Exit to close the Diagnostics Tool dialog box.
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Glossary

Attributes: Characteristics that help define requirements. For example, all 
requirements contain the attribute “Priority”, indicating the priority of the 
requirement. CaliberRM supports both system and user-defined attributes.

Automatic Notification: A feature of CaliberRM that provides email notification 
to a user that a requirement that he/she is assigned to has changed.

Baseline: A static snapshot of a group of requirements or a project at specific 
versions or a specific point in time.

CaliberRBT: A functional test case design system that helps quality assurance 
teams design and develop the minimum number of test cases that provide the 
maximum test coverage. The result is a more complete testing process, with fuller 
coverage. 

CaliberRM: A collaborative, Internet-based requirements management system that 
enables project teams to deliver higher quality applications that meet end-user 
specifications.

Custom Tabs: A CaliberRM feature that allows a CaliberRM Administrator to 
create and delete custom tabs that contain user-defined attributes.

Custom Tools: A CaliberRM feature that allows the user to create custom tools, 
such as a link to Word, specific to the CaliberRM project. Custom tools can be 
created, given a user-chosen icon and placed at a specific location on the 
CaliberRM toolbar for accessibility.

Enterprise: Generally refers to the entire global organization. In terms of 
CaliberRM security, enterprise level restrictions set the policy for all user accounts. 
User account settings allow you to supersede global settings on specific accounts.

Export/Import Projects: A CaliberRM feature that allows the user to export a 
project from a server into an ASCII file to be imported later into the same or 
another server. The user may also import a project to a server by specifying the 
path/name of the import data from a directory created by the export facility.
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Field Changed Indicator: The indicator represented by an asterisk (*) that is 
displayed next to fields that have been changed for a requirement in CaliberRM.

Framework Administrator: Controls all administrative functions related to 
projects, users, groups, security and automatic notification.

Glossary: A CaliberRM feature that allows the user to create, define and store 
project-specific terms. 

Group: A group is a set of users with similar responsibilities (i.e., Managers, 
Developers, Engineers, Marketing, etc.).

Hierarchical Numbers: These numbers, displayed to the left of the requirement 
name, are dynamic and are determined by the requirement’s placement in the 
requirement list. For example, for each requirement type, there is a requirement 
numbered 1 whose children are numbered 1.1, 1.2 and so on. 

Project: Any application or system under development. Projects consist of several 
layers of information, including users and groups, requirement types and 
requirements. 

Reference Documents: Documents that CaliberRM stores that provide additional 
information for a requirement. Referenced documents may include a specifications 
document, meeting notes, a screen shot or anything else that might be of use in 
defining requirements.

Registered Interest: A CaliberRM feature that gives the user the option to receive 
email notification when a change is made to a requirement to which the user is not 
assigned.

Requirements: Specifications that the application or system being built must meet. 
Requirements can originate from many sources such as business rules, business 
process models, product marketing, prototypes, development meetings and more. 

Requirement ID Numbers: These numbers, also called Serial numbers, are 
displayed to the right of the requirement name. These numbers are static and are 
automatically generated by CaliberRM. Each ID number is unique in the system. If 
a requirement is deleted, that ID number will not be reused. 

Requirement Types: High-level groups of requirements. Requirement types are 
typically classified by their function (i.e., Marketing, Functional, GUI, Software, 
Testing, etc.).
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Select Enterprise: An object modeling tool from Princeton Softech.

Security Profile: Determine access privileges. These profiles are then assigned to 
groups within each project through the Framework Administrator.

Software Configuration Management (SCM): Development tools that track 
changes and provide version control for source code or other file types.

System Attributes: An attribute that CaliberRM automatically assigns to each 
requirement. System attributes that CaliberRM assigns are Priority and Status. 
Users set the values for these attributes to define requirements.

TestDirector: A test planning and management tool from Mercury Interactive.

Test Wizard: A CaliberRM feature that allows the user to create tests for any 
requirement by automating the process of creating tests in TestDirector.

Traceability: CaliberRM supports requirement traceability to allow you to see 
requirement relationships easily. Requirements may trace to or trace from other 
requirements, as well as object modeling and test entities. Suspect links, which 
indicate a change in a requirement that may affect other objects, are shown when a 
requirement is changed.

Unread Discussion Indicator: An indicator in CaliberRM that notifies a user when 
a requirement has a discussion item that has not been read.

Unread Discussion List: A pop-up list in CaliberRM that shows all unread 
discussions, allowing the user to view all requirements in the currently selected 
project that have unread discussions.

Unread Message Indicator: An indicator that notifies the user of an unread 
message on the Discussion tab of a selected requirement or project. The indicator is 
illuminated green when the message has not been read. Once the message has been 
read, the indicator becomes gray.

User-Defined Attributes: An attribute that a user defines and assigns to a custom 
tab in a requirement type. 

User: Any person who has access to and uses CaliberRM or the Framework 
Administrator system. Users can be developers, managers, testers, CEOs and 
others.
Glossary � 467



User Identity: The display of a user’s name and department assignment in a tool 
tip box when the cursor is placed over the user ID in the Framework Administrator 
or CaliberRM.

Validation: Validation procedures help determine how to test the application to 
ensure that the requirements are implemented correctly. 
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